RunRyder RC
 1  Topic Subscribe
WATCH
 1 page 612 views POST REPLY
Scorpion Power Scorpion Power
Helicopter
e-
Align
T-REX 550 › Im lossing power after 45 sec to min and then it comes back
04-06-2011 01:38 AM  6 years agoPost 1
willanyone1

rrApprentice

Griffith, IN U.S.

My Posts: All  Forum  Topic

I was just hovering the 550 today in the drive and after about 1 min it felt like i lost half my power and felt like i was in 3d mode. when i pushed the throttle up it felt and sounded like the motor was at like 30 or 40 percent in 3d mode. I still had pitch but then after 45sec to a min my power came back and then after another 45sec to a min it did it again. Any thoughts

PM  EMAIL  GALLERY  Attn:RR
04-06-2011 01:58 AM  6 years agoPost 2
Heli-on

rrVeteran

Southern Cali, CA - USA

My Posts: All  Forum  Topic

Bad connection on your battery or ESC? I would have immediately landed and felt around for hot spots.

When I first read your post, I thought you did a nitro conversion with a oversized fuel tank.

PM  EMAIL  GALLERY  Attn:RR
04-06-2011 09:09 AM  6 years agoPost 3
OLROY

rrKey Veteran

Wichita Ks

My Posts: All  Forum  Topic

I do believe the esc was hot? Only thing I can think of it would be. Anyone else help trouble shoot this for him.

PM  EMAIL  GALLERY  Attn:RR
04-06-2011 11:25 AM  6 years agoPost 4
Ben-T-Spindle

rrProfessor

Central Illinois

My Posts: All  Forum  Topic

What motor? Some of those stock Align motors only run a short time before they start having problems. A short or bad bearing can cause ESC to shutdown. It could also be a defective ESC. What brand of ESC?

When it shuts down do the servos still work?

... BTS

PM  EMAIL  GALLERY  Attn:RR
04-06-2011 11:30 AM  6 years agoPost 5
alchemist

rrVeteran

Auckland,New Zealand

My Posts: All  Forum  Topic

Motor bearings?

PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR
04-06-2011 11:58 AM  6 years agoPost 6
OLROY

rrKey Veteran

Wichita Ks

My Posts: All  Forum  Topic

It's all stock guys...I'm 90% sure

PM  EMAIL  GALLERY  Attn:RR
04-06-2011 01:13 PM  6 years agoPost 7
willanyone1

rrApprentice

Griffith, IN U.S.

My Posts: All  Forum  Topic

thanx guys its the align 70amp esc and the align 600mx. but it dosent shut down all the way just sounds and feels like i loose half the power. I have full controll of servos.

PM  EMAIL  GALLERY  Attn:RR
04-06-2011 03:00 PM  6 years agoPost 8
alchemist

rrVeteran

Auckland,New Zealand

My Posts: All  Forum  Topic

Bad bearings will cause the motor to draw more amps and ESC to heat up. Check your bearings. Also can you test on 2 seperate batts if you haven't already.

PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR
04-06-2011 10:05 PM  6 years agoPost 9
clive45

rrVeteran

NSW Australia

My Posts: All  Forum  Topic

Is the ESC set to cut power when overheated or shut off power.Sounds like the ESC is over hot and reducing power until the heat disapates then restores full power and so on. Check the ESC is set correctly for your motor etc. All other suggestions already made are possible as well. I had motor heating problems and a small change in the ESC settings cured it. See if you can get a power meter (eagletree etc) and see whats actually happening, then when you change something you can see exactly how it affects the power system otherwise you could be shooting in the dark. I found an Eagletree to be the best money I have spent on electric helis, the logging tell you a lot about your power system.
Hope this helps.

If it cannot fly on it's own, then I won't be much help....

PM  EMAIL  GALLERY  Attn:RR
04-07-2011 12:16 AM  6 years agoPost 10
willanyone1

rrApprentice

Griffith, IN U.S.

My Posts: All  Forum  Topic

thanx again guys i will try to reset a couple settings in the esc first. but flew today and did it again then i put it in 3d mode and it flew perfect just dont understand why its doing that in normal mode.

PM  EMAIL  GALLERY  Attn:RR
04-07-2011 12:32 AM  6 years agoPost 11
clive45

rrVeteran

NSW Australia

My Posts: All  Forum  Topic

If you have the throttle setting % to low in normal mode then the ESC will also overheat, you need to be 80% or above. You might need to change your pinion so you can get that for normal and then just cut back a little to get the idle up settings.
Just a thought..

If it cannot fly on it's own, then I won't be much help....

PM  EMAIL  GALLERY  Attn:RR
04-07-2011 12:37 AM  6 years agoPost 12
Mike0251

rrVeteran

Hills of the Blue Ridge VA

My Posts: All  Forum  Topic

Edited

PM  EMAIL  GALLERY  Attn:RR
04-07-2011 02:43 PM  6 years agoPost 13
willanyone1

rrApprentice

Griffith, IN U.S.

My Posts: All  Forum  Topic

I have the 16 tooth pinon and the stock main gear. I turned up my throttle settings up in normal mode and in 3d im running 80 percent I going to fly in a lil. its only 35 degrees in chicago right now. but the motor esc and battery are not getting to hot. the esc maby gets to 90 or 100 degrees. thank you all for the help I defently needed it. what would i do without RR.

PM  EMAIL  GALLERY  Attn:RR
WATCH
 1 page 612 views POST REPLY
Scorpion Power Scorpion Power
Helicopter
e-
Align
T-REX 550 › Im lossing power after 45 sec to min and then it comes back
 Print TOPIC  Make Suggestion 

 1  Topic Subscribe

Friday, September 22 - 10:52 am - Copyright © 2000-2017 RunRyder   EMAILEnable Cookies

Login Here
 New Subscriptions 
 Buddies Online