RunRyder RC
 1  Topic Subscribe
WATCH
 1 page 1750 views POST REPLY
Scorpion Power Scorpion Power
Helicopter
e-
BEAM
Other › Can't get my blades to track
04-04-2011 07:46 AM  6 years agoPost 1
SurfCity

rrNovice

Roseville, CA

My Posts: All  Forum  Topic

Beam V1. Can't get my blades to track. I'm missing something, but I'm clueless. I've changed everything -- main shaft, feathering shaft, dampers, flybar, blade grips. I've redone every link, checked everything for tightness. I've tried five sets of blades. It's like it's a half-turn off, which of course I can't do. One full turn and the blade's too high; a full turn the other way and it's too low. ALL IDEAS WELCOME. Thanks.

PM  EMAIL  Attn:RR
04-04-2011 08:17 AM  6 years agoPost 2
Pistol Pete

rrProfessor

Seffner, FL

My Posts: All  Forum  Topic

Try swapping the links.

~~Enjoying the hobby one flight at a time~~

PM  EMAIL  HOMEPAGE  GALLERY  BLOGAttn:RR
04-04-2011 03:52 PM  6 years agoPost 3
cdrking

rrElite Veteran

Seattle

My Posts: All  Forum  Topic

Have you tried a different set of blades? I had the same problem a couple of years ago and it was the blades. Have you weighed the blades?

Jeff

To hover is divine, the alternative is rather PLANE.

PM  EMAIL  GALLERY  Attn:RR
04-04-2011 04:22 PM  6 years agoPost 4
SurfCity

rrNovice

Roseville, CA

My Posts: All  Forum  Topic

@Pistol_Pete: I've not only swapped my links, I've replaced every one with new.

@cdrking: I've tried five different sets of blades.

PM  EMAIL  Attn:RR
04-04-2011 04:29 PM  6 years agoPost 5
rnkasp

rrApprentice

Pottstown, PA USA

My Posts: All  Forum  Topic

Why can't you do 1/2 a turn on the link?

PM  EMAIL  GALLERY  Attn:RR
04-04-2011 04:36 PM  6 years agoPost 6
Pistol Pete

rrProfessor

Seffner, FL

My Posts: All  Forum  Topic

New shaft should be checked by rolling on glass looking for a wabble and or visible light under it.

Same for spindle but can be checked mounted by removing one blade and turn screw on spindle and observe other blade for any oscillating movement. Repeat other side.

Last resort since it seems to be a half turn issue, I would remove ball, insert ball link from behind and reset ball with loctite.

If you still have issues, then I would suspect main blade grips, seesaw.

~~Enjoying the hobby one flight at a time~~

PM  EMAIL  HOMEPAGE  GALLERY  BLOGAttn:RR
WATCH
 1 page 1750 views POST REPLY
Scorpion Power Scorpion Power
Helicopter
e-
BEAM
Other › Can't get my blades to track
 Print TOPIC  Make Suggestion 

 1  Topic Subscribe

Tuesday, September 26 - 11:54 am - Copyright © 2000-2017 RunRyder   EMAILEnable Cookies

Login Here
 New Subscriptions 
 Buddies Online