RunRyder RC
 1  Topic Subscribe
WATCH
 1 page 444 views
Scorpion Power Scorpion Power
HelicopterAlignT-REX 600N › Trex 600 3g tail tick
02-19-2011 06:03 PM  6 years agoPost 1
sailorboy898

rrNovice

Salt Lake City, Utah​USA

My Posts: All  Forum  Topic

I did the silicone mod on my 3g and I just bought it a couple of months ago so Im sure its the latest version.
Im using a DS650 for the tail.
I've got every thing dialed in pretty good.
But with my tx gain for the tail at 43 on a dx7 I get a slight tail tick when hovering. I turn the gain down to 37 the the tick is almost gone but while hovering the nose will very slightly drift to the right.
Do I need to add some delay to 3g gyro or will that make it worse.
My head speed is around 2100.
Any thoughts?

PM  EMAIL  GALLERY  Attn:RR  Quote
02-20-2011 02:50 PM  6 years agoPost 2
Dino Spadaccini

rrElite Veteran

USA

My Posts: All  Forum  Topic

try the delay i see the same thing on my 700 make sure you have the 3g sensor strapped down tight

i also found my boom supports are loose at the ends after about 100 flight will change them out to the new style that are pin-less

RIP Roman JR
Capt USA Align Factory Team Align - Conquer Your heart
Team Futaba

PM  EMAIL  GALLERY  Attn:RR  Quote
02-20-2011 09:00 PM  6 years agoPost 3
Dino Spadaccini

rrElite Veteran

USA

My Posts: All  Forum  Topic

Found that my tail boom support ends where loose this could have been part of the problem along with a rough main shaft bearing i did have a small crash a few weeks back and never looked at these two things

RIP Roman JR
Capt USA Align Factory Team Align - Conquer Your heart
Team Futaba

PM  EMAIL  GALLERY  Attn:RR  Quote
WATCH
 1 page 444 views
Scorpion Power Scorpion Power
HelicopterAlignT-REX 600N › Trex 600 3g tail tick
 Print TOPIC  Make Suggestion 

 1  Topic Subscribe

Tuesday, November 21 - 12:14 pm - Copyright © 2000-2017 RunRyder   EMAILEnable Cookies

Login Here
 New Subscriptions 
 Buddies Online