RunRyder RC
 1  Topic Subscribe
WATCH
 1 page 499 views
Scorpion Power Scorpion Power
HelicopterRadio - Servo - Gyro - Gov - Batt › Need help with a new tail servo that's acting​strange
02-17-2011 09:53 PM  6 years agoPost 1
Supertoyz

rrApprentice

Colchester, VT

My Posts: All  Forum  Topic

I'm building a Fusion 50 with an Outrage 9188 Tail servo. When I assembled the tail I checked the operation and it was silky smooth. I finished electronics installation last night and centered all of my servo's, installed horns and began setting up the travel adjust of my tail. Right away I noticed a horrible grating noise coming from the tail. When I move the rudder the tail blades begin to resonate in the grips, at first it looked like the slider was grinding along the output shaft or the pushrod was grinding in it's guides. I loosened the guides to allow them to float around the pushrod, it made no difference. I then disconneced the pushrod from the servo and ran the tail mechanism manually, smooth as silk. I put my finger on the servo horn and ran the rudder stick, it felt like the servo was full of sand. I shut it down and turned the servo wheel manually, it was super smooth feeling. Becuase of this I think mechanically the servo is fine, it seems like it's getting a signal from the FBL unit or the Radio causing it to shudder very quickly as it moves. The shudder is transmitted down the pushrod through the tail mechanism and out through the tips of the chattering tail blades . I'm using a DX8 and Helicommand HC3SX. I double checked the FBL setup menu and I've got digital selected for the Cyclic servos and 760 selected for the tail. The tail servo options are (Analog-Digital-760). According to the specs the servo is a 760 and is what I've selected.

Here's the specs:
Voltage: 8.4
Speed (60 degrees): .034
Torque (ozin): 83.28
Torque (kgcm): 6.0

Any idea's? Is this how the new high speed servo's are supposed to act?

PM  EMAIL  GALLERY  Attn:RR  Quote
WATCH
 1 page 499 views
Scorpion Power Scorpion Power
HelicopterRadio - Servo - Gyro - Gov - Batt › Need help with a new tail servo that's acting​strange
 Print TOPIC  Make Suggestion 

 1  Topic Subscribe

Tuesday, November 21 - 11:21 pm - Copyright © 2000-2017 RunRyder   EMAILEnable Cookies

Login Here
 New Subscriptions 
 Buddies Online