RunRyder RC
 4  Topic Subscribe
WATCH
 1 page 821 views
Scorpion Power Scorpion Power
02-15-2011 01:22 AM  6 years agoPost 1
skyy01

rrNovice

nicholasville, ky

My Posts: All  Forum  Topic

hey guys, got my rad in the air this past weekend, all was well until I hit full collective, then dropped the collective back down, seemed as if the motor just stopped for a brief second, the started right back up, I dont feel this is an ignition issue, if it was wouldnt it do this all the time>?? any help on this matter would be appreciated much.

Brian fast by gas!!

PM  EMAIL  GALLERY  Attn:RR  Quote
02-15-2011 02:08 AM  6 years agoPost 2
James Kovach

rrKey Veteran

canton, oh - US

My Posts: All  Forum  Topic

Sure the head is not binding?

*disclaimer: These are my opinions. Agree or disagree, Your Call :)
Let'r Rip Tator Chip

PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
02-15-2011 10:16 AM  6 years agoPost 3
skyy01

rrNovice

nicholasville, ky

My Posts: All  Forum  Topic

radikal g20 stall

as far as we can tell no the head is not binding, it does have the vbar and century flybarless head

Brian fast by gas!!

PM  EMAIL  GALLERY  Attn:RR  Quote
02-15-2011 01:21 PM  6 years agoPost 4
BlakeMcBrayer

rrElite Veteran

Georgetown, Ky

My Posts: All  Forum  Topic

I just thought I'd offer a little more info on SKY001's heli. I helped him finish the build and set up the V-Bar. The V-Bar is spot on and there is no binding in the head. We also made sure that the elevator arms are not hitting the main gear.

Anyway, around the fourth flight on the Zenoha, we started doing a full collective climbsouts and loops. Govenor function has not been enabled yet, so it's flying on curves.

Sometimes when the head was unloaded the engine would miss or stall out for a second. This would happen at the top of the climbout or the top of a loop when collective was reduced to zero and the throttle was at it's lowest point of the curve.

The engine is still in need of some tuning, but running alright. I'm assuming that this engine stumble is just a tuning issue, but being new to gassers, I'm not certain of waht this issue typically means.

I'm thinking that it's more of a low needle adjustment since it only does this when transitioning on and off of the low needle.

Any input would be great.

Blake McBrayer
Fromeco Factory Rep

Don't come off the throttle untill you see your GOD!

PM  EMAIL  GALLERY  Attn:RR  Quote
02-15-2011 01:50 PM  6 years agoPost 5
crazzyjoe

rrVeteran

Grande Prairie​Alberta (Where it's​very slipp

My Posts: All  Forum  Topic

Hi,

I had the same problem on my 231 in my Predy last summer after I put a Torpedo muffler on it and what I found is that the engine was to rich, I leaned out the Low needle and the problem is gone.

I'm NOT saying this is your problem but it's something you can try if you like.

Joe

PM  EMAIL  GALLERY  Attn:RR  Quote
02-15-2011 02:32 PM  6 years agoPost 6
Zman

rrKey Veteran

Florida

My Posts: All  Forum  Topic

Blake,

Sounds like you are spot on in your thinking. The 20, in particular, will do what you described if the needles arent dialed in. As joe mentioned, I would start with the low, most likely will cure the problem. I seen this same behaviour on several 20's.

Now, not to complicate things as above is the problem you are describing but be aware that some of these walbro's like to keep an air bubble in them on first flight and as soon as you go inverted, it will hiccup for a split second. It usually occurs on very first flight of day and subsequent flights afterwards are without incident. But the climbouts with hiccup at reduced throttle is the needles.

Mike

PM  EMAIL  GALLERY  Attn:RR  Quote
02-15-2011 03:58 PM  6 years agoPost 7
Billme

rrElite Veteran

MS

My Posts: All  Forum  Topic

If you are running the stock pickup in the fuel tank, it can do this...Run the felt clunk to eliminate air....

PM  EMAIL  GALLERY  Attn:RR  Quote
02-15-2011 10:35 PM  6 years agoPost 8
skyy01

rrNovice

nicholasville, ky

My Posts: All  Forum  Topic

rad stall

hey bill, no im runing the felt one, not the stock one, guys thanks for the advice, hopefully we will find what the issue is and ill report back our findings

Brian fast by gas!!

PM  EMAIL  GALLERY  Attn:RR  Quote
02-16-2011 12:42 AM  6 years agoPost 9
MAXHSHV

rrKey Veteran

,mn usa

My Posts: All  Forum  Topic

My 231 will do this if it's to lean on the needles especially if the motor isn't good and warm.try adjusting first the low needle till it just starts to gurgle at idle then open up the high needle a bit at a time and see if that helps.this fixed my 231 that was doing the same thing.

Century heli rep. To much power is never enough.

PM  EMAIL  GALLERY  Attn:RR  Quote
02-16-2011 04:14 AM  6 years agoPost 10
James Kovach

rrKey Veteran

canton, oh - US

My Posts: All  Forum  Topic

I misread what you had posted. I thought it was "stalling" when you put in full collective. Not when you let off it. These guys are on the right track. I would say it is your low needle as well.

*disclaimer: These are my opinions. Agree or disagree, Your Call :)
Let'r Rip Tator Chip

PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
WATCH
 1 page 821 views
Scorpion Power Scorpion Power
 Print TOPIC  Make Suggestion 

 4  Topic Subscribe

Thursday, November 23 - 5:44 am - Copyright © 2000-2017 RunRyder   EMAILEnable Cookies

Login Here
 New Subscriptions 
 Buddies Online