RunRyder RC
 0  Topic Subscribe
WATCH
 1 page 669 views
HelicopterKyosho Caliber/Quest Neo-Caliber series › Nexus 30 problem......
09-07-2003 01:22 AM  14 years agoPost 1
Nate7357

rrApprentice

Brooklyn, NY

My Posts: All  Forum  Topic

Today i was flying my nexus for about 45 minutes (around 4 tanks). I noticed that the engne and muffler were getting really hot, so I let the heli rest for 10-15 minutes. After eveything was cooled down i went to restart it, but i encounterd some problems. When i try to start the heli with the electric starter the main blades would spin everytime i attemted to start it.(when the engine is not running) I havent crashed the heli, and nothing has changed .Any idea what it may be ?

PM  EMAIL  GALLERY  Attn:RR  Quote
09-07-2003 02:50 AM  14 years agoPost 2
BladeRunner

rrElite Veteran

Ontario Canada. Member of "some sort" s

My Posts: All  Forum  Topic

Sounds like the clutch shoes (actually the bolts that hold them in place)....a common problem with the Nexus. Once the liner wears down to a certain point the shoes will "overextend" and this stresses and weakens the bolts and the shoe(s) will drop and lock the assembly. Remove the engine (very simple on the Nexus) and check the shoes~bolts.........

PM  EMAIL  GALLERY  Attn:RR  Quote
WATCH
 1 page 669 views
HelicopterKyosho Caliber/Quest Neo-Caliber series › Nexus 30 problem......
 Print TOPIC  Make Suggestion 

 0  Topic Subscribe

Friday, December 15 - 11:52 pm - Copyright © 2000-2017 RunRyder   EMAILEnable Cookies

Login Here
 New Subscriptions 
 Buddies Online