RunRyder RC
 1  Topic Subscribe
WATCH
 1 page 530 views
HelicopterMain Discussion › Weird Gyro/Servo problem
09-06-2003 06:41 AM  14 years agoPost 1
vipul

rrNovice

New Jersey

My Posts: All  Forum  Topic

Guys,

I wanted to check if anyone has had this problem before. I have a Raptor 30 v2 with the JR 460T servo. I have been flying it for about a month with absolutely no problems with a normail hitec ball bearing servo on the tail.

Just last week, I decided to upgrade the rudder servo to a JR 810G digital tail servo. I thought since it had a claimed .10 transit time, it would really be great for the tail. However, I notice that on certain occasions when the raptor is about to make a turn, the tail rotor response in one direction is eeexxxtttreeemly slow, the other direction seems fine. So I checked out the gain (set it to around 56% and I am flying heading lock mode). I put the rappy in hover and pirouette in both directions and it seems fine. The rappy flies fine for a couple more flights. Then today, I take it up and turn it and the basically stalls there in the turn and unfortunately since it was a tight turn , the heli crashes :-(

So now, I am wondering whether I should replace the servo or gyro or what. I know I know, I have been advised by a lot of heli pilots to get a Futaba 401 but since I have already spent over $200 on this gyro and servo, I would rather find a better solution than to toss these out and get the 401.

By the way I am running a futaba 9 channel PCM receiver. Anyhow, if anyone has experienced this problem please let me know. The funny part about it is that in hover, the heli pirouettes fine in both directions, its only when I put it in forward flight and turn it that it starts misbehaving.

Any help would be appreciated. Thanks.

-Vipul

PM  EMAIL  Attn:RR  Quote
09-06-2003 10:08 PM  14 years agoPost 2
pchuckie

rrVeteran

Pemberton TWP, NJ

My Posts: All  Forum  Topic

Just crashed my rap 50 the other day , using a 460 and 4735. The 460 is garbage. I had to send in my 410/9253 for repair and thought I would get some flying in with my old 460. From a hover it just piroed and would't stop. I threw the 460 in the trash, could never get the 460 to work, it worked ok when i had a 30 and wasn't flying backwards.

PM  EMAIL  GALLERY  Attn:RR  Quote
WATCH
 1 page 530 views
HelicopterMain Discussion › Weird Gyro/Servo problem
 Print TOPIC  Make Suggestion 

 1  Topic Subscribe

Saturday, December 16 - 4:41 pm - Copyright © 2000-2017 RunRyder   EMAILEnable Cookies

Login Here
 New Subscriptions 
 Buddies Online