RunRyder RC
 14  Topic Subscribe
WATCH
 7 pages [ <<    <    ( 1 )     2      3     NEXT    >> ] 15509 views POST REPLY
Scorpion Power ProModeler
10-10-2010 08:19 PM  6 years agoPost 1
stevendavis

Senior Heliman

Ashton, Id

My Posts: All  Forum  Topic

I picked up my first glow driven heli. Its a Concept 30 that is new, never flown. I've finished building it and got it fired up, but had a few issues. I've installed an Align 600 tail pitch slider and grips. 600 tail servo mount and rod guides. And a Zeal aluminum clutch bell. I'm still looking for spare parts and I'm going to try and put as many Align parts on as I can in the future. I was suprized to find that the tail slider and grips were a perfect fit. I think the Main Blade grips will work also. Here are a few photos.

PM  EMAIL  GALLERY  Attn:RR
10-10-2010 08:31 PM  6 years agoPost 2
kcordell

Elite Veteran

O Fallon, MO

My Posts: All  Forum  Topic

I hope you don't have the original foam blades on it.

Team Futaba, Team Synergy/Rail, Team Scorpion, Team Castle Creations, YS Engines, VelTye

PM  EMAIL  GALLERY  Attn:RR
10-10-2010 08:56 PM  6 years agoPost 3
stevendavis

Senior Heliman

Ashton, Id

My Posts: All  Forum  Topic

Blades

They are stock blades. They look like woodies to me. How can you tell?

PM  EMAIL  GALLERY  Attn:RR
10-10-2010 09:10 PM  6 years agoPost 4
kcordell

Elite Veteran

O Fallon, MO

My Posts: All  Forum  Topic

I don't think you have one of the original 30 DX's. They had heavy metal flybar paddles and foam blades, real easy to distinguish from wood, and the decal set was red. Is the canopy pointed a bit in front? If so it is probably a Concept 30 SX.

Team Futaba, Team Synergy/Rail, Team Scorpion, Team Castle Creations, YS Engines, VelTye

PM  EMAIL  GALLERY  Attn:RR
10-10-2010 09:31 PM  6 years agoPost 5
Jonty

Veteran

Wellywood

My Posts: All  Forum  Topic

Does that have z bends on the servo horns??

PM  EMAIL  GALLERY  Attn:RR
10-10-2010 09:31 PM  6 years agoPost 6
DOKEY

rrProfessor

Northamptonshire UK

My Posts: All  Forum  Topic

The canopy in the pictures is the Concept SRX one, so I guess its a SRX.
The blades there are not the foamie ones, they are wooden.

I also think the previous SR edition had the different radio tray to the SRX.
Plus larger tank on SRX

PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR
10-10-2010 10:05 PM  6 years agoPost 7
dchekas

Key Veteran

Farmington, CT

My Posts: All  Forum  Topic

My buddy has a TON of concept 30 parts. PM me if you're interested.

Team Align, Team Futaba, Team Byron Fuels, Team Thunder Power

PM  EMAIL  GALLERY  Attn:RR
10-10-2010 10:57 PM  6 years agoPost 8
stevendavis

Senior Heliman

Ashton, Id

My Posts: All  Forum  Topic

The heli is the SR-X. It does still have the Z-bend rods on the servos. I'm planning on switching them out as I get them. I know Z-bend is not the best. It works good for now and every thing is bind free, but I am going to change them out soon.

PM  EMAIL  GALLERY  Attn:RR
10-10-2010 11:02 PM  6 years agoPost 9
stevendavis

Senior Heliman

Ashton, Id

My Posts: All  Forum  Topic

Here is the photo.

PM  EMAIL  GALLERY  Attn:RR
10-13-2010 02:38 PM  6 years agoPost 10
stevendavis

Senior Heliman

Ashton, Id

My Posts: All  Forum  Topic

First Few Tanks

I took it out yesterday and put two tanks through it just hovering and trimming. I think I've about got the engine tuned. I'm only running about 50% on the throtle cure, or the engine seems to run away. Is this normal for a glow unit? I'm used to electric. Also the head shakes real bad if the head speed is too high. I think this might be do to the soft dampners. The pitch also seems a bit mushy. I think I'm running about +8 on normal mode, but it feels prety soft compared to my Trex 450. The tail also vibrates. I think I'm going to try and install some tail braces. Do most of you add tail braces? Other than that, every thing worked great.

PM  EMAIL  GALLERY  Attn:RR
10-13-2010 06:28 PM  6 years agoPost 11
stevendavis

Senior Heliman

Ashton, Id

My Posts: All  Forum  Topic

Just did some checking on my setup and found where the shake was coming from. I had one blade going to +5* full pitch and the other was going to +9* full pitch. I've got them both at +8* full up and -7* full down. This should make a BIG differance.

PM  EMAIL  GALLERY  Attn:RR
10-13-2010 06:45 PM  6 years agoPost 12
greenboot

Veteran

Marblehead, OH

My Posts: All  Forum  Topic

The Z-bends work fine on my Concepts for years. But it shouldn't be shaking. If the blade tracking doesn't help, something is bent or out of balance.

Tom

PM  EMAIL  Attn:RR
10-13-2010 11:16 PM  6 years agoPost 13
airdodger

Elite Veteran

Johnston USA

My Posts: All  Forum  Topic

If you had that big a difference in pitch you did not track the blades.

Chris

PM  EMAIL  GALLERY  Attn:RR
10-14-2010 03:05 AM  6 years agoPost 14
stevendavis

Senior Heliman

Ashton, Id

My Posts: All  Forum  Topic

I took it out and flew it today. I could not see any tracking issues today. It flys slower than I'm used to and its very stable. I still don't know if I'm setting the throtle curve right. I'm only using about half of what is available for peak power.

PM  EMAIL  GALLERY  Attn:RR
10-14-2010 07:26 AM  6 years agoPost 15
balbs

Key Veteran

Los Angeles, CA

My Posts: All  Forum  Topic

Sweet SRX man! Nice that you also have the Zeal metal frame. I have the SRX as well including most of the metal Zeal bits. Check out my gallery. Interesting that you used some Align parts as replacements. Gotta take a note of that.

PM  EMAIL  GALLERY  Attn:RR
10-14-2010 01:45 PM  6 years agoPost 16
stevendavis

Senior Heliman

Ashton, Id

My Posts: All  Forum  Topic

Cool helis balbs,
I see you even have the flapping head. I'm still in serch of that elusive Zeal 6mm hex starter adaptor.

PM  EMAIL  GALLERY  Attn:RR
10-15-2010 01:55 PM  6 years agoPost 17
stevendavis

Senior Heliman

Ashton, Id

My Posts: All  Forum  Topic

Put 3 more flights on it yesterday and the blade tracking was still off just a bit. I"ve got them running true now though. I had a buddy tach it last time out and he had his tach set on a one blader, so the reading was way high. I re-tached yesterday with mine and I'm running about 1600 on the head speed and the motor has cleaned up a bit now that I can run the trotle up where its supposed to be. Pitch feels a lot better also. I installed some dual ball links on the aileron and pitch servos, but I can't find any long enough to replace the elevator rods. Heli's flyin much better now.

PM  EMAIL  GALLERY  Attn:RR
10-15-2010 08:57 PM  6 years agoPost 18
stevendavis

Senior Heliman

Ashton, Id

My Posts: All  Forum  Topic

Tail Wag

I also still have some tail wag. I'm running a chinese gyro, 401 type, and have it in HH mode. If I switch to AVCS will it help prevent the wag?

PM  EMAIL  GALLERY  Attn:RR
10-16-2010 01:56 AM  6 years agoPost 19
balbs

Key Veteran

Los Angeles, CA

My Posts: All  Forum  Topic

Did you balance the tail blades? Also, make sure that the center shaft guide in the boom is not at the center. It has to be a little closer to one of the other ends.

PM  EMAIL  GALLERY  Attn:RR
10-16-2010 05:52 PM  6 years agoPost 20
stevendavis

Senior Heliman

Ashton, Id

My Posts: All  Forum  Topic

Thanks, I'll have to pull the tail boom and check it out.

PM  EMAIL  GALLERY  Attn:RR
WATCH
 7 pages [ <<    <    ( 1 )     2      3     NEXT    >> ] 15509 views POST REPLY
Scorpion Power ProModeler
 Print TOPIC  Make Suggestion 

 14  Topic Subscribe

Friday, July 21 - 9:36 pm - Copyright © 2000-2017 RunRyder   EMAILEnable Cookies

Login Here
 New Subscriptions 
 Buddies Online