RunRyder RC
 1  Topic Subscribe
WATCH
 1 page 986 views POST REPLY
Scorpion Power Scorpion Power
HelicopterThunder TigerRAPTOR 50 › 53 tt does not start
06-06-2010 05:15 AM  7 years agoPost 1
bec123

rrApprentice

regina, sask. canada

My Posts: All  Forum  Topic

Hello
I have been flying the raptor 50se with the tt53. Engine has been running well. Today after 1 flight it did not want to start,,,so I changed glow plug and still does not want to start but what I did notice was that when I used the starter fuel came out of the muffler as long as I kept it spinning fuel kept coming out and still did not start or even fire...I have a 2 in 1 and the glow part showed orange and red or the 2 colors that showed the plug was getting current...Any ideas...I checked the High needle setting and it was 3.5 turns out and was working good at this setting.....thanks in advance

bec

PM  EMAIL  Attn:RR  Quote
06-06-2010 05:25 AM  7 years agoPost 2
RaptorMan23

rrKey Veteran

Sioux City, IA

My Posts: All  Forum  Topic

If fuel was coming out of your muffler then that means your flooding it

when that happens, you need to take the plug out, hold the heli by the tail with the nose facing down, and then spin it over with the starter for awhile

If you only have to bend over once to pick it up it's a good landing.

PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
06-06-2010 05:36 AM  7 years agoPost 3
dcbusdriver

rrApprentice

Stephens City,VA -USA

My Posts: All  Forum  Topic

I have align 2in1 on my 53 as well. Sometimes even though you're getting the lights I guess the contact is not good. Try wiggling/reseating the glow clip and see if it starts. I have done the same thing where it won't even fire and I give the clip a wiggle and it fires right up. Hope that's all it is.

beating the air into submission...........cool!

PM  EMAIL  GALLERY  Attn:RR  Quote
06-06-2010 06:03 AM  7 years agoPost 4
Richie Sabin

rrApprentice

Niagara Falls, NY

My Posts: All  Forum  Topic

3 1/2 turns out is a bit extreme. When i broke in my 53 i started a hair under 3 turns out and worked in from there. 3 and half is too rich which is why fuel is coming out of the muffler. Lean it out a little

Rich Sabin
Team Align
Team Thunder Power
Morgan Fuels
Hatori Mufflers

PM  EMAIL  GALLERY  Attn:RR  Quote
06-06-2010 02:38 PM  7 years agoPost 5
bec123

rrApprentice

regina, sask. canada

My Posts: All  Forum  Topic

53 tt does not start

Hello All
Thanks for the quick responses.....It does seem to make sense being overly rich. I am sure that 3.5 turns out was were it ran great....but I am going to lean it in to 2.75 or 3 and see what happens...I maybe had a brain fart and turned it out for some reasons and don't remember...hmmmm I wonder what will happen if I stick a finger in the blades casue they look like there going slow.... again thanks for the quick responses...I will be heading out flying in a few hours and will post the results'''

bec

PM  EMAIL  Attn:RR  Quote
06-06-2010 10:10 PM  7 years agoPost 6
RaptorMan23

rrKey Veteran

Sioux City, IA

My Posts: All  Forum  Topic

...hmmmm I wonder what will happen if I stick a finger in the blades casue they look like there going slow....

If you only have to bend over once to pick it up it's a good landing.

PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
06-10-2010 06:19 AM  7 years agoPost 7
bec123

rrApprentice

regina, sask. canada

My Posts: All  Forum  Topic

53 tt does not start

Hello All
Had it out the other day and same issue. When trying to start fuel flows out of the muffler.. I did unhook fuel line and start engine and it sounded good and when it started to rev up and run out of fuel I re hooked up the fuel line and it just flooded it self and stopped. My next fix will be to remove engine and check if any screws are loose or if carburater is loose ect....any thoughts appreciated..

bec

PM  EMAIL  Attn:RR  Quote
06-10-2010 06:21 AM  7 years agoPost 8
bec123

rrApprentice

regina, sask. canada

My Posts: All  Forum  Topic

53 tt does not start

hello raptorman

that does apppear to be how I act when brain farts take over....thanks for the lol

bec

PM  EMAIL  Attn:RR  Quote
06-10-2010 06:29 AM  7 years agoPost 9
Richie Sabin

rrApprentice

Niagara Falls, NY

My Posts: All  Forum  Topic

Check the hidden needle inside the carb arm make sure that didnt back out any or fall out completely

Rich Sabin
Team Align
Team Thunder Power
Morgan Fuels
Hatori Mufflers

PM  EMAIL  GALLERY  Attn:RR  Quote
06-10-2010 08:36 PM  7 years agoPost 10
RojoalfarrApprentice - Punta de Mata, Monagas-Venezuela - My Posts: All  Forum  Topic

Bad connector...

/
/

Check B6T black ground cable... the black cable in most of the cases, loses from the O-connector that goes to motor base´s bolt. Use a soldering gun to fix it.
It is probably you have a intermitent conection with this cable...

/

Saludos cordiales,

PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
06-18-2010 03:10 AM  7 years agoPost 11
bec123

rrApprentice

regina, sask. canada

My Posts: All  Forum  Topic

53 tt does not start

Hello All
While I was able to try the engine again....no luck to get it to run long......changed plugs no go.....yesterday I turned the high speed in all the way and it started and as it started to lean out I opened the needle and got to about 1 turn out on High but it was still spewing fuel out the muffler.....I took the engine out and all looks good..I may have to check the hidden needle like iceman suggested as I did look and measure distance between spray bars and it is 1.5mm and as I understand it should be 1mm...would this make that much of a difference.....any thoughts.....I sent an email to heliproz for directions as this may just be a warrenty issue.....anyways thanks in advance

bec

PM  EMAIL  Attn:RR  Quote
06-18-2010 03:36 AM  7 years agoPost 12
GREYEAGLE

rrElite Veteran

Flat Land's

My Posts: All  Forum  Topic

What the heck is that thing with all the wire's. ???

Is that part of the Nitro motor that won't start ???

If it is -- toss it over your shoulder and stick a regular glow ignitor on it .

That does' not look like it does any thing to make it easy and convenient and reliable.

When it doubt - toss it out -

greyeagle

PM  EMAIL  GALLERY  Attn:RR  Quote
06-18-2010 01:02 PM  7 years agoPost 13
Gary H

rrVeteran

Minnesota USA

My Posts: All  Forum  Topic

I agree with Greyeagle,get something u can count on!!!

Gary H

PM  EMAIL  GALLERY  Attn:RR  Quote
06-18-2010 08:09 PM  7 years agoPost 14
Rojoalfa

rrApprentice

Punta de Mata, Monagas-Venezuela

My Posts: All  Forum  Topic

clunk line...

/
/

No glow plug...
No B6T spark ignitor..
No carburator...
No fuel line...

Something related to feeding fuel...

Check clunk line carefully... maybe fuel line is broken inside glow tank...

/

Saludos cordiales,

PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
08-22-2010 07:12 AM  7 years agoPost 15
bec123

rrApprentice

regina, sask. canada

My Posts: All  Forum  Topic

53 tt does not start

Hello all
just an update,,,, it was the hidden needle and blue lock tight and back in buisness...I was using some rotortech 620's on this heli for a bit and I sure liked how this engine and heli responded,,,,I ordered and got the 600 rotortechs as a sub for cy 600's not sure if i like these as much as the 620's but my radikal g20 needed them back..thanks for responses

bec

PM  EMAIL  Attn:RR  Quote
08-22-2010 05:16 PM  7 years agoPost 16
Gary H

rrVeteran

Minnesota USA

My Posts: All  Forum  Topic

Try some SAB`s u will like then even more!

Gary H

PM  EMAIL  GALLERY  Attn:RR  Quote
WATCH
 1 page 986 views POST REPLY
Scorpion Power Scorpion Power
HelicopterThunder TigerRAPTOR 50 › 53 tt does not start
 Print TOPIC  Make Suggestion 

 1  Topic Subscribe

Thursday, October 19 - 12:05 pm - Copyright © 2000-2017 RunRyder   EMAILEnable Cookies

Login Here
 New Subscriptions 
 Buddies Online