RunRyder RC
 1  Topic Subscribe
WATCH
 1 page 478 views POST REPLY
Scorpion Power Scorpion Power
HelicopterRadio - Servo - Gyro - Gov - Batt › Spartan setup with BLS251
12-31-2009 04:42 PM  7 years agoPost 1
Helijockey

rrKey Veteran

150 miles from somewhere

My Posts: All  Forum  Topic

Just did the setup of my new spartan/BLS251. As the manual suggests I didn't connect the servo till I had chosen the servo type. In this case it meant two flashes of the light. When I did connect the servo it went crazy and the servo arm spun really fast clockwise and then anti clockwise. I disconnected the servo and lowered the gain from 100 to 73 and it was ok. It didn't act up again and was fine during the rest of the setup. I even tested it on the bench later and it's fine. Also I had not put the link on the servo arm so it was totally free when it acted up. Do u guys think it's ok to fly with this servo?

PM  EMAIL  Attn:RR  Quote
12-31-2009 06:19 PM  7 years agoPost 2
rapidity

rrVeteran

ohio

My Posts: All  Forum  Topic

If I remember right that's how it signifys a mode change while setting up. I think you should be all right.

PM  EMAIL  GALLERY  Attn:RR  Quote
12-31-2009 07:23 PM  7 years agoPost 3
Helijockey

rrKey Veteran

150 miles from somewhere

My Posts: All  Forum  Topic

U r right but does it do that as soon as u plug in the servo?

PM  EMAIL  Attn:RR  Quote
WATCH
 1 page 478 views POST REPLY
Scorpion Power Scorpion Power
HelicopterRadio - Servo - Gyro - Gov - Batt › Spartan setup with BLS251
 Print TOPIC  Make Suggestion 

 1  Topic Subscribe

Wednesday, October 18 - 11:20 pm - Copyright © 2000-2017 RunRyder   EMAILEnable Cookies

Login Here
 New Subscriptions 
 Buddies Online