RunRyder RC
 1  Topic Subscribe
WATCH
 1 page 662 views POST REPLY
10-21-2009 01:32 AM  8 years agoPost 1
fast88lx

rrNovice

NY

My Posts: All  Forum  Topic

Can someone help me with my radio set up cant get the setup right on the radio

x9303
7100r
jr 8717s
solid-g 9256

my problem is i cant get the head to work the right way if anyone has the same setup maybe you can give me some # from your setup

PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
10-21-2009 02:59 AM  8 years agoPost 2
Tradhunt

rrKey Veteran

Fairfield, Ca. USA

My Posts: All  Forum  Topic

Whats not working right about it?

If the input you give move's the opposite way you want it.... Example- You try positive pitch but the swash travels down you will need to go into you're Swash Mix in you radio and put that value at a Negitive #... So if it's +60 adjust it to -60... Same goes for all the settings if they are off.

I don't crash... I land with style

PM  EMAIL  GALLERY  Attn:RR  Quote
10-22-2009 01:06 AM  8 years agoPost 3
Human_Enigma

rrApprentice

Seattle Wa

My Posts: All  Forum  Topic

Sounds like a first timer with ECCPM setup. My advice would be to watch these videos 2 or 3 times. They will guide you through setting up any head and radio much easier then trying to describe it through text.. http://video.helifreak.com/?subpath...CCPM_Part_1.wmv

http://video.helifreak.com/?subpath...CCPM_Part_2.wmv

If your not regestered, you should be. '_;

Fly it like you wanna re-kit!

PM  EMAIL  GALLERY  Attn:RR  Quote
10-23-2009 01:45 AM  8 years agoPost 4
fast88lx

rrNovice

NY

My Posts: All  Forum  Topic

i got it all fixed thanks

PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
WATCH
 1 page 662 views POST REPLY
 Print TOPIC  Make Suggestion 

 1  Topic Subscribe

Thursday, April 26 - 8:51 am - Copyright © 2000-2018 RunRyder   EMAILEnable Cookies

Login Here
 New Subscriptions 
 Buddies Online