RunRyder RC
 2  Topic Subscribe
WATCH
 1 page 591 views POST REPLY
HelicopterMain Discussion › got my new 3D Knight up and running...however
10-19-2009 04:23 PM  8 years agoPost 1
bcrector

rrNovice

muncie, IN

My Posts: All  Forum  Topic

I am having throttle issues again! The electronics were taken out of a previous heli in which the throttle servo recently started acting up. After buying a new governor and servo, it ended up being the 3151 servo. So I had replaced it with a new (i think...i dont think I would have put a problem servo in a servo box in my parts bin) 3151 servo that I already unknowingly had and a few tanks later and on the maiden voyage of the 3D it started acting up!...irratic rpm and harsh transition from idle to governed rpm. So, two 3151 servos later, do I replace the servo with a new 3151 straight from heliproz or a hs6965 hitec (karbonite gears)that is also new? Both of which I have. Is the hitec servo any more durable. 3151's have seemed to work fine in the past for throttle...maybe just a stroke of bad luck? Yes, I always check throttle linkages as with everything else and get the throws to where they dont bind at all at both limits and are at 100% atv (or very close to it).

PM  EMAIL  Attn:RR  Quote
10-19-2009 04:27 PM  8 years agoPost 2
hornet dave

rrKey Veteran

Cedar Rapids, IA USA

My Posts: All  Forum  Topic

i'm guessing you have issues with the throttle barrel sticking.

I got a fever! The only prescription is MORE 6HV

PM  EMAIL  GALLERY  Attn:RR  Quote
10-19-2009 04:38 PM  8 years agoPost 3
VooDooX

rrElite Veteran

San Francisco Bay Area CA, US (San Mateo)

My Posts: All  Forum  Topic

maybe the governor is sending too high a pulse width or too low and its messing up? try a different servo or check your governor to see if there's different settings what gov u using?

Velocity 50 "99.9999999999999% of an atom is empty space." also 01001000 01001001

PM  EMAIL  GALLERY  Attn:RR  Quote
10-19-2009 11:27 PM  8 years agoPost 4
bcrector

rrNovice

muncie, IN

My Posts: All  Forum  Topic

I initally had a GV1 with the first failure. Switched to a new TJ Pro revmax and still same issue so I threw the original 3151 in the trash and put in a 3151 I already had (I think its new) and it worked like it should for a tank or two until I took everything out to build the Knight. A few minutes into flight it started messing up.

PM  EMAIL  Attn:RR  Quote
10-20-2009 02:10 AM  8 years agoPost 5
jschenck

rrProfessor

La Vista, NE.

My Posts: All  Forum  Topic

Is your revmax set to 'high frame rate' mode - aka "DS mode" or "super servo" mode? turn that off, may be killing your servo (as voodoo said) or could be the throttle sticking (which engine do you have?)

another item to check is your clutch runout. if the clutch is off a bit it'll cause high speed vibrations which are directly transmitted to the servo.

Personally I wouldn't put the 6965 on the throttle - just my opinion but it's overkill to have a digital coreless servo on the throttle. Find any basic servo you have that is reliable and faster than say .18 and run that. I've had my heli tach'd while doing continuous flips running a Hitec 525 on the throttle and a TJ Pro - tack guy said it was varying by ~20 RPM.

PM  EMAIL  GALLERY  Attn:RR  Quote
10-20-2009 02:44 AM  8 years agoPost 6
mlucia

rrKey Veteran

Essex Jct., Vermont

My Posts: All  Forum  Topic

Have you tried a throttle curve in idle up and bypass the governor?
Possibly a bad sensor?

PM  EMAIL  GALLERY  Attn:RR  Quote
10-20-2009 02:51 AM  8 years agoPost 7
jschenck

rrProfessor

La Vista, NE.

My Posts: All  Forum  Topic

^^ good call, did you replace the sensor when you replaced the gov ?

Also, I think we are assuming the engine is tuned properly, is it? An engine that is too rich or too lean could act funny on a gov.

PM  EMAIL  GALLERY  Attn:RR  Quote
10-20-2009 01:55 PM  8 years agoPost 8
mlucia

rrKey Veteran

Essex Jct., Vermont

My Posts: All  Forum  Topic

Also, I think we are assuming the engine is tuned properly, is it?
And that also

PM  EMAIL  GALLERY  Attn:RR  Quote
WATCH
 1 page 591 views POST REPLY
HelicopterMain Discussion › got my new 3D Knight up and running...however
 Print TOPIC  Make Suggestion 

 2  Topic Subscribe

Tuesday, January 23 - 7:56 am - Copyright © 2000-2017 RunRyder   EMAILEnable Cookies

Login Here
 New Subscriptions 
 Buddies Online