RunRyder RC
 4  Topic Subscribe
WATCH
 1 page 529 views POST REPLY
HelicopterJR Heli Vibe 90/50, Sylphide 90, GSR260 › Please help! Cant get my tail to perform like it used to....
10-19-2009 12:03 PM  8 years agoPost 1
tommyvuitton

rrApprentice

Joburg, South Africa

My Posts: All  Forum  Topic

Hi guys, i need some help to figure out what is making the tail on my vibe 50 perform so badly. I am getting a twitch from the tail which was never there and it seems worse when i go into idle up, i also now have bad drift on the tail. Yes, i have tried to set the gyro up in rate mode (48% on my X9303) but the tail seems like it has a mind of its own, if it drifts one way i try counter the other way a little the tail kicks out badly in the direction i counter. I have a 770 and 8900g. The tail servo has just been replaced and i have also fitted the G-Force tail grips thinking maybe it was the original parts which were the problem.

My tail used to perform flawless until my 8900g burned out its motor and i had to replace. Since then i have gone through all the mechnicals twice and everything seems fine but cant get rid of this twitch on the tail.

very

PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
10-19-2009 12:08 PM  8 years agoPost 2
Ronald Thomas

rrMaster

Gainesville, Fl, USA

My Posts: All  Forum  Topic

Any crashes? Did you replace the tail shaft bearings as well as the grips? Is there any binding at all? Any vibration?
Usually when a tail kicks inconsistently, it is a mechanical thing whether it be a bind or a bearing going bad.
Also which hub did you use with the G-force grips? I hope you used the Quick UK hub and bearings and not the Align hub ...........Ron

Team MikadoUSA 480XXTreme, 550SX, 600SX, 700XXTreme, 800XXTreme!!

PM  EMAIL  GALLERY  Attn:RR  Quote
10-19-2009 12:40 PM  8 years agoPost 3
tommyvuitton

rrApprentice

Joburg, South Africa

My Posts: All  Forum  Topic

Hey bud, i crashed on flight 15 and replaced all visable damaged parts. After which the setup was almost perfect including a smooth tail which did occasionally wag when coming out of high speed turns.

Are you talking about the thrust bearings? Vibrations seem good as my tail fin is steady. My tail also seems smooth without any binding as it was when i put it together.

Yea, i bought the G-Force grips because of that post. I have ordered the quickUK hub but for the meantime i have sourced an align hub that was 12mm. Seems to be ok, the only thing that i am not to sure about is the play on the grips when i hold the hub and move the grip around. Do you notice any play?

QuickUK bearings? I thought you needed to use the thrust bearings that came with the grips?

PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
10-19-2009 01:44 PM  8 years agoPost 4
Ronald Thomas

rrMaster

Gainesville, Fl, USA

My Posts: All  Forum  Topic

The Align hub is a source of failures I would put the Quick UK one on.
If you replaced all bearings and you have no binding,l then all should be good mechanically except for the play. Where is it and how much?

Team MikadoUSA 480XXTreme, 550SX, 600SX, 700XXTreme, 800XXTreme!!

PM  EMAIL  GALLERY  Attn:RR  Quote
10-19-2009 02:10 PM  8 years agoPost 5
tommyvuitton

rrApprentice

Joburg, South Africa

My Posts: All  Forum  Topic

With the grips on the heli, i can move the grips about 5mm (measured at the blade tip) toward and away from the hub. It looks like the thrust bearings are quite a bit smaller than the tail grips.

PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
10-19-2009 04:21 PM  8 years agoPost 6
KsSportflyer

rrApprentice

Louisburg, Kansas

My Posts: All  Forum  Topic

I had the same problem with my 770 and 8900g. It would kick out, and wag. It ended up being that my motor was not tuned correct. Once I got the motor tuned right the wag went away for the most part. Then I replaced the gyro cushion with some Kyosho zeal gyro gel. My tail holds awesome now.

Brandon

PM  EMAIL  GALLERY  Attn:RR  Quote
10-22-2009 08:27 AM  8 years agoPost 7
tommyvuitton

rrApprentice

Joburg, South Africa

My Posts: All  Forum  Topic

I have just run in my Novarossi it seems to be close in the tuning department. Also tried mounting the gyro on two pieces foam with a coin in the middle and still no luck. I am really starting to get discouraged with this tail and have been grounded with thus issue for months.

PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
10-22-2009 09:34 AM  8 years agoPost 8
Spacey

rrVeteran

Pretoria, South Africa

My Posts: All  Forum  Topic

I dunno, maybe get it to someone to get a second eye on it.

PM  EMAIL  GALLERY  Attn:RR  Quote
10-22-2009 10:10 AM  8 years agoPost 9
tommyvuitton

rrApprentice

Joburg, South Africa

My Posts: All  Forum  Topic

Hey Rudolf

Think i am going to get together with Dawie this weekend if he isnt busy. Maybe with 2 Vibe 50s we can work it out!

PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
10-22-2009 10:16 AM  8 years agoPost 10
Spacey

rrVeteran

Pretoria, South Africa

My Posts: All  Forum  Topic

You must get that shirt from me also sometime I dunno for sure about D's plans but Saturday I know is out, maybe he's open Sunday. I don't think I'll be back early enough Sunday to help out but can't say now. Next weekend I think we're mostly free though.

PM  EMAIL  GALLERY  Attn:RR  Quote
10-22-2009 11:59 AM  8 years agoPost 11
FLYERCLD

rrVeteran

Proctor, Arkansas

My Posts: All  Forum  Topic

Tail
Check the engine tuning, tail output shaft, go back and reset your tail setup.

PM  EMAIL  GALLERY  Attn:RR  Quote
10-22-2009 03:07 PM  8 years agoPost 12
KsSportflyer

rrApprentice

Louisburg, Kansas

My Posts: All  Forum  Topic

Also Tommy, if possible try a different tail servo, if you have one. If that dont work try a different gyro. Maybe one of your buddies has an extra you can try just to diagnose the problem. Hope that helps.

Brandon

PM  EMAIL  GALLERY  Attn:RR  Quote
10-22-2009 08:45 PM  8 years agoPost 13
tommyvuitton

rrApprentice

Joburg, South Africa

My Posts: All  Forum  Topic

ThanKs Ks, I have organized a Buddy to lend me another gyro and I have a spare tail servo.

PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
WATCH
 1 page 529 views POST REPLY
HelicopterJR Heli Vibe 90/50, Sylphide 90, GSR260 › Please help! Cant get my tail to perform like it used to....
 Print TOPIC  Make Suggestion 

 4  Topic Subscribe

Thursday, April 26 - 10:14 pm - Copyright © 2000-2018 RunRyder   EMAILEnable Cookies

Login Here
 New Subscriptions 
 Buddies Online