RunRyder RC
 2  Topic Subscribe
WATCH
 1 page 471 views POST REPLY
Scorpion Power Scorpion Power
HelicopterRadio - JR DMSS › Trim Shift Issue - 12X Sudden Change in Elevator Trim
09-03-2009 04:01 AM  8 years agoPost 1
rocket_33

rrElite Veteran

Mount Pleasant, Michigan USA

My Posts: All  Forum  Topic

Had something strange happen today. I was at the field trying to help another flyer with buddy boxing his radio (read post regard 9303 to 9303 if interested).

Anyway, to see if there was a problem with his master, I thought.....hey let's try my helicopter....I will use my 12X as a master and his 9303 slave as the slave.

Plugged everything in and everything worked well. So we figured out what the problem was with his helicopter and off he went happy.

Here is where it gets strange....I went to fly my helicopter and noticed a whole bunch of forward trim (elevator) in it. I thought himmm....did I bump my trims.....nope they were 0. I looked at my roll (aileron) axis and it looked fine....just a whole bunch of forward.

I then thought maybe I had it all the time because I have flown a few gallons through this machine. So after checking to make sure the linkages were all tight and everything looked good so lifted it off in a safe hover. Sure enough this thing wanted to drop its nose and go. It took alot of back stick to hold it. So landed it and shut it off.

I flew the machine yesterday for a large part of the day and no problem, had not made any changes or anything. The only thing between yesterday (and the day before for that matter) is that I plugged in the trainer and slave transmitter and now I have a ton of forward trim.

To correct it out, it took 5 turns on the pushrod to re-level the swashplate.

Anyone have an idea what could have happened? It is concerning that it had such a trim change (yet it never went back). My only fear is that I may be flying and it all of a sudden change again then I will have a ton of rear elevator.

Thoughts

PM  EMAIL  GALLERY  Attn:RR  Quote
09-03-2009 08:08 AM  8 years agoPost 2
f penfold

rrKey Veteran

uk

My Posts: All  Forum  Topic

check the splines on the servo arm sounds like they are warn and could have jumped. if not that check for slop in the gaer in side the servo.

I know I used lock tight why did my head explode

PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
09-03-2009 01:02 PM  8 years agoPost 3
rocket_33

rrElite Veteran

Mount Pleasant, Michigan USA

My Posts: All  Forum  Topic

Yep had done that just to be sure....but as an aside this is a 140 CCPM so that would have meant multiple servos moving in the correct way to result in only an elevator shift not roll. Definitely strange

PM  EMAIL  GALLERY  Attn:RR  Quote
09-03-2009 02:54 PM  8 years agoPost 4
Chris Bergen

rrElite Veteran

cassopolis, MI USA

My Posts: All  Forum  Topic

I also have seen wierd things happen when plugging radios together for a Buddy box session.

In one case, the aileron system was reversed....But ONLY when used as a buddy box. Individually each radio had the correct direction, but when the momentary switch was pulled, the ailerons were backwards. Unfortunately we did not notice this at first, and it cost me a set of $250 blades, rebuild time, a few other parts, and quite a bit of embarrasment with the customer.

2 IDENTICAL and brand new 9303 radios on 2.4.

We verified that both programs were the same, actually flying the heli with both transmitters (one at a time of course).

With the cord plugged in and the switch pulled, aileron backwards...

Moral is, ALWAYS check directions and movements BEFORE flying....

Chris D. Bergen

PM  EMAIL  GALLERY  Attn:RR  Quote
WATCH
 1 page 471 views POST REPLY
Scorpion Power Scorpion Power
HelicopterRadio - JR DMSS › Trim Shift Issue - 12X Sudden Change in Elevator Trim
 Print TOPIC  Make Suggestion 

 2  Topic Subscribe

Thursday, October 19 - 9:01 pm - Copyright © 2000-2017 RunRyder   EMAILEnable Cookies

Login Here
 New Subscriptions 
 Buddies Online