RunRyder RC
 2  Topic Subscribe
WATCH
 1 page 1139 views
Helicopter
e-
MSH Protos, Mini Protos
› Protos 80 amp ESC New to Electrics
09-02-2009 10:40 PM  8 years agoPost 1
Wedge77

rrVeteran

St. Charles Missouri USA

My Posts: All  Forum  Topic

Ok, i have a Gaui 425, that i bought at IRCHA. I bought a new protos esc here on RR, I am reading and seeing ppl having problems with cutoffs? Im fairly new to electrics, so will I have problems using a Scorpion motor with the esc? anything special I might need to do to make my heli DEPENDABLE?
btw, i dont do 3d flying, basic circuits, loops and rolls so far.

Any help would be greatly appreciated guys.
Thanks Wedge

PM  EMAIL  GALLERY  Attn:RR  Quote
09-03-2009 04:41 AM  8 years agoPost 2
drdot

rrElite Veteran

So. California, Orange County.

My Posts: All  Forum  Topic

fwiw..

As much as I like to promote MSH and the Protos....We've not had good luck with the 80A MSH esc...No fires, but programming and start issues have made most of the locals go with the Align 60 A...Plug and play on the Protos...

John.

PM  EMAIL  Attn:RR  Quote
09-03-2009 05:04 AM  8 years agoPost 3
Wedge77

rrVeteran

St. Charles Missouri USA

My Posts: All  Forum  Topic

Well, .... guess that was 50.00 bucks wasted?

PM  EMAIL  GALLERY  Attn:RR  Quote
09-03-2009 05:06 AM  8 years agoPost 4
drdot

rrElite Veteran

So. California, Orange County.

My Posts: All  Forum  Topic

fwiw..

Not necessarily...Many people have had good luck, and apparently if it works, it works well....Get somebody to help you set it up, see if you've got a good'un...

John.

PM  EMAIL  Attn:RR  Quote
09-03-2009 05:16 AM  8 years agoPost 5
Wedge77

rrVeteran

St. Charles Missouri USA

My Posts: All  Forum  Topic

*L* well, i wont give up on it, Ill try it and see what happens.. Ive tried a few elec planes and had bad luck.. mostly because I didnt know the lipos.. burnt a cell in the batteries from running too long.. ill gtet this together and see what happens..
thanks for the input guys..
wedge

PM  EMAIL  GALLERY  Attn:RR  Quote
09-04-2009 09:31 PM  8 years agoPost 6
integy2

rrVeteran

California USA

My Posts: All  Forum  Topic

Try it out = crash.
best bet go with Align 60A plug and play no issue.

(Good flight end up with ...... big smile :D)

PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
09-05-2009 01:53 PM  8 years agoPost 7
dizzymarkus

rrVeteran

Oswego, NY

My Posts: All  Forum  Topic

I am using the 80 in the Protos and have had no issues other than the soft start -- if your spooling down forgot glasses etc then try to respool -- you have to wait until its stopped before it will spin again :0( -- I run it on 6s with a rather tight belt, 3 x 9650, 1 x 9254 and a 401 without issues and no external BEC :0) The LVC --- set your timer onthe radio lol if it hits it drops power like a falling truck -- no warning no nothing just sarts to loos epower and you have 15 secs to land :0(

Just my experiences with it

Markus

I reject your reality and substitute my own :0)

PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
WATCH
 1 page 1139 views
Helicopter
e-
MSH Protos, Mini Protos
› Protos 80 amp ESC New to Electrics
 Print TOPIC  Make Suggestion 

 2  Topic Subscribe

Monday, December 18 - 1:22 am - Copyright © 2000-2017 RunRyder   EMAILEnable Cookies

Login Here
 New Subscriptions 
 Buddies Online