RunRyder RC
 2  Topic Subscribe
WATCH
 1 page 648 views POST REPLY
Scorpion Power Scorpion Power
HelicopterFuel-Helicopters New or Limited ActivityRJX Hobby › Free play in elavator cyclic Extreme 50
09-01-2009 08:50 AM  8 years agoPost 1
barako

rrNovice

Israel

My Posts: All  Forum  Topic

Hi...

I just finish building and set up my Extreme 50..
But- i have noticed that when i move the cyclic(elavator) stick full up to full down the paddles does not return to nuetral every time..

I have noticed that there is some free play when i tried to move the paddles by hand..
Does someone know how to eliminate this ??
I have checked the screws from the swash up .....

Thx-Barak Ohana.

PM  EMAIL  GALLERY  Attn:RR  Quote
09-02-2009 03:44 AM  8 years agoPost 2
Jody

rrApprentice

Australia

My Posts: All  Forum  Topic

Firstly check the elevator arm (between the frames) has the set screw located correctly onto the flat in the spindle that it is on (dont just tighten it, check it is on the flat)

Make sure your links are free (binding can stop it returning to zero)

Cheap servos may have a high deadband (not accurate) which will also stop them returning to centre.

cheers

Jody

PM  EMAIL  GALLERY  Attn:RR  Quote
09-03-2009 03:40 PM  8 years agoPost 3
barako

rrNovice

Israel

My Posts: All  Forum  Topic

Hi Jody..
Thanks for your reply!
The problem is not the servo as i see , the servos plate does not "move" when i manually try to twist the flybar ..

Thx again! i will re check what you suggest......

PM  EMAIL  GALLERY  Attn:RR  Quote
WATCH
 1 page 648 views POST REPLY
Scorpion Power Scorpion Power
HelicopterFuel-Helicopters New or Limited ActivityRJX Hobby › Free play in elavator cyclic Extreme 50
 Print TOPIC  Make Suggestion 

 2  Topic Subscribe

Tuesday, October 17 - 6:58 am - Copyright © 2000-2017 RunRyder   EMAILEnable Cookies

Login Here
 New Subscriptions 
 Buddies Online