RunRyder RC
 3  Topic Subscribe
WATCH
 2 pages [ <<    <    ( 1 )     2     NEXT    >> ] 1339 views POST REPLY
HelicopterRadio - Servo - Gyro - Gov - Batt › Multigov Pro Keeps Destroying Servos
08-06-2009 06:43 PM  8 years agoPost 1
Melon

rrApprentice

California

My Posts: All  Forum  Topic

Hey guys, i've had my MGP for about a year now, for some reason it keeps destroying throttle servos, i dont know if unplugging it multiple times does it or what. First i destroyed my brand new 8717 and now an old futaba.
Is there something i should know about it?

PM  EMAIL  GALLERY  Attn:RR  Quote
08-06-2009 06:46 PM  8 years agoPost 2
JuanRodriguez

rrProfessor

The Villages, Florida

My Posts: All  Forum  Topic

Does the MultiGov have a "super servo" setting ? and if so, are your servos capable of using that setting ?

Maybe you got a melon ??? Oppssss, I meant lemon !!

PM  EMAIL  GALLERY  Attn:RR  Quote
08-06-2009 07:10 PM  8 years agoPost 3
chopper_crazy

rrElite Veteran

Delphos, Ohio

My Posts: All  Forum  Topic

I have multigov pro's on 3 of my birds all running 8717's on the throttle and never had any issues.

It's a complex, costly, glow powered anti-gravity machine!

PM  EMAIL  GALLERY  Attn:RR  Quote
08-06-2009 07:36 PM  8 years agoPost 4
cgalavis

rrNovice

Franklin, WI USA

My Posts: All  Forum  Topic

I am running MGP with 9252 for the throttle in both my nitro helis and I have never had a problem either. Have you contacted Aerospire yet? Maybe you have a faulty unit?

When everybody actually is out to get you, paranoia is just good thinking.

PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
08-06-2009 09:09 PM  8 years agoPost 5
Gearhead

rrMaster

Vt

My Posts: All  Forum  Topic

are you sure you have NO binding at Full Throttle ??

or, are you sure you didn't set the Governor's Full Throttle End Point in Normal Mode then have a higher Throttle Curve setting in Idle Up ??

Jim
Buzz Buzz Buzz

PM  EMAIL  GALLERY  Attn:RR  Quote
08-06-2009 09:17 PM  8 years agoPost 6
cgalavis

rrNovice

Franklin, WI USA

My Posts: All  Forum  Topic

are you sure you didn't set the Governor's Full Throttle End Point in Normal Mode then have a higher Throttle Curve setting in Idle Up ??
Good call, I have done that...

When everybody actually is out to get you, paranoia is just good thinking.

PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
08-06-2009 09:18 PM  8 years agoPost 7
Melon

rrApprentice

California

My Posts: All  Forum  Topic

Yes, i do all of the set up with no binding.

PM  EMAIL  GALLERY  Attn:RR  Quote
08-06-2009 09:19 PM  8 years agoPost 8
Gearhead

rrMaster

Vt

My Posts: All  Forum  Topic

""Good call""

hey, it just popped in my head, you know,,

thanks !!

Jim
Buzz Buzz Buzz

PM  EMAIL  GALLERY  Attn:RR  Quote
08-06-2009 09:35 PM  8 years agoPost 9
Aerospire

rrApprentice

Honolulu, HI

My Posts: All  Forum  Topic

What's your power source and what voltage are you running the unit at?

Either there is binding occurring, too high voltage, just coincidence servos failed, or a problem with the unit.

Is there a lot of oil getting on your servos? If two servos failed over a course of a few flights, then I would suspect the unit. If it was over the course of a year, then maybe it is bad luck/coincidence.

We have not had any other reports of a problem with servos.

bob

PM  EMAIL  GALLERY  Attn:RR  Quote
08-06-2009 09:38 PM  8 years agoPost 10
Melon

rrApprentice

California

My Posts: All  Forum  Topic

I'm running off a 2s lipo regulated at 6 volts using the Arizona regulator. Not sure why it would burn out a servo rated for 6V.

This just started happening recently.

PM  EMAIL  GALLERY  Attn:RR  Quote
08-06-2009 09:41 PM  8 years agoPost 11
JuanRodriguez

rrProfessor

The Villages, Florida

My Posts: All  Forum  Topic

Check the output of your regulator to make sure you are getting 6 V....

PM  EMAIL  GALLERY  Attn:RR  Quote
08-06-2009 09:41 PM  8 years agoPost 12
Aerospire

rrApprentice

Honolulu, HI

My Posts: All  Forum  Topic

Anything change on the heli recently? What Futaba servo was that? Many Futaba servos aren't rated for 6V.

bob

PM  EMAIL  GALLERY  Attn:RR  Quote
08-06-2009 10:22 PM  8 years agoPost 13
Melon

rrApprentice

California

My Posts: All  Forum  Topic

Nothing, i just redid my wiring and then got the 8717, never saw a flight. Then i had a 9452 on it before which worked fine since i had my 700 in october, it whent out today.

PM  EMAIL  GALLERY  Attn:RR  Quote
08-06-2009 10:23 PM  8 years agoPost 14
Shawn Behrens

rrApprentice

DEEP IN THE BOG

My Posts: All  Forum  Topic

Doubt it's voltage or regulator issue both items can handle 2s lipo unregulated.

PM  EMAIL  GALLERY  Attn:RR  Quote
08-06-2009 10:31 PM  8 years agoPost 15
Aerospire

rrApprentice

Honolulu, HI

My Posts: All  Forum  Topic

I would try another spare low-end servo you don't care about just for testing.

If you don't have one or don't want to do that, just mail the unit back to us along with your problem description/contact info and I will check it out:

AEROSPIRE LLC
PO BOX 25925
HONOLULU, HI 96825

bob

PM  EMAIL  GALLERY  Attn:RR  Quote
08-06-2009 11:15 PM  8 years agoPost 16
ren

rrVeteran

Houston, TX

My Posts: All  Forum  Topic

I has the same problem 4 times, never had bidding, and the gov is conected to the regulated section of the reciver,at some point I blame the servos by been old, but the last one was a new hightec, I sent it back to service and they said it was fry some how.
sistem:
ax7100 ( gov at regulated section)
2s lipo

I have lost:
futaba 9253, 9254
jr 4131
ht 5965

I notice that the servos start pulsating right before are complete gone!!

PM  EMAIL  GALLERY  Attn:RR  Quote
08-06-2009 11:43 PM  8 years agoPost 17
Melon

rrApprentice

California

My Posts: All  Forum  Topic

I'll be at ircha, i'll stop by your tent if you have one. I'd be happy to have it checked, but not too happy having to replace all of these servos...

PM  EMAIL  GALLERY  Attn:RR  Quote
08-07-2009 12:09 AM  8 years agoPost 18
Aerospire

rrApprentice

Honolulu, HI

My Posts: All  Forum  Topic

Sorry, won't be at IRCHA but you can send your unit back to us to have it checked out.

Servos are mechanical and they move a lot and can fail. We don't do anything unusual that would cause them to fail.

There are many MultiGov users around the world with tons of flights going on without any problems. That said, it would not be surprising to hear about a few bad servos just by the fact of having so many units in use/coincidence/normal failure rate. This would be the case with any product being widely used.

---------------
This might not be applicable in your setup but one thing to note is that if you are using a 7100, look at this from our FAQ page http://www.aerospire.com/support.html

I am running a Spektrum 7100 dual-voltage receiver or similar, are there any special connection considerations?

When connecting the RPM select input to the receiver, please remove the red wire from the extension cable. This avoids any problem with conflicting input voltage levels. MultiGov only needs the power line (red) coming from the receiver throttle output for operation.

The 7100 provides regulated and unregulated outputs so this would prevent you from accidentally hooking up the unit to two different voltage sources. This is not a typical setup as throttle, aux2, and gear is supposed to be regulated.
----------------

bob

PM  EMAIL  GALLERY  Attn:RR  Quote
08-07-2009 12:23 AM  8 years agoPost 19
WJackson

rrElite Veteran

Smyrna, Delaware

My Posts: All  Forum  Topic

Weird, got two MGP and two MG that I've been using since Bob hit the market, not a lick of problems out of any of them. That said, I would send it back and let Bob check it out JIC!

BTW Bob, cant believe your not making it to IRCHA again!!!!!!

RIP Roman
Bill Jackson
AlignUSA

PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
03-12-2010 09:47 AM  8 years agoPost 20
Ringo Ranger

rrVeteran

Honolulu, Hawaii USA

My Posts: All  Forum  Topic

With Multigov, I don't have any issues with that. keep working on it till u do it RIGHT.

PM  EMAIL  GALLERY  Attn:RR  Quote
WATCH
 2 pages [ <<    <    ( 1 )     2     NEXT    >> ] 1339 views POST REPLY
HelicopterRadio - Servo - Gyro - Gov - Batt › Multigov Pro Keeps Destroying Servos
 Print TOPIC  Make Suggestion 

 3  Topic Subscribe

Monday, April 23 - 10:35 pm - Copyright © 2000-2018 RunRyder   EMAILEnable Cookies

Login Here
 New Subscriptions 
 Buddies Online