RunRyder RC
 1  Topic Subscribe
WATCH
 1 page 350 views POST REPLY
HelicopterAlignT-REX 700N › Tail with steppy feel
06-02-2009 12:43 PM  8 years agoPost 1
Against Gravity

rrVeteran

Pottstown PA

My Posts: All  Forum  Topic

I have a Sparten, BlS 251 combo on my 700 when I move the tail on the bench it has a very steppy feel not smooth like my other heli's.
the bird fly's great but this bothers me. I swapped servos and have the same feel, brand new 251.
Went through set up a couple times to make sure it is correct and it is, I have 2 other heli's with Sparten's and they seem to work fine.

Any Ideas would help

Thanks

PM  EMAIL  GALLERY  Attn:RR  Quote
06-02-2009 12:49 PM  8 years agoPost 2
duceduc

rrKey Veteran

Saitama-Ken, Japan

My Posts: All  Forum  Topic

You have popped off the linkage to the servo and checked the push rod for smoothness I would assumed?

On my 600, I have the exact same setup as you and it feels like it is grinding with rudder inputs. My tail had no binding. I think it is the servo that is causing it. I also remember when I had the 611, it felt like this aswell.

Duc S
Do It! Do It!™
AMA:REVOMIX
RCK:24005615-01

PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
06-02-2009 02:05 PM  8 years agoPost 3
Against Gravity

rrVeteran

Pottstown PA

My Posts: All  Forum  Topic

Steppy feel
Yes all my linkage is buttery smooth, also have a Qiuck tail and Micro heli arm.

PM  EMAIL  GALLERY  Attn:RR  Quote
WATCH
 1 page 350 views POST REPLY
HelicopterAlignT-REX 700N › Tail with steppy feel
 Print TOPIC  Make Suggestion 

 1  Topic Subscribe

Wednesday, May 23 - 11:50 pm - Copyright © 2000-2018 RunRyder   EMAILEnable Cookies

Login Here
 New Subscriptions 
 Buddies Online