RunRyder RC
 4  Topic Subscribe
WATCH
 1 page 1461 views POST REPLY
HelicopterEngines Plugs Mufflers Fuel › Red Line RL-53 Engine from Thunder Tiger
06-01-2009 06:32 PM  8 years agoPost 1
jrmann

rrNovice

Albuquerque NM

My Posts: All  Forum  Topic

I have had the engine for 4 months and it runs good. But I have started to do loop's and rolls, and every time I rolled the heli over the engine lost power and fell fast, lucky I was on a buddy box. I have tryed it with a MP5 muffler and a thunder tiger smoothie pipe with the samer results. The temp of the engine was 173 the first time I looped and went to 190 the next time with the same responce.

PM  EMAIL  Attn:RR  Quote
06-01-2009 06:43 PM  8 years agoPost 2
Nashville

rrElite Veteran

Formerly Music City now back home in Sunny Florida

My Posts: All  Forum  Topic

I really, really hate to ask this, but are you in idle up when performing the loops and rolls?

I was Spektrum when Spektrum wasn't cool

PM  EMAIL  GALLERY  Attn:RR  Quote
06-01-2009 06:45 PM  8 years agoPost 3
VooDooX

rrElite Veteran

San Francisco Bay Area CA, US (San Mateo)

My Posts: All  Forum  Topic

i would say this is more to due with throttle curves in idle up have a pro try to flip it without buddy box and see what happens also are you really rich ?

Velocity 50 "99.9999999999999% of an atom is empty space." also 01001000 01001001

PM  EMAIL  GALLERY  Attn:RR  Quote
06-01-2009 06:53 PM  8 years agoPost 4
Andy from Sandy

rrElite Veteran

Bedfordshire, UK

My Posts: All  Forum  Topic

The temp of the engine was 173 the first time I looped and went to 190 the next time with the same responce.
With a marked rise in temperature after just a couple of loops may indicate the engine is set lean. I don't mean to contradict you VoodooX but I don't think the engine temperature should vary that much.

PM  EMAIL  GALLERY  Attn:RR  Quote
06-01-2009 06:55 PM  8 years agoPost 5
VooDooX

rrElite Veteran

San Francisco Bay Area CA, US (San Mateo)

My Posts: All  Forum  Topic

ya but during a lean out doesn't an engine gain power? not lose it

Velocity 50 "99.9999999999999% of an atom is empty space." also 01001000 01001001

PM  EMAIL  GALLERY  Attn:RR  Quote
06-01-2009 06:59 PM  8 years agoPost 6
jackheli

rrProfessor

Vancouver - Canada

My Posts: All  Forum  Topic

Is the clunk inside the tank working?

It's easy to find an excuse to do wrong. Hard is not to find an excuse to do right.

PM  EMAIL  GALLERY  Attn:RR  Quote
06-01-2009 07:09 PM  8 years agoPost 7
VooDooX

rrElite Veteran

San Francisco Bay Area CA, US (San Mateo)

My Posts: All  Forum  Topic

o ya and do you have a header?

Velocity 50 "99.9999999999999% of an atom is empty space." also 01001000 01001001

PM  EMAIL  GALLERY  Attn:RR  Quote
06-01-2009 07:15 PM  8 years agoPost 8
30636086

rrKey Veteran

Tacoma, WA

My Posts: All  Forum  Topic

over the engine lost power and fell fast
+1 on idle up question and or check your radio settings!

I dont suffer from mental iIlness, I actually enjoy mine!

PM  EMAIL  GALLERY  Attn:RR  Quote
06-02-2009 03:26 AM  8 years agoPost 9
Furious Predator

rrProfessor

Kitchener, Ontario, Canada

My Posts: All  Forum  Topic

another question.

what are your cyclic pitch, and collective pitch settings?

what type of blades are you using?

also, are you using full throws on the sticks during the loops and rolls?

if your doing consecutive flips, you dont want to use both full cyclic and collective. you will quickly loose a lot of energy. but manage it so your cyclic is about half way, and your using just enough collective during the flip to keep you where you need to be, and you should be able to do them all day.

Shawn
Team Leisure-Tech
Team HelixRC

PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
06-02-2009 03:45 AM  8 years agoPost 10
Zaneman007

rrElite Veteran

Texas - USA

My Posts: All  Forum  Topic

Not sure how being on a buddy box, had any effect on the engine.

I second your are running rich, The engine temp should be around 210, with no load on the engine.

How are you metering the temp?

Flipping the engine over will not cause the engine to loose power. The engine temp will increase under load, but should cool back down. Still 190 is NOT hot, and not lean.

I'd recommend checking the fuel tubing.

Are you sure that your buddy is not messing with you?

Old Guys Rule!

PM  EMAIL  GALLERY  Attn:RR  Quote
06-02-2009 03:54 AM  8 years agoPost 11
Furious Predator

rrProfessor

Kitchener, Ontario, Canada

My Posts: All  Forum  Topic

Not sure how being on a buddy box, had any effect on the engine.
I have a feeling part or all of the problem has to do with collective management.

Shawn
Team Leisure-Tech
Team HelixRC

PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
06-02-2009 04:05 AM  8 years agoPost 12
Leon Brodie

rrApprentice

Brighton, Colorado - USA

My Posts: All  Forum  Topic

I have the RL 53 combined with the black TT pipe and the combo gets the job done. Well. + 1 on idle up set up

PM  EMAIL  Attn:RR  Quote
06-02-2009 04:23 AM  8 years agoPost 13
Nashville

rrElite Veteran

Formerly Music City now back home in Sunny Florida

My Posts: All  Forum  Topic

He must not want an answer very badly.

I was Spektrum when Spektrum wasn't cool

PM  EMAIL  GALLERY  Attn:RR  Quote
06-02-2009 04:37 AM  8 years agoPost 14
woop

rrApprentice

toronto, canada

My Posts: All  Forum  Topic

Redline engine= lotsa power.......problem elsewhere i believe throttle and pitch curves.

Powered by Rotorquest

PM  EMAIL  GALLERY  Attn:RR  Quote
06-02-2009 02:50 PM  8 years agoPost 15
LONEWOLF2440

rrElite Veteran

MYRTLE BEACH S.C

My Posts: All  Forum  Topic

wow were did he go i say throttle curve in idle up to check to

MIKADO LOGO 600 TREX 550

PM  EMAIL  GALLERY  Attn:RR  Quote
06-02-2009 02:52 PM  8 years agoPost 16
Cowjock

rrVeteran

Pa.

My Posts: All  Forum  Topic

Sure sounds like throttle and pitch curves not set up. Not in idleup.

Damn that ground is hard! When's the right time to get out of this money sucking hobby?

PM  EMAIL  GALLERY  Attn:RR  Quote
06-03-2009 11:40 PM  8 years agoPost 17
jrmann

rrNovice

Albuquerque NM

My Posts: All  Forum  Topic

Red Line RL-53 Engine from Thunder Tiger
I have check all the curves and pitch all is good. I have put a new OS 50 on everthing is working like it should. I think I will send the moter back to ace and have them take a look at it. One of my better heli guys is going to take it and see what he can do with it.

PM  EMAIL  Attn:RR  Quote
WATCH
 1 page 1461 views POST REPLY
HelicopterEngines Plugs Mufflers Fuel › Red Line RL-53 Engine from Thunder Tiger
 Print TOPIC  Make Suggestion 

 4  Topic Subscribe

Friday, May 25 - 5:57 pm - Copyright © 2000-2018 RunRyder   EMAILEnable Cookies

Login Here
 New Subscriptions 
 Buddies Online