RunRyder RC
 2  Topic Subscribe
WATCH
 1 page 311 views
Scorpion Power Scorpion Power
HelicopterBeginners Corner › Diagnosis help
03-22-2009 11:55 AM  8 years agoPost 1
dbldins

rrVeteran

Danville,Ky.

My Posts: All  Forum  Topic

Yesterday I downed the REX450sa. 430L. 35amp align speed control, gy401. Got home surveyed the damage and rebuilt the frame. When I plug up the batt. the gyro blinks but no servo response at all and no setting beeps from ESC aside from the escalating tone when plugged in. Any ideas as to what electronics are gone? I'm thinkin ESC cause the lower frame was bent bad so it probably took a good shock. All help and responses are appreciated.

I'm addicted to flying! Seriously!! I need rehelihab!

PM  EMAIL  GALLERY  Attn:RR
03-22-2009 12:10 PM  8 years agoPost 2
nivlek

rrProfessor

Norfolk England

My Posts: All  Forum  Topic

Remove the ESC lead from the receiver and power the rest of the electronics up and see if they work .

At the end of the day , it gets dark .

PM  EMAIL  Attn:RR
03-22-2009 06:53 PM  8 years agoPost 3
dbldins

rrVeteran

Danville,Ky.

My Posts: All  Forum  Topic

Problem solved!

I'm addicted to flying! Seriously!! I need rehelihab!

PM  EMAIL  GALLERY  Attn:RR
WATCH
 1 page 311 views
Scorpion Power Scorpion Power
HelicopterBeginners Corner › Diagnosis help
 Print TOPIC  Make Suggestion 

 2  Topic Subscribe

Sunday, November 19 - 7:03 am - Copyright © 2000-2017 RunRyder   EMAILEnable Cookies

Login Here
 New Subscriptions 
 Buddies Online