RunRyder RC
 2  Topic Subscribe
WATCH
 1 page 505 views
Scorpion Power Scorpion Power
HelicopterAlignT-REX 600N › ENGINE FAN MOUNT
03-20-2009 11:41 PM  8 years agoPost 1
VIDEOMAN

rrNovice

new york

My Posts: All  Forum  Topic

I need help please. I just bought a Align 600 sport frame. I'm in the process of building it. Well, I have a problem trying to mount the Fan holder to the Crankshaft. I screwed the socket screw all the way but the fan holder is still loose. I want to check if I can do it without the M6 Nut supply with 50 OS engine.
Please help, I'm new bulding nitro birds.

PM  EMAIL  GALLERY  Attn:RR
03-20-2009 11:51 PM  8 years agoPost 2
baddynergy

rrElite Veteran

sierra madre, ca-​usa

My Posts: All  Forum  Topic

Did you use the washer under the hub?

Install washer
put hub on
tighten crank nut
tighten socket head screws in hub

It should tighten up. If not come back and post a couple of detailed pix

**Unattended children will be givin a shot of espresso and a puppy**

PM  EMAIL  GALLERY  Attn:RR
03-20-2009 11:51 PM  8 years agoPost 3
george0079

rrElite Veteran

USA

My Posts: All  Forum  Topic

You need to use the prop nut, as well.

Hell... I can fix that.
Uh oh..
Nope.
It's ***ked!!!
RE-KIT!!!!!

PM  EMAIL  GALLERY  Attn:RR
03-21-2009 12:07 AM  8 years agoPost 4
VIDEOMAN

rrNovice

new york

My Posts: All  Forum  Topic

ENGINE FAN MOUNT

Yes the black washer is installed but I screwed the socket screws pretty well, but there is not grab between the ckackshaft and the engine mount. I don't know if the align 50 engine and the os 50 crankshaft are the same. Thanks for the help.

PM  EMAIL  GALLERY  Attn:RR
03-21-2009 12:14 AM  8 years agoPost 5
baddynergy

rrElite Veteran

sierra madre, ca-​usa

My Posts: All  Forum  Topic

I don't know if the align 50 engine and the os 50 crankshaft are the same.
They are the exact same engine. Can you post a couple pix of this. You could have a bad hub. But when you push the hub onto the crank it should not just fall on, you should have to push a little.

**Unattended children will be givin a shot of espresso and a puppy**

PM  EMAIL  GALLERY  Attn:RR
03-21-2009 12:41 AM  8 years agoPost 6
VIDEOMAN

rrNovice

new york

My Posts: All  Forum  Topic

pc added

pc added

When i push the engine mount into the crankshaft it just fall there loose and even whe I screw the bolt it is still loose. and my question is it should be loose until the M6 nut is use?

PM  EMAIL  GALLERY  Attn:RR
03-21-2009 12:45 AM  8 years agoPost 7
baddynergy

rrElite Veteran

sierra madre, ca-​usa

My Posts: All  Forum  Topic

Was this a used kit??
Is the hub going all the way down to the engine or is it stopping at the step on the crank?

**Unattended children will be givin a shot of espresso and a puppy**

PM  EMAIL  GALLERY  Attn:RR
03-21-2009 01:26 AM  8 years agoPost 8
VIDEOMAN

rrNovice

new york

My Posts: All  Forum  Topic

fan mount

Ths OS 50 is new and the Fan mount is used. The hub is going all the way down and stopping on top of the black washer and it stay loose even if I screw the socked screws hard. I think that I'm gonna have to buy a new engine mount.

PM  EMAIL  GALLERY  Attn:RR
03-21-2009 01:41 AM  8 years agoPost 9
TankDirt

rrKey Veteran

Illinois

My Posts: All  Forum  Topic

try this...put the washer on the crankshaft,then your fan mount,then lock the piston,and crank down the nut,THEN tighten up the 2 smaller screws.

Is it possible that somebody drilled out the center for a Big block mod?

PM  EMAIL  GALLERY  Attn:RR
03-21-2009 01:56 AM  8 years agoPost 10
bah7566

rrVeteran

Colorado

My Posts: All  Forum  Topic

I believe you should be using two washers. The thin black one on the shaft first, then the fan, followed by the nut washer then the nut.

I am a Heli addict!!!

PM  EMAIL  GALLERY  Attn:RR
03-21-2009 02:08 AM  8 years agoPost 11
baddynergy

rrElite Veteran

sierra madre, ca-​usa

My Posts: All  Forum  Topic

The hub is going all the way down and stopping on top of the black washer and it stay loose even if I screw the socked screws hard. I think that I'm gonna have to buy a new engine mount.
I would almost be tempted to say then, That the previous owner ran a big-block in it and modified it. I would replace the hub and start over. They are cheap anyway.

How many holes are in the engine to frame mounts?

**Unattended children will be givin a shot of espresso and a puppy**

PM  EMAIL  GALLERY  Attn:RR
03-21-2009 06:46 AM  8 years agoPost 12
VIDEOMAN

rrNovice

new york

My Posts: All  Forum  Topic

engine FAN MOUNT

I guess that you are right. The previous owner may modified it. There are 4 holes in the fram mount. I will start again. Thanks to all for the help.

PM  EMAIL  GALLERY  Attn:RR
WATCH
 1 page 505 views
Scorpion Power Scorpion Power
HelicopterAlignT-REX 600N › ENGINE FAN MOUNT
 Print TOPIC  Make Suggestion 

 2  Topic Subscribe

Monday, November 20 - 12:30 am - Copyright © 2000-2017 RunRyder   EMAILEnable Cookies

Login Here
 New Subscriptions 
 Buddies Online