RunRyder RC
 4  Topic Subscribe
WATCH
 1 page 831 views
Scorpion Power Scorpion Power
HelicopterRadio - Servo - Gyro - Gov - Batt › Century GL450 Tx seems different?
03-20-2009 09:16 AM  8 years agoPost 1
Rory

rrNovice

London, UK

My Posts: All  Forum  Topic

Hi all, a real newbie here and a small problem (I think). I have a raptor 30 which I can hover just fine (and travel around a little). As getting down to the flying field is such a mission, I bought myself theis lovely little GL450 which came with a 5page manual, but no setup instructions. Can't find anything about this heli on the centuryuk website (except for spare canopy)? Anyway, my problem is this, using the stock Tx and Rx, everything works fine, but the heli won't lift. I've done extensive research and found instructions for the Tx, but it seems different to my raptor's Tx. On the raptor, the throttle lever (left), makes the heli lift as well when rpm is right and controls collective. The right lever controls forward and backward. On the GL, it seems that the left lever controls rpm and forward and backward, but the right lever controls collective (lift)? This is very confusing as I've just gotten used to the raptor setup and now it seems I have to learn all over with the GL? Possibly I've made a mistake somewhere with the Rx cables wrong way round? As mentioned, everything works fine, the swashplate moves in all the correct directions on static test, but the right hand lever makes the swashplate move up and down instead of forward and backward? I have realflight sim and this is the same as the raptor for learning. Am I just being daft or is something wrong? Any help would be greatly appreciated. Cheers, Rory.

PM  EMAIL  Attn:RR  Quote
03-20-2009 04:10 PM  8 years agoPost 2
rotormonkey

rrKey Veteran

Ottawa, ON - Canada

My Posts: All  Forum  Topic

There are different types of radio. North America, and Canada use Mode 2 which is what you're Realflight sim, and Raptor are using. Sounds like the other heli you're having problems with is Mode 1? I think that's what most of the UK uses. Anyway the problem is just the radio configuration. Unless it's a good computer radio where you can select which mode it's using (it's my understanding that few radios do this), you'll have to just get a different radio to correct the issue.

PM  EMAIL  Attn:RR  Quote
03-20-2009 04:20 PM  8 years agoPost 3
nivlek

rrProfessor

Norfolk England

My Posts: All  Forum  Topic

Sounds like the other heli you're having problems with is Mode 1? I think that's what most of the UK uses.
Nah , most of us use Mode 2 . It sounds like it's going to be something pretty simple , maybe just one servo ('elevator'?) being reversed .

At the end of the day , it gets dark .

PM  EMAIL  Attn:RR  Quote
03-20-2009 04:28 PM  8 years agoPost 4
rotormonkey

rrKey Veteran

Ottawa, ON - Canada

My Posts: All  Forum  Topic

I was just about to re-post saying there's no way, but after re-reading the OP it doesn't sound like any configuration I've ever heard of. Nivlek, you're probably right. Collective and throttle are always mixed together afaik. Something's probably plugged in wrong, or the description of the problem is inaccurate.

A video is worth a thousand words. Show us a vid with the sticks moving and the swash doing stuff.

PM  EMAIL  Attn:RR  Quote
03-20-2009 05:43 PM  8 years agoPost 5
imnxtc

rrVeteran

BC.Canada

My Posts: All  Forum  Topic

Rory,

May I suggest that you change the title of this thread by removing Century from it. As many of us in North America will think it is a product designed and manufactured by Century Helicopters Products here in the USA.

The GL450 is a heli sold in England by a compamy called CenturyUK, who also import the real Century helicopters into your country. But the GL450 has no association whatsoever with those manufactuered by Century here.

You will note that the GL450 is not even listed anywhere on the Century manufacturers web site:

http://www.centuryheli.com/

It is a 450 electric heli that is made in China by some other company then Century here in the USA. So by using the Century name in the title of the thread will be a bit misleading...even using CenturyUK would be more accurate and less confusing for us blokes on this isde of the pond.

PM  EMAIL  Attn:RR  Quote
03-20-2009 09:43 PM  8 years agoPost 6
Rory

rrNovice

London, UK

My Posts: All  Forum  Topic

Hi all, thanks for the replies. It would seem that the Tx is setup that way. I found the manual here: http://www.fonogramos.lt/ivairus/FT06%20Manual.pdf. and you can see on page 5 that the left lever controls the power (throttle), but the right lever controls the ascend / descend function. Is this bizare or what? Anyway, I found the solution in trying my Raptors Tx with the GL450 crystal in and that worked just fine, so it must be the GL450 Tx that is configured wrong? Very strange as this is a top-spec elevtric heli here in the UK and does not come cheap retailing at £250+. I have been hovering the heli in the yard, so all is good now. I must apologise for naming the thread Century instead of CenturyUK as well. How do I go about changing the name of the thread?

PM  EMAIL  Attn:RR  Quote
03-20-2009 11:29 PM  8 years agoPost 7
Silvashadow

rrVeteran

Kent, UK

My Posts: All  Forum  Topic

Hi Rory,

Something is set up wrong. Which ever mode your GL450's transmitter is in (i.e. mode 1 or 2) the collective and throttle will be on the same stick be it left or right. The transmitter which comes with the Century UK GL 450, though not top spec. by any means, is very suitable for the model. Just give the guys at Century UK a call on 01795 437056 and they will set you right.

Although the GL450 is no longer listed for sale, replaced by the Razor 400, all spares are availiable AS SHOWN HERE

PM  EMAIL  GALLERY  Attn:RR  Quote
03-22-2009 02:05 PM  8 years agoPost 8
Rory

rrNovice

London, UK

My Posts: All  Forum  Topic

Hi all, and thanks for the many replies to my issue. It is definately the Transmitter as can be seen in the link to the manual I posted before. As mentioned I am now using my other transmitter for the job and to change the crystals takes only a few seconds, then reverse the rudder, a little play with trims and she's ready to go. I don't know if the radio I got with the GL450 is the original one or if it has been replaced (I bought it as a used item see), or if it was an import and China flies very weird setups or what, but the transmitter seems to be a cross between Mode2 and Mode1, but neither actual one? Has anyone actually looked at the manual? You can see "POWER" (i.e. throttle) on the left lever up and down, and then "ascend/descend" on the right lever up and down. WEIRD>? Thanks again for all the help. Many kind regards, Rory.

PM  EMAIL  Attn:RR  Quote
WATCH
 1 page 831 views
Scorpion Power Scorpion Power
HelicopterRadio - Servo - Gyro - Gov - Batt › Century GL450 Tx seems different?
 Print TOPIC  Make Suggestion 

 4  Topic Subscribe

Tuesday, November 21 - 3:55 pm - Copyright © 2000-2017 RunRyder   EMAILEnable Cookies

Login Here
 New Subscriptions 
 Buddies Online