RunRyder RC
 3  Topic Subscribe
WATCH
 1 page 340 views
Scorpion Power Scorpion Power
HelicopterBeginners Corner › Blade 400 running in reverse
03-18-2009 06:55 AM  8 years agoPost 1
agj5489

rrNovice

lafayette,louisiana

My Posts: All  Forum  Topic

I changed my servos with jr and now my heli runs opposite the only thing that runs correct is my tail rudder. What did I do wrong I paid attention on how I removed the old servos.also If anyone get a elite do plus tell what you think if it's the sweetest heli ever made I love mine more than the blade.x

PM  EMAIL  Attn:RR  Quote
03-18-2009 07:05 AM  8 years agoPost 2
jjvwg

rrApprentice

Vail/Boulder, CO

My Posts: All  Forum  Topic

check finless's setup videos on helifreak for the 450. basically if all move in the wrong direction you just need to flip your swash mix from + to - or - to +. If two move one way and the other moves opposite your gonna have to fool with it a reverse at least one servo, maybe 2. good luck, shouldnt take too long to figure out.

Jeff

PM  EMAIL  GALLERY  Attn:RR  Quote
03-18-2009 08:16 AM  8 years agoPost 3
what_the_helli

rrKey Veteran

cookeville, tn USA

My Posts: All  Forum  Topic

start here dkshema has it all spelled out and simply explained how to get it moving correct
http://www.runryder.com/helicopter/t410466p1/

I put the fun in dysFUNctional :)
Team KBDD & Funding by TnPrintMasters.com

PM  EMAIL  GALLERY  Attn:RR  Quote
WATCH
 1 page 340 views
Scorpion Power Scorpion Power
HelicopterBeginners Corner › Blade 400 running in reverse
 Print TOPIC  Make Suggestion 

 3  Topic Subscribe

Monday, November 20 - 11:21 am - Copyright © 2000-2017 RunRyder   EMAILEnable Cookies

Login Here
 New Subscriptions 
 Buddies Online