RunRyder RC
 1  Topic Subscribe
WATCH
 1 page 362 views
Scorpion Power Scorpion Power
HelicopterAerial Photography and Video › Maxi-Joker 2 Futaba 14MZ Swash settings?
03-18-2009 02:53 AM  8 years agoPost 1
sixstringlz

rrNovice

Hillsboro, OH. USA

My Posts: All  Forum  Topic

I have been trying to transfer my settings over from my 9C to my 14MZ and I'm not having much luck. Could someone please give me which swash type to pick and the swash mix numbers to help me get started.

I have it setup for the 120 swash. I can get the elev. and alir. sevros moving in the right direction with the swash mix numbers. But when I move the collective the left servo looking from the back of the heli is the only one that moves and it will not move when I give alir. input??? Tried reversing the servos, but it didn't help.

Thanks for your help!

PM  EMAIL  GALLERY  Attn:RR
03-18-2009 09:26 AM  8 years agoPost 2
rroback

rrElite Veteran

Irvine (UCI), Ca

My Posts: All  Forum  Topic

read the manual. it sounds like you have the wrong swash selected, or your servos in the wrong spot on the receiver.

Rhett..... I can't fly, but the Profi sure can.

PM  EMAIL  GALLERY  Attn:RR
03-18-2009 09:46 PM  8 years agoPost 3
sixstringlz

rrNovice

Hillsboro, OH. USA

My Posts: All  Forum  Topic

Using the HR3(120) swash and I have the servos plugged into the same places that the 9c had them? There is no SR3 on the 14mz that I can find, like the 9c?

PM  EMAIL  GALLERY  Attn:RR
03-19-2009 02:49 AM  8 years agoPost 4
sixstringlz

rrNovice

Hillsboro, OH. USA

My Posts: All  Forum  Topic

Got it, thanks! Servos not in the right spot on the 14 channel rx.

PM  EMAIL  GALLERY  Attn:RR
WATCH
 1 page 362 views
Scorpion Power Scorpion Power
HelicopterAerial Photography and Video › Maxi-Joker 2 Futaba 14MZ Swash settings?
 Print TOPIC  Make Suggestion 

 1  Topic Subscribe

Friday, November 24 - 7:04 am - Copyright © 2000-2017 RunRyder   EMAILEnable Cookies

Login Here
 New Subscriptions 
 Buddies Online