RunRyder RC
 5  Topic Subscribe
WATCH
 1 page 2671 views
Scorpion Power Scorpion Power
HelicopterRadio - Futaba FASST › Futaba 14mz 2.4 glitch on elevator
03-17-2009 12:11 PM  8 years agoPost 1
Dan78

rrNovice

Australia

My Posts: All  Forum  Topic

Just wondering what the signs are of a worn pot in the radio.
My heli has started to get a small elevator glitch only in hover with the elevator stick just past centre.Its like a quick pulse of elevator movement like it centres for a split second then remembers your giving it slight forward elevator. It will then stop and be normal again then a few seconds later it will do it again. Thought it was a servo problem at first but i am having the same issue with all 3 of my helis. It only does it in hover near centre stick no where else.
Is this likely a pot issue or does the sticks need recalibrating? Any suggestions would be greatly appreciated.

Daniel

PM  EMAIL  Attn:RR  Quote
03-17-2009 02:58 PM  8 years agoPost 2
Kevin Dalrymple

rrKey Veteran

Indianapolis

My Posts: All  Forum  Topic

I had that on my Aleron pot. You will need a new pot. Send the radio back and they should fix it for free. They fixed mine for free.

PM  EMAIL  GALLERY  Attn:RR  Quote
03-17-2009 03:19 PM  8 years agoPost 3
rob_k

rrApprentice

Castle Rock, CO

My Posts: All  Forum  Topic

Yep, my 12Z (same pots) had the same issue on Rudder, Ail, and Pit a couple weeks ago. I sent it in and paid for express service and had it back in less than a week with no charge for the actual repair(all pots were replaced). The problem is gone now.

PM  EMAIL  GALLERY  Attn:RR  Quote
03-17-2009 04:29 PM  8 years agoPost 4
JimmyC

rrApprentice

Gaithersburg,​Maryland USA

My Posts: All  Forum  Topic

Just went through this with my 12z. I could see the aileron jumping on the servo monitor screen which verified it being in the radio. Sent it to hobby services and had it back with in a week. Changed pots, no charge. Great Service!

JimmyC

PM  EMAIL  GALLERY  Attn:RR  Quote
03-17-2009 10:01 PM  8 years agoPost 5
AlexV

rrApprentice

Dubai, UAE

My Posts: All  Forum  Topic

welcome to "worn pots community"!

Alexander

PM  EMAIL  GALLERY  Attn:RR  Quote
03-17-2009 10:58 PM  8 years agoPost 6
smallplanes

rrElite Veteran

S.C. ,SSA

My Posts: All  Forum  Topic

I'm glad you posted your findings as i've never hear of this problem with these radios. Now i will know what to look for if i have any of the same problems. Do you guys have a lot of flights on your radios?

Thanks


Spectra G 26cc
Jewel
Bat 27cc
Trex 700<br

PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
04-27-2009 12:46 AM  8 years agoPost 7
dogg5306

rrVeteran

Brussels, Belgium

My Posts: All  Forum  Topic

Is that service (getting all your pots replaced) supposed to be free even on more than 3 years Futaba radio?

PM  EMAIL  GALLERY  Attn:RR  Quote
04-27-2009 01:13 AM  8 years agoPost 8
Kevin Dalrymple

rrKey Veteran

Indianapolis

My Posts: All  Forum  Topic

Do you guys have a lot of flights on your radios?
Yes, I do. New pots are working well and it has been a year and a half since the service. Works great.
Is that service (getting all your pots replaced) supposed to be free even on more than 3 years Futaba radio?
You will have to call and find out. it was for me. The 14MZ is the best radio the futaba makes and they stand behind there products.

PM  EMAIL  GALLERY  Attn:RR  Quote
08-06-2010 09:35 PM  7 years agoPost 9
AnnihilaT

rrKey Veteran

The Netherlands

My Posts: All  Forum  Topic

I could kiss you all for this thread. I suddenly had my 14 MZ and Trex 700 doing this today to me for the first time in 1.5 years (same radio same heli nothing has changed) and it drove me mad trying to find the issue on the field today. My 14 mz is probably 4-5 years old (got it when they FIRST came out) so im almost certain this is the same issue i was seeing today. Gonna have to send it in for service.





A day without sunshine is like, well, night.

PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
08-06-2010 09:38 PM  7 years agoPost 10
steph280

rrElite Veteran

Irvine, California

My Posts: All  Forum  Topic

AnnihilaT do you use that same radio for the Mikrokopter?

PM  EMAIL  GALLERY  Attn:RR  Quote
08-07-2010 12:14 AM  7 years agoPost 11
AnnihilaT

rrKey Veteran

The Netherlands

My Posts: All  Forum  Topic

yeah i did at first but then i went back to a Futaba 9C so i could run 2.4Ghz video downlink... why ?





A day without sunshine is like, well, night.

PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
WATCH
 1 page 2671 views
Scorpion Power Scorpion Power
HelicopterRadio - Futaba FASST › Futaba 14mz 2.4 glitch on elevator
 Print TOPIC  Make Suggestion 

 5  Topic Subscribe

Wednesday, November 22 - 10:21 pm - Copyright © 2000-2017 RunRyder   EMAILEnable Cookies

Login Here
 New Subscriptions 
 Buddies Online