RunRyder RC
 2  Topic Subscribe
WATCH
 1 page 783 views
Scorpion Power Scorpion Power
Helicopter
e-
Outrage 200,G5,550,600,700
› Outrage 550 setup issue: Climb left, dropping​right!!
03-16-2009 07:19 PM  8 years agoPost 1
CoronaL

rrKey Veteran

Winnebago IL

My Posts: All  Forum  Topic

I'm sure it's a setup fubar on my part. I think most of my helis do this but the Outrage 550 is the worst. Not sure what I'm setting up wrong as I "think" I have swash level at mid/high/low positions. I've checked it, but I suppose I could just be wrong.

Anyway, problem is when I"m hovering and punch out for a fast climb, the heli will roll left and I need to correct with right aileron. If I push the collective negative the heli will pitch/roll right and need to correct with left aileron. Pretty sure it's doing it in Fast forward flight too. I don't notice it as much in slow flight, but maybe it's just not as pronounced. At first I thought it might be links being tight, but now I'm noticing it more now, b/c I'm watching for it, not b/c it's actually getting worse. Then I flew my TREX700 the other day, and I noticed with that heli too I was getting that issue. Not nearly as bad, but figured I would ask around and see if I set something up wrong.

I had never used expo in the pitch curve or swash mix before. I tried setting the expo to "on" in the pitch curve menu of the 12x and didn't notice any improvement in flight.

Can anyone explain to me if I'm setting something up wrong, what to correct etc...??? Or is this somewhat normal due to torque of the heli.

thx

PM  EMAIL  GALLERY  Attn:RR  Quote
03-16-2009 07:25 PM  8 years agoPost 2
FlaG8r

rrElite Veteran

Florida

My Posts: All  Forum  Topic

Did you use a swash leveler during setup? Considering you said it happens on all helis that's prob your issue. Although it might look level throughout travel, you need to use a tool. Also, turn on swash mix expo. You'll need to recheck your collective pitch afterwards as it usually shrinks it down a degree or two.

Life is tough, it's tougher if you're stupid

PM  EMAIL  GALLERY  Attn:RR  Quote
03-16-2009 08:22 PM  8 years agoPost 3
CoronaL

rrKey Veteran

Winnebago IL

My Posts: All  Forum  Topic

well I checked the swash with a leveling too on the 500esp and the 700, but not the outrage 550 as I didn't have a tool for that one. I did use a bubble level on that though side to side, front to back etc...
I'll turn on swash mix expo and report back later.

thx for the tips
John

edit: expo in swash mix turned on
will see what happens
thx again

PM  EMAIL  GALLERY  Attn:RR  Quote
03-16-2009 11:33 PM  8 years agoPost 4
Eury

rrProfessor

Dover NH

My Posts: All  Forum  Topic

Easy fix, the servo on one side is going a little farther than the one on the other, so lower the end point of the right servo on top, and lower it on the same servo at the lower end (If I'm picturing it right in my head). Just do 1 or 2 points and keep tuning it until it stays level.

Nick Crego

Citizen #0168

PM  EMAIL  GALLERY  Attn:RR  Quote
03-17-2009 03:17 AM  8 years agoPost 5
CoronaL

rrKey Veteran

Winnebago IL

My Posts: All  Forum  Topic

swash expo fixed about 80% of it

other 20% I'm guessing is from totally shot dampners at 21 flights and one grips radial bearing are shot. One is about to lock or fall apart .

PM  EMAIL  GALLERY  Attn:RR  Quote
03-17-2009 04:17 AM  8 years agoPost 6
CoronaL

rrKey Veteran

Winnebago IL

My Posts: All  Forum  Topic

pics

PM  EMAIL  GALLERY  Attn:RR  Quote
WATCH
 1 page 783 views
Scorpion Power Scorpion Power
Helicopter
e-
Outrage 200,G5,550,600,700
› Outrage 550 setup issue: Climb left, dropping​right!!
 Print TOPIC  Make Suggestion 

 2  Topic Subscribe

Thursday, November 23 - 5:46 am - Copyright © 2000-2017 RunRyder   EMAILEnable Cookies

Login Here
 New Subscriptions 
 Buddies Online