RunRyder RC
 1  Topic Subscribe
WATCH
 1 page 527 views
Scorpion Power Scorpion Power
HelicopterAlignT-REX 700N › RF Glitch or SZ surge?
03-16-2009 11:05 AM  8 years agoPost 1
Ladymagic

rrKey Veteran

South Korea

My Posts: All  Forum  Topic

I need your input on a few things. I have a friend who recently installed the 760 in his 700 and it performs okay (better than the 770), but since then, he's had an annoying glitching problem. Actually, neither he or I have any idea if it even is a "glitch" or some sort of surging problem with the SZ for sure.

I am curious if any of you have ever had any issues with your SZ dropping RPM's suddenly and then returning to normal within a few seconds. Glow plug has been swapped, the head is tight and there are no known leaks. We've tried tuning the motor and nothing seems to help. Maybe the pump is crapping out. The engine it's self is fairly new and only has about 5 gallons through it since last September. He's always flown it slightly rich.

With that said, I came to the conclusion that there probably is an 2.4ghz RF problem somewhere between the 9303 and the Rx and the heli might be going into failsafe. The thing about that is, the heli still has full cyclic and rudder response so, technically, it's not in failsafe right? He has his failsafe set for the engine to enter idle and all surfaces are to report to neutral. In a full lock out nothing would should respond right? The wires have been checked for frays and loose plugs as well. So, that brings the problem back to the engine. In any case you probably have some insight that might prove to be quite useful. The 700 is grounded in fear of a fatal failure if it actually turns out to be a RF issue.

Thanks in advance for your input guys

Mellisa

PM  EMAIL  GALLERY  Attn:RR
03-16-2009 11:35 AM  8 years agoPost 2
Bonez

rrApprentice

Cabot, Arkansas

My Posts: All  Forum  Topic

r u running the stock gov? that could be a problem of the engine dropping rpm.. might be going bad..

PM  EMAIL  GALLERY  Attn:RR
03-16-2009 12:05 PM  8 years agoPost 3
Ladymagic

rrKey Veteran

South Korea

My Posts: All  Forum  Topic

Actually, that's probably a great idea. I didn't think to check that. I have another Align gov that he can try in his 700.

That's why it's always good to ask around. I never thought to check the Gov. I haven't heard of any issues with the Align gov. Have you had any issues? If so, was is your gov or the sensor?

Also, if there was a govorner failure, wouldn't the Rx pass the signal back to the Tx's throttle curve?

Mellisa

PM  EMAIL  GALLERY  Attn:RR
03-16-2009 12:47 PM  8 years agoPost 4
Bonez

rrApprentice

Cabot, Arkansas

My Posts: All  Forum  Topic

i havent had any issue with the gov but i have read in a few cases of it messing up.. well thats goes for any gov..

yes if the gov goes bad it goes back to the radio throttle curves, but if ur radio throttle curve is lower then what the gov was at the engine will down speed, now the gov starts working again the engine will up speed. thats when u get the surge..

oh, if it was a radio glitch, and you think u went into fail safe, when u land check the rx and remote rx.. it should have blinking lights..

PM  EMAIL  GALLERY  Attn:RR
WATCH
 1 page 527 views
Scorpion Power Scorpion Power
HelicopterAlignT-REX 700N › RF Glitch or SZ surge?
 Print TOPIC  Make Suggestion 

 1  Topic Subscribe

Monday, November 20 - 11:26 am - Copyright © 2000-2017 RunRyder   EMAILEnable Cookies

Login Here
 New Subscriptions 
 Buddies Online