RunRyder RC
 5  Topic Subscribe
WATCH
 3 pages [ <<    <    ( 1 )     2      3     NEXT    >> ] 2008 views
Scorpion Power Scorpion Power
Helicopter
e-
MSH Protos, Mini Protos
› Now we got it straitened out!
12-27-2008 10:58 PM  8 years agoPost 1
McRex

rrVeteran

AZ-USA

My Posts: All  Forum  Topic

OK, this is my second attempt at putting together my Protos tail assembly, with all new hardware, and still the tail does not feel smooth like it should. I have used the included reamer, and the links feel smooth, everything is smooth until it's all put together. It's so stiff, that the tail hunts as if there was too much gain, but if you turn down the gain, it just will spin 180 degrees then come back. I need help! I don't have a local flying club with any helicopter help, just all plankers. Is there something else that could be wrong here? Any ideas would bee appreciated.

Daniel, AMA # 923248

PM  EMAIL  GALLERY  Attn:RR
12-27-2008 11:14 PM  8 years agoPost 2
CatchMyStratus

rrNovice

Ohio

My Posts: All  Forum  Topic

Is it stiff through the entire range of travel? Or just at the extremes? Mine will get slightly stiff at the extremes (mainly the inner extreme) but I will never setup my tail to operate with that much pitch.

Other than that, you must make sure the brass slider plate is perfectly 90 deg when screwed into the plastic slider housing.

Do you have the correct metal bushing (tube) inside the slider arm bearing assembly (pivot point)? Is that pivot point smooth or tightened too much?

I noticed the pushrod links can also make a big difference. Make sure they rotate on the ball easily, but don't over-do it or they get sloppy.

PM  EMAIL  Attn:RR
12-27-2008 11:30 PM  8 years agoPost 3
McRex

rrVeteran

AZ-USA

My Posts: All  Forum  Topic

It is definitely stiffer at the extremes, but that's not what worries me, it is stiff throughout the whole range of motion. I am used to how smooth Align heli's are, so this just bugs me. Plus as I mentioned, I believe this making my tail wag. I have checked all the things you mentioned. I'm at my wits end with it, I'm close to getting rid of this thing and getting a T-Rex 500...just kidding!

Daniel, AMA # 923248

PM  EMAIL  GALLERY  Attn:RR
12-27-2008 11:31 PM  8 years agoPost 4
Ronald Thomas

rrMaster

Gainesville, Fl, USA

My Posts: All  Forum  Topic

Did you size the ball links in the tail?

Team MikadoUSA 480XXTreme, 550SX, 600SX, 700XXTreme, 800XXTreme!!

PM  EMAIL  GALLERY  Attn:RR
12-27-2008 11:45 PM  8 years agoPost 5
McRex

rrVeteran

AZ-USA

My Posts: All  Forum  Topic

yep, with the included sizer.

Daniel, AMA # 923248

PM  EMAIL  GALLERY  Attn:RR
12-27-2008 11:55 PM  8 years agoPost 6
CatchMyStratus

rrNovice

Ohio

My Posts: All  Forum  Topic

Take the links off the tail grips and try moving the slider. Does it improve? Do this without the pushrod.

Also oil the shaft with light oil if you haven't already.

PM  EMAIL  Attn:RR
12-28-2008 12:18 AM  8 years agoPost 7
McRex

rrVeteran

AZ-USA

My Posts: All  Forum  Topic

it is smoother with the grips disconnected, the pushrod, didn't make much difference. I have already tried using oil, didn't help much.

Daniel, AMA # 923248

PM  EMAIL  GALLERY  Attn:RR
12-28-2008 12:34 AM  8 years agoPost 8
CatchMyStratus

rrNovice

Ohio

My Posts: All  Forum  Topic

That tells me you either have tight links or your slider was threaded while misaligned. But I could be wrong.

PM  EMAIL  Attn:RR
12-28-2008 01:23 AM  8 years agoPost 9
tchavei

rrProfessor

Portugal

My Posts: All  Forum  Topic

Sorry to intrude here (I don't own a protos... yet anyway) but maybe a couple of pics of the tail assembly would help the experts around?

Tony


--------------------
"Perfection and patience usually walk side by side..."

PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR
12-28-2008 01:30 AM  8 years agoPost 10
Ronald Thomas

rrMaster

Gainesville, Fl, USA

My Posts: All  Forum  Topic

Here ya go:

Sorry it is the only one I have right now.....Ron

Team MikadoUSA 480XXTreme, 550SX, 600SX, 700XXTreme, 800XXTreme!!

PM  EMAIL  GALLERY  Attn:RR
12-28-2008 01:51 AM  8 years agoPost 11
tchavei

rrProfessor

Portugal

My Posts: All  Forum  Topic

Well actually I was asking McRex to post a pic of his to maybe shed some light on why his tail isn't smooth

Yours looks pretty lubrificated to me

Tony


--------------------
"Perfection and patience usually walk side by side..."

PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR
12-28-2008 01:51 AM  8 years agoPost 12
Ronald Thomas

rrMaster

Gainesville, Fl, USA

My Posts: All  Forum  Topic

Team MikadoUSA 480XXTreme, 550SX, 600SX, 700XXTreme, 800XXTreme!!

PM  EMAIL  GALLERY  Attn:RR
12-28-2008 02:50 AM  8 years agoPost 13
S76 Mech

rrElite Veteran

Hatboro, Pa.

My Posts: All  Forum  Topic

ha, he said your shaft looks well lubricated

on a side note, did you try sanding down the tailshaft with some emery and oil, bet that would smooth things up!

Gaui Greatness X7, X5, NX4, X3

PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR
12-28-2008 03:46 AM  8 years agoPost 14
tchavei

rrProfessor

Portugal

My Posts: All  Forum  Topic

yeah well it depends on the hand job lol.

I'm starting to itch for a proto myself so I can lubricate my shaft too hahahha

Tony


--------------------
"Perfection and patience usually walk side by side..."

PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR
12-28-2008 04:14 AM  8 years agoPost 15
McRex

rrVeteran

AZ-USA

My Posts: All  Forum  Topic

nothing seems to be misaligned, and the slider was not threaded crooked. I will try to get some pics up in a few, my internet isn't the fastest, so it takes a bit. I did try sanding down the original one, and that seemed to make things worse. The only thing I keep coming back to is the links. Maybe my ball link sizer is junk?

Daniel, AMA # 923248

PM  EMAIL  GALLERY  Attn:RR
12-28-2008 04:20 AM  8 years agoPost 16
Ronald Thomas

rrMaster

Gainesville, Fl, USA

My Posts: All  Forum  Topic

Did you follow Corrado's instructions on how to use it?

Team MikadoUSA 480XXTreme, 550SX, 600SX, 700XXTreme, 800XXTreme!!

PM  EMAIL  GALLERY  Attn:RR
12-28-2008 04:48 AM  8 years agoPost 17
McRex

rrVeteran

AZ-USA

My Posts: All  Forum  Topic

What did Corrado say specifically? I just have the manual.

Daniel, AMA # 923248

PM  EMAIL  GALLERY  Attn:RR
12-28-2008 04:54 AM  8 years agoPost 18
McRex

rrVeteran

AZ-USA

My Posts: All  Forum  Topic

Here are some pics

Daniel, AMA # 923248

PM  EMAIL  GALLERY  Attn:RR
12-28-2008 05:03 AM  8 years agoPost 19
McRex

rrVeteran

AZ-USA

My Posts: All  Forum  Topic

It definitely has to do with something between the pitch slider out, because it only gets tight when the slider i connected to the grips? But as I said, I have used the ball link sizing tool, and have re- verified the fact that the slider is assembled straight, I have no clue!!!!!

Daniel, AMA # 923248

PM  EMAIL  GALLERY  Attn:RR
12-28-2008 08:30 AM  8 years agoPost 20
Corrado-Italy

rrVeteran

Italy

My Posts: All  Forum  Topic

Try to rotate the tail pitch boss, does it rotate free? Maybe an old boss with tight recess?

Another thing to check is the screw that keeps the lever in place, is it too tight?

Corrado

Corrado

PM  EMAIL  HOMEPAGE  Attn:RR
WATCH
 3 pages [ <<    <    ( 1 )     2      3     NEXT    >> ] 2008 views
Scorpion Power Scorpion Power
Helicopter
e-
MSH Protos, Mini Protos
› Now we got it straitened out!
 Print TOPIC  Make Suggestion 

 5  Topic Subscribe

Thursday, November 23 - 3:54 am - Copyright © 2000-2017 RunRyder   EMAILEnable Cookies

Login Here
 New Subscriptions 
 Buddies Online