RunRyder RC
 0  Topic Subscribe
WATCH
 1 page 453 views
Scorpion Power Scorpion Power
HelicopterMain Discussion › Align 450 v2 Speed control Issues
12-24-2008 01:29 PM  8 years agoPost 1
Earthauger

rrNovice

Wellington,​Florida-USA

My Posts: All  Forum  Topic

Has anyone had problems in the past with the programming on the speed control (RCE-BL-35X)screwing up? I noticed that all my batteries for my 450 were starting to give me problems. That being after a full, good ,proper charge, it would fly maybe 1 or 2 minutes and the tail wag would start.. Yes the batteries are good, yes they were charged corretly, never have been drained below 80% or rated capacity.. I fly all my electrics including my 600E 4.30 min before landing. This usually give me plenty of time left on the batteries..
Jeff polisena reprogrammed it at the field and then test flew it, it was awesome for about 4 full batteries, then for no reason it started acting up again.. I have ordered a new speed control a will install it when it arrives. However I was wondering why and how this occurs?
Thanks Ted (Earthauger)
PS Thank to Jeff Polisena, this guy know heli's and is a true master in all areas of the hobby

Live Free or Die! USA Forever!!!!!!!!

PM  EMAIL  GALLERY  Attn:RR  Quote
12-24-2008 02:11 PM  8 years agoPost 2
marco

rrApprentice

Santa Rosa , Ca -​USA

My Posts: All  Forum  Topic

Mine just started to do the same thing , but I have alot more flights on it than you . Mine had been sitting awile before my latest flights , so I thought before I bought a new ESC I would try to cycle the batteries a few times . Since you are a step ahead of me with a new ESC on the way , let us know if that solves the problem .

PM  EMAIL  GALLERY  Attn:RR  Quote
12-24-2008 02:15 PM  8 years agoPost 3
Skarn

rrVeteran

Pasadena, MD

My Posts: All  Forum  Topic

What LVC do you have it programmed for? I believe mine did that when I first got it....so I reprogrammed it for I believe MID LVC which was 3.2v per cell and the problem went away.

Skarn

It's better to burn out than to fade away...

PM  EMAIL  Attn:RR  Quote
12-24-2008 07:31 PM  8 years agoPost 4
Earthauger

rrNovice

Wellington,​Florida-USA

My Posts: All  Forum  Topic

I set the LVC to the high stick position which is the lowest voltage I beleive, it seems like if you realy load the motor up, thats when the problem seem to happen. I have two 450 and the other one has no problems. As for the lipo's, I been told that they need not be cycled. However I have cycled them out just to see that they were good. I am just about sure it is in the speed control, just cant figure out why??:

Live Free or Die! USA Forever!!!!!!!!

PM  EMAIL  GALLERY  Attn:RR  Quote
WATCH
 1 page 453 views
Scorpion Power Scorpion Power
HelicopterMain Discussion › Align 450 v2 Speed control Issues
 Print TOPIC  Make Suggestion 

 0  Topic Subscribe

Tuesday, November 21 - 7:52 am - Copyright © 2000-2017 RunRyder   EMAILEnable Cookies

Login Here
 New Subscriptions 
 Buddies Online