RunRyder RC
 0  Topic Subscribe
WATCH
 1 page 586 views
Scorpion Power Scorpion Power
HelicopterAlignT-REX 700N › Tail Rod Control Arm Problem
12-22-2008 10:03 PM  8 years agoPost 1
matt155

rrNovice

Pembroke Pines,​Florida-USA

My Posts: All  Forum  Topic

I am in the middle of my TRex 700 build. The tail rod control arm ball that mounts upright towards the inside of the frame makes contact with the ridge that runs down the middle of the tail boom mount on the frame when the ball link is installed. Has anyone had this problem? I think the simple fix is just to turn thte ball upside down but from all of the pictures I have seen no one has had to do this for proper clearance. Am I doing something wrong?

PM  EMAIL  GALLERY  Attn:RR  Quote
12-22-2008 10:06 PM  8 years agoPost 2
george0079

rrElite Veteran

USA

My Posts: All  Forum  Topic

It sounds like you have the block mounted backwards, which puts the arm too far into the frame....

A pic would really help

Hell... I can fix that.
Uh oh..
Nope.
It's ***ked!!!
RE-KIT!!!!!

PM  EMAIL  GALLERY  Attn:RR  Quote
12-23-2008 04:45 PM  8 years agoPost 3
floop

rrVeteran

Southern, NJ

My Posts: All  Forum  Topic

How far do you need to push it for it to hit? I think at the extreme travel mine hits but the tail servo doesn't use that much travel.

IT's what I do.

PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
WATCH
 1 page 586 views
Scorpion Power Scorpion Power
HelicopterAlignT-REX 700N › Tail Rod Control Arm Problem
 Print TOPIC  Make Suggestion 

 0  Topic Subscribe

Saturday, November 18 - 8:32 am - Copyright © 2000-2017 RunRyder   EMAILEnable Cookies

Login Here
 New Subscriptions 
 Buddies Online