RunRyder RC
 2  Topic Subscribe
WATCH
 1 page 348 views
Scorpion Power Scorpion Power
Helicopter
e-
Align
T-REX 600 › 600e- esp main shaft colar problem...
12-22-2008 02:52 PM  8 years agoPost 1
6983868850

rrNovice

Athens Greece

My Posts: All  Forum  Topic

both my 600e and esp after 2-3 hard flights have a little gap when i lift the heli from the grips (main shaft goes up and down).
i tried new colar and even i placed a second one on the second bearing block but no result, after all the tightening again the same result.
i noticed that the bottom of the colar rubs on the top bearing block and this causes the 2-3 mm gap
does anyone faces the same problem as me?
how can i counteract this?
thanks in advance!

kmiglis Get airborne..!!!!! TDRigid

PM  EMAIL  Attn:RR  Quote
12-22-2008 03:18 PM  8 years agoPost 2
JSTAGE

rrApprentice

Visalia, CA

My Posts: All  Forum  Topic

colar

Do you have the colar facing the right way with the ridge pointing down to the bearing. I have both of those heli's with no problem.
Jeff

NITRO AND FLYBARS ARE A THING OF THE PAST

PM  EMAIL  GALLERY  Attn:RR  Quote
12-22-2008 03:35 PM  8 years agoPost 3
6983868850

rrNovice

Athens Greece

My Posts: All  Forum  Topic

if i got it right and if we imagine the colar as a cone the smaller diameter goes down?
gee i have placed it upside down thanks very very much!!!!

kmiglis Get airborne..!!!!! TDRigid

PM  EMAIL  Attn:RR  Quote
12-22-2008 03:38 PM  8 years agoPost 4
JSTAGE

rrApprentice

Visalia, CA

My Posts: All  Forum  Topic

glad I could help

NITRO AND FLYBARS ARE A THING OF THE PAST

PM  EMAIL  GALLERY  Attn:RR  Quote
WATCH
 1 page 348 views
Scorpion Power Scorpion Power
Helicopter
e-
Align
T-REX 600 › 600e- esp main shaft colar problem...
 Print TOPIC  Make Suggestion 

 2  Topic Subscribe

Tuesday, November 21 - 7:48 am - Copyright © 2000-2017 RunRyder   EMAILEnable Cookies

Login Here
 New Subscriptions 
 Buddies Online