RunRyder RC
 4  Topic Subscribe
WATCH
 1 page 1096 views POST REPLY
Scorpion Power Scorpion Power
Helicopter
e-
Align
T-REX 500 › Static electricity
12-09-2008 08:41 PM  8 years agoPost 1
michalss

rrNovice

France - Lyon

My Posts: All  Forum  Topic

Hi,

This is my configuration : T-Rex500 CF + carbon boom tail + aluminium AC tail box + Spektrum 2.4 GH AR7000 + sat on CF frame + tail belt.
May i risk in this case to have troubles due to static electricity (top of reception) ?

Anyone can help me about this ?

Best regards. Stan

PM  EMAIL  GALLERY  Attn:RR  Quote
12-09-2008 09:24 PM  8 years agoPost 2
Lomcevek1

rrApprentice

Eagle River, Alaska

My Posts: All  Forum  Topic

I am running into the same issue. I have grounded about all I can think of and the gyro still goes nuts on occasion.

PM  EMAIL  GALLERY  Attn:RR  Quote
12-09-2008 10:12 PM  8 years agoPost 3
Helipilot01

rrApprentice

ColliervilleTn

My Posts: All  Forum  Topic

I had the exact same problems using almost the same equipment. The cause is the receiver location. Move the receiver out of the position shown during the build and move it to the lower plate. I didn't believe it was this easy either but Charles Anderson, IRCHA V.P., showed this to me at a funfly this year. I've had over a dozen flights since that were totally glitch free.

PM  EMAIL  GALLERY  Attn:RR  Quote
12-09-2008 10:53 PM  8 years agoPost 4
lugnutz

rrApprentice

trenton,nj

My Posts: All  Forum  Topic

i don't understand what you guys are doing but i have never had a static problem with this heli,and i have over 250 flights ,i think most of the problems that i have read about are do to the fact the receiver is not in the correct place away from higher voltage wires if anyone can post pictures of their layout of electronics that would help

PM  EMAIL  GALLERY  Attn:RR  Quote
12-10-2008 08:21 PM  8 years agoPost 5
Andy.Kim

rrVeteran

Seattle, WA

My Posts: All  Forum  Topic

keeping the belt lubed helps too, but no more static issues since i went TT

PM  EMAIL  GALLERY  Attn:RR  Quote
12-10-2008 08:32 PM  8 years agoPost 6
BLUETHUNDER

rrVeteran

Glass City

My Posts: All  Forum  Topic

PM  EMAIL  Attn:RR  Quote
12-10-2008 11:19 PM  8 years agoPost 7
MU300PILOT

rrApprentice

Florida

My Posts: All  Forum  Topic

I have the new ESP 500 super pro with all the up grades should I have this problem?

PM  EMAIL  GALLERY  Attn:RR  Quote
12-10-2008 11:41 PM  8 years agoPost 8
Andy.Kim

rrVeteran

Seattle, WA

My Posts: All  Forum  Topic

I noticed glitches in my servo when I had the stock belt drive tail assembly and once I upgraded to TT I never had an issue. I've "heard" that ESD can still occur with the TT but I never experienced it.

PM  EMAIL  GALLERY  Attn:RR  Quote
12-11-2008 12:58 AM  8 years agoPost 9
BLUETHUNDER

rrVeteran

Glass City

My Posts: All  Forum  Topic

Even with a TT you still have ESD from the main gear and TT
drive gear that contacts the main gear. A TT will not stop
these two points of ESD. (See Video)

PM  EMAIL  Attn:RR  Quote
12-11-2008 01:07 AM  8 years agoPost 10
Double Springs

rrApprentice

Cookeville, TN

My Posts: All  Forum  Topic

Never had any static problems here either, just spray a shot of silicone every once in a while, I've seen the pros do this on other belt drive machines also.

Do or Do Not, There is No Try

PM  EMAIL  GALLERY  Attn:RR  Quote
12-11-2008 10:01 AM  8 years agoPost 11
Jamin_00

rrApprentice

Essex UK

My Posts: All  Forum  Topic

I've always had the rx on the bottom tray and never had an issue even when I was using the belt drive

PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
12-11-2008 11:33 AM  8 years agoPost 12
cwright

rrKey Veteran

Blossvale New York

My Posts: All  Forum  Topic

Here is my receiver layout. The receiver is mounted on the lower frame in the rear. I am running the torque tube as well. Never had a static issue with this arrangement. Chuck

PM  EMAIL  GALLERY  Attn:RR  Quote
12-11-2008 01:08 PM  8 years agoPost 13
mmc205

rrElite Veteran

PA - USA

My Posts: All  Forum  Topic

mine is the same as yours cw, except my main ain sattelite reciever are swapped (for easy access to servo leads for programming, etc) I also have hand zero problems with a my belt drive static. I'm also using a CC BEC.

***Logo 600 vbar***Henseleit TDR vbar***

PM  EMAIL  GALLERY  Attn:RR  Quote
03-04-2009 08:43 AM  8 years agoPost 14
michalss

rrNovice

France - Lyon

My Posts: All  Forum  Topic

Thats ok, no problem

Finaly,

- i put 2.4 ghz spektrum AR7000 to the lower place in the frame
- do contact beetween tail boom and metal ac
- do contact beetween tail boom and metal frame support (i have CopterX CX500 SE)
- place rx satelite in from of the av/rear cyclic servo but on the other frame side

It works perfect. No problem with my belt transmission.

Stan

[img]http://runryder.com/rrpw.htm?d=/helicopter/gallery/69311/&i=11&a=0&s=0[/img]

PM  EMAIL  GALLERY  Attn:RR  Quote
WATCH
 1 page 1096 views POST REPLY
Scorpion Power Scorpion Power
Helicopter
e-
Align
T-REX 500 › Static electricity
 Print TOPIC  Make Suggestion 

 4  Topic Subscribe

Friday, October 20 - 2:47 am - Copyright © 2000-2017 RunRyder   EMAILEnable Cookies

Login Here
 New Subscriptions 
 Buddies Online