RunRyder RC
 2  Topic Subscribe
WATCH
 1 page 689 views POST REPLY
Scorpion Power Scorpion Power
Helicopter
e-
Blade
Blade CX › 2 Tail won't hold
07-14-2008 03:49 AM  9 years agoPost 1
!2Old2Fly

rrKey Veteran

North Bend, WA

My Posts: All  Forum  Topic

I've had my CX2 since Christmas.
It has a fair amount of flight time on now, and all the sudden the tail won't hold at all. I have almost full right trim in it to get it stay.

My guess is the motor(s) are going bad.
Any other thoughts on what could be causing it? It has flown fine up until now. And no, it hasn't suffered a major crash, and the shafts are not bent (checked that already).

I figure it's either the motors going, or a bearing...?

I'd appreciate any thoughts on this.

Yet Anohter IT Worker

PM  EMAIL  Attn:RR
07-14-2008 09:16 AM  9 years agoPost 2
StevenT

rrVeteran

Dallas, GA USA

My Posts: All  Forum  Topic

Well if you've had it that long then I would guess you know what your doing when it comes to the 4in1. So, if it's not that, I would say it is a motor problem.

Steven

Shhh, don't tell the wife.

PM  EMAIL  GALLERY  Attn:RR
07-14-2008 01:22 PM  9 years agoPost 3
speeddemon370

rrVeteran

Spruce Grove, Alberta, Canada

My Posts: All  Forum  Topic

The 4in1 dosen't last forever. I'll bet that's where your problem is. Buy a new one and fly again. Doubtful it's a motor but it's not impossible. If it's not the 4in 1 then it's probably a motor or a bearing that got all gummy. You do know about the pot adjustment on the 4in1 right?

with 2 ears and 1 mouth you should listen twice as much as you talk

PM  EMAIL  HOMEPAGE  Attn:RR
WATCH
 1 page 689 views POST REPLY
Scorpion Power Scorpion Power
Helicopter
e-
Blade
Blade CX › 2 Tail won't hold
 Print TOPIC  Make Suggestion 

 2  Topic Subscribe

Monday, September 25 - 5:27 am - Copyright © 2000-2017 RunRyder   EMAILEnable Cookies

Login Here
 New Subscriptions 
 Buddies Online