RunRyder RC
 4  Topic Subscribe
WATCH
 1 page 285 views POST REPLY
Scorpion Power Scorpion Power
07-14-2008 03:46 AM  9 years agoPost 1
!2Old2Fly

rrKey Veteran

North Bend, WA

My Posts: All  Forum  Topic

Okay, I know, this isn't a blade group...
But...

I've had my CX2 since Christmas. Lately, the tail won't hold at all. I have almost full right trim on it to get it to stay straight.

Sooo... Any guesses on what's causing it?
My guess is one of the motors is getting weak, and won't hold. I has a fair amount of flight time (no, I wasn't counting, or logging..).

Any ideas?

Thanks!

Yet Anohter IT Worker

PM  EMAIL  Attn:RR
07-14-2008 03:48 AM  9 years agoPost 2
norsman

rrKey Veteran

paradise PA

My Posts: All  Forum  Topic

Did you mess with the motor pot on the 3in1 ??

PM  EMAIL  GALLERY  Attn:RR
07-14-2008 03:53 AM  9 years agoPost 3
!2Old2Fly

rrKey Veteran

North Bend, WA

My Posts: All  Forum  Topic

Nope, haven't touched it.
Just over the last few flights, it has gotten progressively worse, until now I have almost full right trim in to get it to hold.

When it started getting really bad, I did go in and try to adjust the proportional to see if I could get it out, but with no success.

FWIW: The motors are HOT at the end of flying. Particularly the rigth (upper rotor) one.

Yet Anohter IT Worker

PM  EMAIL  Attn:RR
07-14-2008 11:17 PM  9 years agoPost 4
rsking45

rrNovice

ny

My Posts: All  Forum  Topic

Sounds like the problem I had.I sent 3in1 back to Horizon,they sent me a new one and problem fixed.

PM  EMAIL  Attn:RR
07-15-2008 12:04 AM  9 years agoPost 5
Gregor99

rrElite Veteran

Western Wa

My Posts: All  Forum  Topic

It could be the 3in1 and or one of motors getting soft. I'd first try adjusting the 3in1. Then it's crap shoot whether you try new motors or a new 3in1. If you plan on keeping the CX for a while, I'd start with the new motors. That way if its the 3in1 at least you get some rock'n new motors.

http://www.xtreme-production.com/xt...emart&Itemid=31

http://www.xtreme-production.com/xt...emart&Itemid=31

Revolectrix Beta Team

PM  EMAIL  GALLERY  Attn:RR
07-15-2008 01:55 AM  9 years agoPost 6
!2Old2Fly

rrKey Veteran

North Bend, WA

My Posts: All  Forum  Topic

Sounds like the problem I had.I sent 3in1 back to Horizon,they sent me a new one and problem fixed.
Ya know, I hadn't thought about getting a hold of Horizon. It's worth a check. After that, new motors. Maybe some of the Xtreme High Performance ones (thanks Gregor!).

Funny thing is, my little walkera needs a new 4-in-1 also. Seems to be a local epidemic!

Yet Anohter IT Worker

PM  EMAIL  Attn:RR
07-15-2008 01:57 AM  9 years agoPost 7
!2Old2Fly

rrKey Veteran

North Bend, WA

My Posts: All  Forum  Topic

It could be the 3in1 and or one of motors getting soft. I'd first try adjusting the 3in1. Then it's crap shoot whether you try new motors or a new 3in1. If you plan on keeping the CX for a while, I'd start with the new motors. That way if its the 3in1 at least you get some rock'n new motors.
It really is a coin toss isn't it?
It could be either one. I'll try the Horizon avenue first though. If they replace it, then I'm ahead, and maybe I can afford those new high performance motors!

Yet Anohter IT Worker

PM  EMAIL  Attn:RR
WATCH
 1 page 285 views POST REPLY
Scorpion Power Scorpion Power
 Print TOPIC  Make Suggestion 

 4  Topic Subscribe

Tuesday, September 26 - 4:41 am - Copyright © 2000-2017 RunRyder   EMAILEnable Cookies

Login Here
 New Subscriptions 
 Buddies Online