RunRyder RC
 3  Topic Subscribe
WATCH
 1 page 439 views
Scorpion Power Scorpion Power
Helicopter
e-
Mikado
Other › Power troubles
07-09-2008 01:36 AM  9 years agoPost 1
EricBrandenburg

rrApprentice

Milwaukee,WI

My Posts: All  Forum  Topic

Hi guys, I got a chance to maiden my Logo 600 today, and about 30 seconds or so into the flight the motor shut down and i had to auto it in, luckily no damage. It is set up with an actro 32-3, castle 110 HV esc and a 10s 5350 flight power pack. I was doing a roll doing straight down and backwards when it happened. The motor and esc and packs were not hot, the motor was slightly warmer than the ambient temp. My esc settings were the new 2.0 firmware, heli fixed andpoints, overcurrent disabled, 30v cut off, and I has the throttle at 90% across the board. The esc has that toasted electronics sort of smell, so I'm guessing the problem is coming from it. I had this same esc in a 12s Ion for about 5-10 flights and hadn't had any problems with it on the old 1.56 firmware. Anybody have any ideas?
Eric

Spending money I don't have on things I don't need to impress people I don't know

PM  EMAIL  GALLERY  Attn:RR  Quote
07-09-2008 01:40 AM  9 years agoPost 2
Ronald Thomas

rrMaster

Gainesville, Fl, USA

My Posts: All  Forum  Topic

If it smells toasted, don't fly it. Call Castle and see if they can advise....Ron

Team MikadoUSA 480XXTreme, 550SX, 600SX, 700XXTreme, 800XXTreme!!

PM  EMAIL  GALLERY  Attn:RR  Quote
07-09-2008 03:22 AM  9 years agoPost 3
HeliCSR

rrApprentice

Hesperia, Ca, US

My Posts: All  Forum  Topic

ESC

I once had a jeti-opto that would just turn off the motor, then I had to auto it down.

It would do it every flight, nothing wrong with the batteries, voltage
all good.

It would do it after 1-2 min, every time. so I bought another esc, and everyting was fixed.

If it smells burnt, dont fly I agree. Buy a differant ESC, I had castle, I like the 25 amp one, I bought the 40 amp one and did not like it.

PM  EMAIL  HOMEPAGE  Attn:RR  Quote
07-09-2008 06:24 AM  9 years agoPost 4
Carl Bonta

rrApprentice

Elgin, IL USA

My Posts: All  Forum  Topic

Static from the belt blew the controller, you need to run a drain wire from the neg. on the controller to a self tapping thru the frame and into the boom. We had the same thing happen during spool up. on hv85

PM  EMAIL  Attn:RR  Quote
07-09-2008 07:25 PM  9 years agoPost 5
EricBrandenburg

rrApprentice

Milwaukee,WI

My Posts: All  Forum  Topic

Interesting, I do have my esc lead going near the boom clamp, so in any event the esc is toast then?

Spending money I don't have on things I don't need to impress people I don't know

PM  EMAIL  GALLERY  Attn:RR  Quote
WATCH
 1 page 439 views
Scorpion Power Scorpion Power
Helicopter
e-
Mikado
Other › Power troubles
 Print TOPIC  Make Suggestion 

 3  Topic Subscribe

Friday, November 24 - 3:02 pm - Copyright © 2000-2017 RunRyder   EMAILEnable Cookies

Login Here
 New Subscriptions 
 Buddies Online