RunRyder RC
 4  Topic Subscribe
WATCH
 1 page 1121 views
Scorpion Power Scorpion Power
HelicopterTandem Rotor Craft Chinook - Osprey › I Left The "Smoke" OUT!!!!!!!!!!!!!!!!!!
07-07-2008 01:40 PM  9 years agoPost 1
doorman

rrProfessor

Sherwood, Arkansas

My Posts: All  Forum  Topic

Was out yesterday doing some final trimming prior to putting the converted unit back into the fuselage.....spooled up fine and I stopped it so that I could make an adjustment..... when I went to spool back up the motor was very slowly turning the blades so I pulled the throttle back and about then I saw the smoke coming from the ESC????
I pulled the arming switch and that took the batteries out of the mix and waited for it to clear.....
I have flown the combo about 4-6 other times for trim flights and have had no problems with the set up.... the only thing that I did differently is to add a Maxx products High Current Arming Switch....

Any ideas on what might have "smoked" this esc.....

I am running: AXI 4120/14 motor, CC Phoenix 80ESC, (2) 5s TP 3700's in parallel, and a Century 11t long pinion....

Thanks in advance for any info/ideas..... Stan

AMA 2918-Team JR, Spin Blades, East Coast Scale Helicopter,Castle Creations

PM  EMAIL  GALLERY  Attn:RR  Quote
07-07-2008 03:13 PM  9 years agoPost 2
"Cam"

rrKey Veteran

UK

My Posts: All  Forum  Topic

There's your problem...

It was a Pheonix! They blow... Really

Sorry I know it can be frustrating. Get a Hyperion, a Scorpion or a Kontronic next.

PM  EMAIL  GALLERY  Attn:RR  Quote
07-07-2008 05:40 PM  9 years agoPost 3
tadawson

rrElite Veteran

Lewisville, TX

My Posts: All  Forum  Topic

Or, depending on it's age, just get your Phoenix repaired under warranty . . . no point spending more money if it's covered.

- Tim

Friends don't let friends become electrotarded . . . .

PM  EMAIL  GALLERY  Attn:RR  Quote
07-07-2008 05:47 PM  9 years agoPost 4
avconslt

rrApprentice

Houston, Texas

My Posts: All  Forum  Topic

Stan

Actually, the Phoenix is a good ESC, however, you need to use the High Voltage version with the bigger motors, either an HV85 or HV100. That should fix the problem! I am using the HV85 on my Chinook and have had no problems, it's not even getting hot! I also like the governor feature!

Richard

o

PM  EMAIL  GALLERY  Attn:RR  Quote
07-07-2008 06:10 PM  9 years agoPost 5
doorman

rrProfessor

Sherwood, Arkansas

My Posts: All  Forum  Topic

Good info.....

Thanks for the info so far and I have already shipped the ESC out to Castle to see what they have to say about it.....since it only had about 5-6 test flights on it..... so I am sure they will repair it.... I also sent along the info on what equipment I am running and will see what they have to say about it.....
The HV seems like a good cure, but overkill to me on a 5S set up... (not if it cures the problem though) so since I already purchased this one for the project, I would really like to see why this one would not work in this application.... I checked it again and it is "rated" at 6s, so lets see what they have to say also.....
I was mostly wondering if the "little" added wire from the High Current switch could have "loaded" it somehow???? I guess the reason I am asking is that I had just read someplace that if you add wire to an ESC you should add it to the motor side and not the battery sides since it can do something (:rolleyesto the capacitors???? They lost me on that one....
But I certainly do appreciate the info and the recommendations....and will let you know if and what I find out also!!!!

Thanks, Stan

AMA 2918-Team JR, Spin Blades, East Coast Scale Helicopter,Castle Creations

PM  EMAIL  GALLERY  Attn:RR  Quote
07-08-2008 06:02 PM  9 years agoPost 6
Ronald Thomas

rrMaster

Gainesville, Fl, USA

My Posts: All  Forum  Topic

Are you running a seperate BEC? If so, did you pull the RED wire from the 3 pin plug on the CC80?

Team MikadoUSA 480XXTreme, 550SX, 600SX, 700XXTreme, 800XXTreme!!

PM  EMAIL  GALLERY  Attn:RR  Quote
07-08-2008 08:56 PM  9 years agoPost 7
doorman

rrProfessor

Sherwood, Arkansas

My Posts: All  Forum  Topic

Pulled The Red.....

Yes, I am running a separate BEC and had the red wire out of the plug and shielded.....
This was not the first flight, but more like the 5-6th and just doing some testing/trimming when this happened....

Thanks, Stan

AMA 2918-Team JR, Spin Blades, East Coast Scale Helicopter,Castle Creations

PM  EMAIL  GALLERY  Attn:RR  Quote
07-08-2008 10:31 PM  9 years agoPost 8
fergus

rrKey Veteran

Ireland

My Posts: All  Forum  Topic

I have seen a castle go up in flames before the heli even spooled up. I would not let them near any of my machines. Letting the smoke out of those things is easy its keeping it in is the problem

Regards

Fergus

PM  EMAIL  GALLERY  Attn:RR  Quote
07-08-2008 10:54 PM  9 years agoPost 9
Ronald Thomas

rrMaster

Gainesville, Fl, USA

My Posts: All  Forum  Topic

I had a CC 60, CC 35 , CC85 HV, and a CC45 and I never had a problem with them. Some have reported problems but CC support is awesome and they will do whatever it takes to make it right.....Ron

Team MikadoUSA 480XXTreme, 550SX, 600SX, 700XXTreme, 800XXTreme!!

PM  EMAIL  GALLERY  Attn:RR  Quote
07-20-2008 02:47 AM  9 years agoPost 10
ShaCho

rrApprentice

LA (Lower Alabama)

My Posts: All  Forum  Topic

I agree with LaughingStill concerning the CC products and customer service. My CC caught on fire and they did not hesitate to replace it. They only wanted to know my setup to help determine the cause.

Aim High!

PM  EMAIL  GALLERY  Attn:RR  Quote
07-20-2008 12:20 PM  9 years agoPost 11
doorman

rrProfessor

Sherwood, Arkansas

My Posts: All  Forum  Topic

Customer Service!!!

I have used CC for a lot of different aircraft (heli's and planes) and have only had one other problem and that was due to my set up and they still replaced it with no problems....
This one has been sent in to them to see if they can determine the cause, but I am confident that they will take care of it.... I have since put an HV85 on board and it seems to be working just fine....
I like the CC because of the different items that you can "adjust" to fit your needs.... I have yet to strip a main gear due to the soft start capabilities and in a scale machine, to me that is a very important requirement.....
I will post when I hear from them..

Stan

AMA 2918-Team JR, Spin Blades, East Coast Scale Helicopter,Castle Creations

PM  EMAIL  GALLERY  Attn:RR  Quote
07-20-2008 01:23 PM  9 years agoPost 12
Turbinator

rrApprentice

Nanticoke, PA

My Posts: All  Forum  Topic

I have about a 100 flights on my converted Vertol using the CC Phoenix 80 running 8 cells in series in high gov mode and it does not even get warm. I'm running 1550 head speed and I'm very happy with the set up so far. Maybe there are just some bum ones out there? I hear Castle warranty is usuall no hassle if you have receipt and unit is in warranty period, so far I have not had to find out personally, hope it stays that way !!

PM  EMAIL  GALLERY  Attn:RR  Quote
WATCH
 1 page 1121 views
Scorpion Power Scorpion Power
HelicopterTandem Rotor Craft Chinook - Osprey › I Left The "Smoke" OUT!!!!!!!!!!!!!!!!!!
 Print TOPIC  Make Suggestion 

 4  Topic Subscribe

Tuesday, November 21 - 11:17 pm - Copyright © 2000-2017 RunRyder   EMAILEnable Cookies

Login Here
 New Subscriptions 
 Buddies Online