RunRyder RC
 6  Topic Subscribe
WATCH
 2 pages [ <<    <    ( 1 )     2     NEXT    >> ] 2534 views
Scorpion Power Scorpion Power
HelicopterMiniature Aircraft Whiplash & Fury 55 › tail torque rod failure
03-15-2003 04:52 PM  14 years agoPost 1
RICH

rrApprentice

Ontario, Canada

My Posts: All  Forum  Topic

I had the torque rod in my Fury Extreme 91 break on me today about 150' up in a banked turn comming towards me. I hit throttle hold and flared it a bit to scrub off some of its forward momentum and autoed it straight down to a safe landing w/o a scratch. Needless to say I was quite shaken but relieved that my heli was fine. The rod was installed as per the manual with some lube on the ends. I'll have to phone MA on Monday and see what they can do for me if anything. The break is fowards the tail of the heli.

Rich

PM  EMAIL  GALLERY  Attn:RR  Quote
03-15-2003 09:20 PM  14 years agoPost 2
spincycl

rrVeteran

Marietta, GA

My Posts: All  Forum  Topic

I have heard of and seen more than a few torque tube failures. It's a shame that the Xcell has this, being that the rest of it is a work of art.

They really need to come up with a more robust drive tube.

I use a Bergen TT drive system and it's many times stronger than the MA one, and the replacements are much cheaper. If you want to know more check out my post on that. (the search should find it ok)

PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
03-15-2003 09:59 PM  14 years agoPost 3
gforce

rrVeteran

Fort Mill, SC

My Posts: All  Forum  Topic

What is the date of your kit? When was it shipped out from MA?

PM  EMAIL  GALLERY  Attn:RR  Quote
03-15-2003 11:00 PM  14 years agoPost 4
Naomi

rrElite Veteran

Ontario, Canada

My Posts: All  Forum  Topic

Wowl rich glad to hear you got it down alright.. G2 sure paid off big time. did you changed your underwear ?
What's the diameter on that torque tube?.. If it's a 6.2mm you might be able to use the vario torque tube.

Naomi

PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
03-15-2003 11:33 PM  14 years agoPost 5
RICH

rrApprentice

Ontario, Canada

My Posts: All  Forum  Topic

tube

Hi my heli was purchased in Sept/02 serial # 10200376. The tube is or should I say was the original supplied with the kit. I personally feel that if the tube had 2 more bearing supports instead of just 2 for such a long span that the torsional rigidity of the tube would greatly be increased when the tube is "winding" under load. My LHSO was nice enough to give me another tube from his own yet to be built kit to use for now. Oh well at least I can fly again on Sunday, and I thought my Raptor woof was scarey geeesh. lol . If people have some alternative tubes I would appreciate it if you can E me the info..

thx
Rich

PM  EMAIL  GALLERY  Attn:RR  Quote
03-16-2003 12:07 AM  14 years agoPost 6
SAL

rrVeteran

Oakville, Ontario,​Canada

My Posts: All  Forum  Topic

Oh dear, not another one !!!!!!

You boys in Ontario all seem to be infected by the same TT rod failure disease

I'm moving their this summer, so please stay away from me if it's contagious

SAL

.

PM  EMAIL  GALLERY  Attn:RR  Quote
03-16-2003 12:14 AM  14 years agoPost 7
BladeRunner

rrElite Veteran

Ontario Canada. ​Member of "some​sort" s

My Posts: All  Forum  Topic

Oh~oh.......see my reply in the thread "what is your weather like today".....sluggo had a tube failure today as well...at least it's slipping and not flyable.....

PM  EMAIL  GALLERY  Attn:RR  Quote
03-16-2003 12:25 AM  14 years agoPost 8
furyextreme

rrApprentice

USA

My Posts: All  Forum  Topic

did you ever crash this heli before?
or boom strike before and broke the tail boom and thought the tube was still good?
i have never seen or heard of a tube break in that spot before.
usually the ends spin off where they are glued.

PM  EMAIL  Attn:RR  Quote
03-16-2003 12:28 AM  14 years agoPost 9
RICH

rrApprentice

Ontario, Canada

My Posts: All  Forum  Topic

No

No this heli was never crashed in anyway way shape or form ever.

Rich

PM  EMAIL  GALLERY  Attn:RR  Quote
03-16-2003 12:57 AM  14 years agoPost 10
gforce

rrVeteran

Fort Mill, SC

My Posts: All  Forum  Topic

Such a clean break too. Almost like something cut right through it.

Did all you Canada TT failure guys get your Fury's from the same LHS? Is this an isolated batch of failures, or will there need to be a recall on all Fury TT's?

PM  EMAIL  GALLERY  Attn:RR  Quote
03-16-2003 01:02 AM  14 years agoPost 11
RICH

rrApprentice

Ontario, Canada

My Posts: All  Forum  Topic

MARCH 15th

The Ides of March
Beware the Ides of March. Julius Caesar ignored that warning and you know what happened to him.

RICH

PM  EMAIL  GALLERY  Attn:RR  Quote
03-16-2003 03:00 AM  14 years agoPost 12
noxam

rrApprentice

Lancaster, PA

My Posts: All  Forum  Topic

Me too?

I broke a tail tube today too, in front of Rich! Plus a set of main blades, stripped 2 servo gears, bent the flybar, screwed up the paddles, bent all the linkages, trashed a main shaft and a main axle! Oh yeah - the canopy is done too! Don't pull back all the way when you are 10 feet off the ground unless you are in idle up and your head speed is over 1500. Just doesn't work that good I hear! Et tu Brute!

Alive and Tocking!

PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
03-16-2003 03:07 AM  14 years agoPost 13
rappyfly

rrVeteran

Toronto, ONT

My Posts: All  Forum  Topic

kit number 10200384
I know the pain boyz. Oh I know, it must be the weather issue now, cause MA glue does not hold & work in cold weather.
Hope MA will find a solution

PM  EMAIL  GALLERY  Attn:RR  Quote
03-16-2003 03:13 AM  14 years agoPost 14
noxam

rrApprentice

Lancaster, PA

My Posts: All  Forum  Topic

FURBALL?

What do you mean there about Furball Boyz? Your rod is broke or seperated from the end, Riches broke(snapped off) above the end of the rod. And Canadian glue? What does that have to do with a snapped rod?

Alive and Tocking!

PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
03-16-2003 03:18 AM  14 years agoPost 15
sluggo

rrElite Veteran

Kitchener Ont

My Posts: All  Forum  Topic

kit #10200594

Well Boys there is more!!!! I had my secound one fail today to. The first one was in the kit and was never used. Tim shipped me a new one no prob. Well today was flight #4 on this tube and the end let go 8mins into my flight.

It didn't break like riches just the end came unglued and the tail felt mushy and would not piro or stop half way through the piro.

We removed it at the LHS and sure enough the end was slpiing in the carbon rod. Lik come on I do not even have a gallon through my fury yet and I am tube #3. I am just starting to really like this heli and want to fly without worring if I am going to have to auto in or crash due to another tube failure!!!!!!

One thing I will say is I got another tube today but this one had a yellow paint dot on it. Anyone know if this has anything to do with testing or inspection of the tube?

Going back out tomorrow and it better hold because I am going to beat on this thing hehehehehehe!

Rich Glad you got the heli down ok!!!!!

Chris

PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
03-16-2003 03:23 AM  14 years agoPost 16
sluggo

rrElite Veteran

Kitchener Ont

My Posts: All  Forum  Topic

noxam rappyfly is making a joke that maybe the glue is not holding up to the cold weather we are having here. Also this thread is about tube failures be it snapped in half or tube ends that come off or slip.

Chris

PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
03-16-2003 03:45 AM  14 years agoPost 17
noxam

rrApprentice

Lancaster, PA

My Posts: All  Forum  Topic

I know!

Just wondering where furball is coming from.

Alive and Tocking!

PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
03-16-2003 03:55 AM  14 years agoPost 18
sluggo

rrElite Veteran

Kitchener Ont

My Posts: All  Forum  Topic

hey raptor ya hennry really beats on them. I have been flying mine nice well breaking in the new heli and motor. I was hoping to start really spanking it this weekend but know I am scared s*&^less!!!!

Noxam it is just a nic for the fury same as furby and all the rust of them.

I hope they have it fix soon, I held off buying a fury so all the bugs would be worked out of them. Well when I got the kit I was very happy because it had all the new updates and the new gun metal look. Now there is all this tube drive stuff to deal with hehehee.

Chris

PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
03-16-2003 04:04 AM  14 years agoPost 19
bob00

rrVeteran

Toronto, ON

My Posts: All  Forum  Topic

kit #10200551& what's the yellow dot about

raptorrecker,

TT that failed in Sluggo's machine today was from one of my kits, kit #10200551 (not yet built). It was 'borrowed' to replace the one that shipped with his kit which had other problems. So your later kit may be in the clear.

Sluggo's replacement tube and all the tubes in the most recent shipment to arrive at the LHS have a tiny yellow dot on the shaft close to one of the bearing holders. Does anyone know what the yellow dot means?

- Rob

PM  EMAIL  HOMEPAGE  Attn:RR  Quote
03-16-2003 04:11 AM  14 years agoPost 20
RappyTappy

rrProfessor

North Denver,​Colorado

My Posts: All  Forum  Topic

I know a friend whose torque tube end started slipping on him last weekend. He auto'd it in safely. He put 30 min epoxy and a pin in to secure the end. It's like torque tube hell!

PM  EMAIL  GALLERY  Attn:RR  Quote
WATCH
 2 pages [ <<    <    ( 1 )     2     NEXT    >> ] 2534 views
Scorpion Power Scorpion Power
HelicopterMiniature Aircraft Whiplash & Fury 55 › tail torque rod failure
 Print TOPIC  Make Suggestion 

 6  Topic Subscribe

Monday, November 20 - 7:09 pm - Copyright © 2000-2017 RunRyder   EMAILEnable Cookies

Login Here
 New Subscriptions 
 Buddies Online