RunRyder RC
 2  Topic Subscribe
WATCH
 1 page 345 views POST REPLY
Scorpion Power Scorpion Power
HelicopterBeginners Corner › Servo configuration ?
11-30-2007 06:54 AM  9 years agoPost 1
stanley

rrNovice

javea spain

My Posts: All  Forum  Topic

my TT E550 raptor took a very heavy landing,after a thorough check over when i try the swashplate direction on aileron left the swashplate tilts slightly forwards and on alieron right the swash tilts back the same few degrees in elevator the swash is perfect HELP!!!!!!!

PM  EMAIL  Attn:RR  Quote
11-30-2007 08:51 AM  9 years agoPost 2
HotsHabit

rrVeteran

Idaho

My Posts: All  Forum  Topic

I would look for stripped servo gears or bent linkages.

PM  EMAIL  GALLERY  Attn:RR  Quote
11-30-2007 09:58 AM  9 years agoPost 3
MichaelP

rrKey Veteran

Northumberland UK

My Posts: All  Forum  Topic

A thorough check over is needed here and any suspect parts replaced.

PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
11-30-2007 11:16 AM  9 years agoPost 4
DJDAZ

rrVeteran

Perth Western Australia

My Posts: All  Forum  Topic

Did you fix it yet? Sounds like servo's are plugged in wrong to the channels on the receiver.

PM  EMAIL  GALLERY  Attn:RR  Quote
WATCH
 1 page 345 views POST REPLY
Scorpion Power Scorpion Power
HelicopterBeginners Corner › Servo configuration ?
 Print TOPIC  Make Suggestion 

 2  Topic Subscribe

Monday, October 23 - 2:35 pm - Copyright © 2000-2017 RunRyder   EMAILEnable Cookies

Login Here
 New Subscriptions 
 Buddies Online