RunRyder RC
 3  Topic Subscribe
WATCH
 1 page 889 views POST REPLY
Scorpion Power Scorpion Power
HelicopterTurbine Helicopters › Vario Cobra PHT3 strange
09-16-2007 08:30 PM  10 years agoPost 1
Bang68

rrApprentice

Denmark

My Posts: All  Forum  Topic

Hello guys !

I have clocked 6-8 tanks of flight with my PHT3 Cobra without any problems, however my last fligt has been very strange. Turbine running normal I would say but rotorspeed is very very low like something is slipping

Glutch has no colour or miscoulering what so ever. Max turbine speed according to the ECU is the same as always but something is wrong from a mechanical point of view !

Ok this afternoon I started looking and wondering and first I noticed the the FODscreen was completely missing:

]

First - have anybody experienced that ??

Secondly what is slipping !!!

Any comments and help preciated !

regards

Peter B

PM  EMAIL  GALLERY  Attn:RR
09-16-2007 09:02 PM  10 years agoPost 2
WIRLYBIRD

rrVeteran

CAPE TOWN / SOUTH AFRICA.

My Posts: All  Forum  Topic

I losty FOD screen three years ago , has been fine ever since , but is quite protected being inside the NH90 , will not replace it , and think many people have had this problem!

WHAT GOES UP MUST SURELY COME DOWN.

PM  EMAIL  GALLERY  Attn:RR
09-16-2007 11:32 PM  10 years agoPost 3
PETER ROB

rrElite Veteran

Devon UK

My Posts: All  Forum  Topic

Peter B, looks like you had the early type FOD guard , they were a much smaller mesh size they got blocked with fine debris very easily and then got sucked into the turbine, the later ones have a much bigger mesh size, and do not suffer from the same problem
I have had a few disapear,I used to replace them, now I do not bother with one,
The SPH5 2 stage, are not fitted with a FOD guard
Peter R

PM  EMAIL  GALLERY  Attn:RR
09-17-2007 01:51 AM  10 years agoPost 4
DKTek

rrVeteran

Melbourne, FL-USA

My Posts: All  Forum  Topic

Whoa!!! Are you suggesting that the turbine ingested the screen? I'm new to these little gems but I'd think that would cause the turb to fail in some way. What about the leading edge of the fan blades? Are there signs of FOD damage and if so, shouldn't JetCat inspect it? I have the new version screen and wouldn't want my turb feasting on it....

DK

PM  EMAIL  GALLERY  Attn:RR
09-17-2007 08:23 AM  10 years agoPost 5
PETER ROB

rrElite Veteran

Devon UK

My Posts: All  Forum  Topic

DK, Don't panic the first time it happened to me ,I took my turbine back for inspection, the then UK importer, service agent, took it apart, there were no visible signs of any damage, the internals were closley inspected, and checked for vibration, no additional adjustments for ballence was required
The original FOD was made of a nylon type material, the latest are I believe metal(wire mesh), I would be worried, if one of these, went through the works
Peter R

PM  EMAIL  GALLERY  Attn:RR
09-17-2007 08:40 PM  10 years agoPost 6
Bang68

rrApprentice

Denmark

My Posts: All  Forum  Topic

Thanks for all your replies !

Problem solved with the slipping glutch feeling

Collar behind the glutchbell itself was a bit loose causing
the pinion to slip !

Screw out, loctite on and a firmly grib on the allenwrench together with some red Vario screwpaint to monitor the screw in the future

This maybe happen when you fly it like a pood and boom

regards

Peter B

PM  EMAIL  GALLERY  Attn:RR
09-17-2007 09:07 PM  10 years agoPost 7
DKTek

rrVeteran

Melbourne, FL-USA

My Posts: All  Forum  Topic

Had me worried there. Thanks for setting me straight.

DK

PM  EMAIL  GALLERY  Attn:RR
WATCH
 1 page 889 views POST REPLY
Scorpion Power Scorpion Power
HelicopterTurbine Helicopters › Vario Cobra PHT3 strange
 Print TOPIC  Make Suggestion 

 3  Topic Subscribe

Friday, September 22 - 9:30 pm - Copyright © 2000-2017 RunRyder   EMAILEnable Cookies

Login Here
 New Subscriptions 
 Buddies Online