RunRyder RC
 0  Topic Subscribe
WATCH
 1 page 486 views POST REPLY
Scorpion Power Scorpion Power
Helicopter
e-
Electric Motors-Controllers-ESC
Other › new Align 43G ESC
09-16-2007 01:44 AM  10 years agoPost 1
onesubdrvr

rrNovice

PSL, Florida

My Posts: All  Forum  Topic

Well, a few weeks ago I had a problem with my heli, and my ESC caught fire, I hadn't done anything with it because my Raptor was running good, but now I've got a little time, I decided to replace the ESC, so I did.

Soldered all my connections, turned radio on, plugged batter in. Got the 3 tone power on, then nothing, no control. So, I figured it might need to be programmed, so I increased throttle to maximum, and after a few seconds, it gave me the programming beeps, but couldn't do anything from there.

Disconnected everything, tried again, nothing, no beeps on power up nothing. ATV's set at 100, neutral trim, DX-7 radio with AR-6000 receiver.

All other functions are normal (rudder, cyclic, collective), just nothing from the ESC itself. Replaced the motor incase that was suspect, and same thing.

Any ideas? is it possible that it's bad without turning the motor at all?

Thanks
wayne

Cheap, Fast and Reliable, pick any 2 !

PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR
WATCH
 1 page 486 views POST REPLY
Scorpion Power Scorpion Power
Helicopter
e-
Electric Motors-Controllers-ESC
Other › new Align 43G ESC
 Print TOPIC  Make Suggestion 

 0  Topic Subscribe

Tuesday, September 19 - 6:00 pm - Copyright © 2000-2017 RunRyder   EMAILEnable Cookies

Login Here
 New Subscriptions 
 Buddies Online