RunRyder RC
 12  Topic Subscribe
WATCH
 3 pages [ <<    <    ( 1 )     2      3     NEXT    >> ] 2923 views
Scorpion Power Scorpion Power
HelicopterAlignOther › 2IN1 LONG TERM USE WITH NO PROBLEMS
09-16-2007 12:56 AM  10 years agoPost 1
redboy

rrNovice

new york

My Posts: All  Forum  Topic

hey all i have this nice 2in1 on my table waiting to go into my pro, lets hear some good news, keep it or return?

PM  EMAIL  Attn:RR  Quote
09-16-2007 01:00 AM  10 years agoPost 2
george0079

rrElite Veteran

USA

My Posts: All  Forum  Topic

check your PM

Keep it. 13 gals and not a single problem in either of them.

Hell... I can fix that.
Uh oh..
Nope.
It's ***ked!!!
RE-KIT!!!!!

PM  EMAIL  GALLERY  Attn:RR  Quote
09-16-2007 01:06 AM  10 years agoPost 3
BarracudaHockey

rrMaster

Jacksonville FL

My Posts: All  Forum  Topic

No problems, I've been running one on my Raptor for a couple weeks.

Andy
AMA 77227
http://www.jaxrc.com

PM  EMAIL  GALLERY  Attn:RR  Quote
09-16-2007 01:31 AM  10 years agoPost 4
carcrasher

rrElite Veteran

east coast

My Posts: All  Forum  Topic

What are the specs of this reg? Is it adjustable?

PM  EMAIL  GALLERY  Attn:RR  Quote
09-16-2007 01:38 AM  10 years agoPost 5
george0079

rrElite Veteran

USA

My Posts: All  Forum  Topic

No it is not adjustable. I has 2 outputs... One is 5.8V for the receiver. the other is 1.5V for a glow driver

Hell... I can fix that.
Uh oh..
Nope.
It's ***ked!!!
RE-KIT!!!!!

PM  EMAIL  GALLERY  Attn:RR  Quote
09-16-2007 03:36 AM  10 years agoPost 6
scamp62

rrVeteran

Shermen Oaks, CA

My Posts: All  Forum  Topic

with about 8gal's though my 600N and loving it !

Dimmit..I can stop this anytime I want..no..really I can

PM  EMAIL  GALLERY  Attn:RR  Quote
09-16-2007 03:58 AM  10 years agoPost 7
redboy

rrNovice

new york

My Posts: All  Forum  Topic

what radio are you using and if u dont mind your set up?

PM  EMAIL  Attn:RR  Quote
09-16-2007 05:06 AM  10 years agoPost 8
rcmarty

rrVeteran

Penticton , B.C.​CANADA

My Posts: All  Forum  Topic

Well i bought one and then got to reading all the fuss on the net. Got me all paranoid. Left it on the bench for a bit and thought it over while following all the threads ( here and the freek ).

I took the shrink off mine and resoldered the joints , used silicone wire for the batt leads , extended the glow lead 1" with silcone also , resoldered the servo lead 180 (back onto the board) brought it around the modlex connector ,5 min epoxy'd all the wires (fuel tube sleeves leaving the unit), and re-shrunk it.

Bottom line i've learned so far .. (no expert clause of course )

- 2-1 has issues with futaba 2048 rx's , causing lockouts
- other brands have had mixed results on pcm / fm
- you NEED to glue the leads coming out of the unit - some hotglue works fine. Some say silicone sealant but it does attack boards. Hence my 5 min epoxy preference.
- don't hard mount it , give it a little 'dampening'. Mine is mounted with velcro and lightly stapped with another velcro (for good measure)
- Spectrum guys are doing well with it , of course std common sense wiring still apply's.

I have 2 flights on mine , i know not a long term guy , but give me a few months .

The glow plug option is sweet !!

Martin

What goes up will come down.... one way or another !

PM  EMAIL  HOMEPAGE  Attn:RR  Quote
09-16-2007 05:16 AM  10 years agoPost 9
K&B

rrApprentice

Columbus Ohio

My Posts: All  Forum  Topic

I am flying it with FM rec and no problems!!!

Kevin

PM  EMAIL  GALLERY  Attn:RR  Quote
09-16-2007 07:03 AM  10 years agoPost 10
dazzaster

rrKey Veteran

right next door to​hell

My Posts: All  Forum  Topic

no problems with mine, i think youl find that people with lock out will easily blame the new product without seeing if theres anything else to cause the lock outs, i had the same problem turned out the fan hub had come loose.
no problems since.
god knows how many galloons through it
Darren

A.K.A 509

PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
09-16-2007 08:34 AM  10 years agoPost 11
Magnazan

rrVeteran

Auckland - New​Zealand

My Posts: All  Forum  Topic

No issues with mine either. Just make sure you mount it as far as possible from the receiver (Probably not necessary but why risk it). Also hot glue both ends of the reg, this imo is a MUST.

PM  EMAIL  Attn:RR  Quote
09-16-2007 10:13 AM  10 years agoPost 12
ba board

rrVeteran

England

My Posts: All  Forum  Topic

With regard to silicone on the leads, you need to ensure that you use a silicone specifically designed for use with electrical componenets. Most silicones give off acetic acid when they cure which can attack components.

PM  EMAIL  GALLERY  Attn:RR  Quote
09-16-2007 02:23 PM  10 years agoPost 13
jetblue2135

rrVeteran

Atlanta, GA

My Posts: All  Forum  Topic

12 gallons run through mine with the 2 in 1, no problems

Align I Team Futaba I Thunder Power I

PM  EMAIL  GALLERY  Attn:RR  Quote
09-16-2007 03:59 PM  10 years agoPost 14
matey

rrNovice

Luton, Bedfordshire​UK

My Posts: All  Forum  Topic

Mines been perfect so far. I'm on gallon No6. Havent had one glitch or lockout. Great bit of kit.

PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
09-16-2007 04:10 PM  10 years agoPost 15
ThunderRobo

rrKey Veteran

Toronto, Canada

My Posts: All  Forum  Topic

loving mine... over 10 gallons on unit #2... i broke unit #1 when i dropped it off my bench and onto my flight box but unit #1 had liek 20 gallons on it....

i have 1 more on my bench... not sure if i trust it on my 90 tho....

Derek
Da' kid with the toyz!
"Time for some Muzak!"

PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
09-16-2007 11:46 PM  10 years agoPost 16
redboy

rrNovice

new york

My Posts: All  Forum  Topic

thanks for all the info guys .

PM  EMAIL  Attn:RR  Quote
09-17-2007 12:26 AM  10 years agoPost 17
JAGNZ

rrProfessor

Auckland, New​Zealand

My Posts: All  Forum  Topic

Mines fine after a few gallons now. I hot glued the leads out of the unit and also use a slice of foam rubber between it and the radio tray for cushion.


Jason Greenwood

www.3dheli.co.nz

PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
09-19-2007 01:17 AM  10 years agoPost 18
Helijost

rrApprentice

Pevely, MO - USA

My Posts: All  Forum  Topic

Mine died today in flight, it popped one of the capacitors off. With all the horror stories out there, i'm lucky, didn't crash, but from now on ARIZONA REGULATOR!!! ONLY!!

PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
09-19-2007 01:24 AM  10 years agoPost 19
JAGNZ

rrProfessor

Auckland, New​Zealand

My Posts: All  Forum  Topic

Did you hot glue the end of yours like it's been suggested? The capacitors are redundant so will not cause a crash anyway...


Jason Greenwood

www.3dheli.co.nz

PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
09-19-2007 01:29 AM  10 years agoPost 20
Helijost

rrApprentice

Pevely, MO - USA

My Posts: All  Forum  Topic

If a product is so crappy that you have to "hot glue" it to make it work, then why buy it? How many thousands of dollars do you have invested? Why would you risk that on hot glue? Sorry, but not I. This is not the first failure I have seen with one, and I'm sure it won't be the last. Just buck up and buy the Arizona and be done with it, it has been proven in the long haul. I guess it goes back the mentallity, why buy a cheap gyro, yeah the 611 is expensive but there are gyros out there for under a hundred bucks that claim to do the same, my guess is you wouldn't run one. You get what you pay for.

PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
WATCH
 3 pages [ <<    <    ( 1 )     2      3     NEXT    >> ] 2923 views
Scorpion Power Scorpion Power
HelicopterAlignOther › 2IN1 LONG TERM USE WITH NO PROBLEMS
 Print TOPIC  Make Suggestion 

 12  Topic Subscribe

Thursday, November 23 - 5:43 am - Copyright © 2000-2017 RunRyder   EMAILEnable Cookies

Login Here
 New Subscriptions 
 Buddies Online