RunRyder RC
 5  Topic Subscribe
WATCH
 1 page 1006 views
Scorpion Power Scorpion Power
HelicopterMain Discussion › This Heli Problem is Unbelievable.
09-16-2007 12:33 AM  10 years agoPost 1
440GTX

rrVeteran

Calgary, Canada

My Posts: All  Forum  Topic

I had 2 nice flights with my raptor 50 this morning.
OS 50 SH, GY 401 , Hitec 6965 Tail Servo.

On the third flight the heli started spinning counter clockwise.
I honestly did not touch a thing except re-fuel my Heli.
Battery on Rx and Tx was good. 4.9V and 10.6V
Nothing different happens when I reverse my gyro
Gyro initilised . The Servo is working correctly.

HELP

Fred..

PM  EMAIL  GALLERY  Attn:RR  Quote
09-16-2007 12:40 AM  10 years agoPost 2
flipped2left

rrKey Veteran

indianapolis,in.

My Posts: All  Forum  Topic

What kind of tail drive do you have? torque tube/wire/belt? something is slipping or stripped

Smile! people will wonder what you're up to!!

PM  EMAIL  GALLERY  Attn:RR  Quote
09-16-2007 01:06 AM  10 years agoPost 3
Pistol Pete

rrProfessor

Seffner, FL

My Posts: All  Forum  Topic

Rx battery capacity?

4.9V? under load?

i would recommend an onboard Rx battery monitor for quick reference

ill get you a link shortly...ok HERE

nothing like a little peace of mind.

EDITED
BTW...you can also place a load by using a 250ohm 1/2w resistor on anyone of the meter leads...better than none at all.

~~Enjoying the hobby one flight at a time~~

PM  EMAIL  HOMEPAGE  GALLERY  BLOGAttn:RR  Quote
09-16-2007 01:14 AM  10 years agoPost 4
GyroFreak

rrProfessor

Orlando Florida​...28N 81W

My Posts: All  Forum  Topic

Sure sounds like loss of tail rotor drive. Check your tail rotor blade drive that something didn't come loose or broke. I'm not faimler with your system, but you should be able to turn your main rotors by hand slowly and gently load the tail rotor and feel for any slippage or notchy feeling. This will help sort out any mech failure. Next would be a bad servo, wacky gyro, low battery, xmitter setup , so forth.

I think about the hereafter. I go somewhere to get something, then wonder what I'm here after ?

PM  EMAIL  GALLERY  Attn:RR  Quote
09-16-2007 01:15 AM  10 years agoPost 5
BarracudaHockey

rrMaster

Jacksonville FL

My Posts: All  Forum  Topic

4.9 volt loaded is iffy, 4.9 volt static, no way, you probably dragged down the voltage and the gyro reset.

Andy
AMA 77227
http://www.jaxrc.com

PM  EMAIL  GALLERY  Attn:RR  Quote
09-16-2007 01:38 AM  10 years agoPost 6
Mutt

rrKey Veteran

M ca usa

My Posts: All  Forum  Topic

I have to agree with barracuda on this one 4.9 is way to low I wont fly mine below 5.2

PM  EMAIL  Attn:RR  Quote
09-16-2007 01:46 AM  10 years agoPost 7
jschenck

rrProfessor

La Vista, NE.

My Posts: All  Forum  Topic

I use one of these and highly recommend some type of load type tester

http://www.radiosouthrc.com/ProESVTester.htm

I will fly down to 4.9V but that's under a 5 second 1.5A load.

also if the tail is spinning the click throttle hold and shoot the auto. May not help if you have a driven tail and the servo is holding it over or the gyro lost it's brains but could help. if you are quick enough - flip the gyro into rate mode.

PM  EMAIL  GALLERY  Attn:RR  Quote
09-16-2007 02:38 AM  10 years agoPost 8
Jeff polisena

rrElite Veteran

westpalmbeachflorida​usa

My Posts: All  Forum  Topic

gyro is the first sign of dead bat 4.9 is to low charge and you will probably be fine

PM  EMAIL  GALLERY  Attn:RR  Quote
09-16-2007 02:49 AM  10 years agoPost 9
Super Phreek

rrVeteran

Sunny Lancaster,​California

My Posts: All  Forum  Topic

4.9 is on the real low side. When power gets a little low, first thing that goes is the tail. Count your lucky stars you didn't lose a heli.

Derek

Is that a 6s 5000 in your pocket,
or are you just happy to see me?

PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
09-16-2007 03:13 AM  10 years agoPost 10
440GTX

rrVeteran

Calgary, Canada

My Posts: All  Forum  Topic

Thanks for the reply everyone
Sure sounds like loss of tail rotor drive. Check your tail rotor blade drive that something didn't come loose or broke
GyroFreak. The tail rotor pulley teeth are almost gone.
I will have to Fire my Heli Mechanic. No wait thats me.
Scarry. Time to buy a new pulley and I will also get a new battery.
I just charged my 2100 at .2 amps for 8 hrs . It only reads 5.1 volts with No Load.

Thanks again
Fred..

PM  EMAIL  GALLERY  Attn:RR  Quote
WATCH
 1 page 1006 views
Scorpion Power Scorpion Power
HelicopterMain Discussion › This Heli Problem is Unbelievable.
 Print TOPIC  Make Suggestion 

 5  Topic Subscribe

Tuesday, November 21 - 9:21 pm - Copyright © 2000-2017 RunRyder   EMAILEnable Cookies

Login Here
 New Subscriptions 
 Buddies Online