RunRyder RC
 0  Topic Subscribe
WATCH
 1 page 447 views POST REPLY
Scorpion Power Scorpion Power
HelicopterBeginners Corner › not starting Heelp
09-15-2007 03:44 AM  10 years agoPost 1
speedyjo63

rrNovice

Melaka,Malaysia

My Posts: All  Forum  Topic

Well I have solder everything,connect everything turn on the radio,nothing moves at all,how can u tell weather is the SPEED CONTROLLER OR MOTOR or anything.......this is my first electric.is a MINI TITAN 325E.......

6 grand in Heli and I still cant Hover

PM  EMAIL  GALLERY  Attn:RR
09-15-2007 03:54 AM  10 years agoPost 2
wlouigene

rrApprentice

Coral Springs, FL

My Posts: All  Forum  Topic

What kind of ESC are you using?

PM  EMAIL  GALLERY  Attn:RR
09-15-2007 04:24 AM  10 years agoPost 3
krashtagain

rrKey Veteran

ohio

My Posts: All  Forum  Topic

probably going to get the directions for the speed control out of the garbagr can (lol) and program the esc .

If you're not living on the edge you're just taking up space !

PM  EMAIL  GALLERY  Attn:RR
09-15-2007 02:28 PM  10 years agoPost 4
Pistol Pete

rrProfessor

Seffner, FL

My Posts: All  Forum  Topic

the more info you provide the quicker your issues resolved.

first step...remove ESC-motor from RX...now try to see if Rx is working all servos.

then come back for more with more info on ESC or finish filling out profile.

~~Enjoying the hobby one flight at a time~~

PM  EMAIL  HOMEPAGE  GALLERY  BLOGAttn:RR
09-15-2007 05:00 PM  10 years agoPost 5
speedyjo63

rrNovice

Melaka,Malaysia

My Posts: All  Forum  Topic

ok will try again and sheck everything.thanks

6 grand in Heli and I still cant Hover

PM  EMAIL  GALLERY  Attn:RR
09-15-2007 09:37 PM  10 years agoPost 6
speedyjo63

rrNovice

Melaka,Malaysia

My Posts: All  Forum  Topic

Just to make sure: on connection,

3 wires comin out from the motor: Left YELLOW> Center Black>Right RED.

3 BLACK wires comin out from the SPEED CONTROLLER: Left being NEGATIVES and Right being POSITIVES.DO i Cnnect the middle wire from the SPeed controller to the middle Black wire from the motor???

6 grand in Heli and I still cant Hover

PM  EMAIL  GALLERY  Attn:RR
09-16-2007 12:41 AM  10 years agoPost 7
Pistol Pete

rrProfessor

Seffner, FL

My Posts: All  Forum  Topic

still no info on ESC model?

ok...just connect them...the colors dont matter and dont have to match either

and IF motor is not turning the way you expected it all you have to do is switch ANY two wires to reverse motor direction.

i would suggest not having the blades on to test direction as well as to make sure nothing else is out of balance such as flybar/paddles

Best of luck!

~~Enjoying the hobby one flight at a time~~

PM  EMAIL  HOMEPAGE  GALLERY  BLOGAttn:RR
09-16-2007 01:58 AM  10 years agoPost 8
speedyjo63

rrNovice

Melaka,Malaysia

My Posts: All  Forum  Topic

I think is a DYNAM 45A
I have this receiver ELECTRON 6 from Hitec and I have replace the crystal to channel 59 which is my radio frequency and I think is not receiving it.How do I find out wether the crystal is working or not or do I have to do some adjustment to the radio..thanks guys

6 grand in Heli and I still cant Hover

PM  EMAIL  GALLERY  Attn:RR
09-16-2007 02:02 AM  10 years agoPost 9
Pistol Pete

rrProfessor

Seffner, FL

My Posts: All  Forum  Topic

got it...no governor...best of luck with the throtle/pitch settings.

EDITED:
How do I find out wether the crystal is working or not or do I have to do some adjustment to the radio..thanks guys
you should not have to do anything to the Tx...some Rx are very picky for their crystals...the only way to find out if its the crystal is to replace with a know good one...a bad connection can also be a cause...you can "gently" wiggle crystal to see if this cures the issue...assuming that you have not had any crashes with this Rx...of course.

wait a minute...just caught something...is the Rx positive or negative shift?

your futaba radio is a negative shift...a positive shift Rx will not work...period.

~~Enjoying the hobby one flight at a time~~

PM  EMAIL  HOMEPAGE  GALLERY  BLOGAttn:RR
09-17-2007 12:55 AM  10 years agoPost 10
speedyjo63

rrNovice

Melaka,Malaysia

My Posts: All  Forum  Topic

Negatives shift,,I change it over to my Futaba 148 receiver but I have to attached a the receiver battery to it in order to get it running.So I know all those servos andgyro works.when I switch it back to the Hitec Electron 6 nothin happen,the crystal I got cost me 9.00 bucks from Helipros.I know nothin about this but I suspect is the receiver,not sure just guessing....

6 grand in Heli and I still cant Hover

PM  EMAIL  GALLERY  Attn:RR
09-17-2007 01:01 AM  10 years agoPost 11
A. Bundy

rrElite Veteran

Aurora,IL. 30W/SW of Chicago

My Posts: All  Forum  Topic

Are you getting gas to the carb?

PM  EMAIL  GALLERY  Attn:RR
WATCH
 1 page 447 views POST REPLY
Scorpion Power Scorpion Power
HelicopterBeginners Corner › not starting Heelp
 Print TOPIC  Make Suggestion 

 0  Topic Subscribe

Monday, September 25 - 10:45 am - Copyright © 2000-2017 RunRyder   EMAILEnable Cookies

Login Here
 New Subscriptions 
 Buddies Online