RunRyder RC
 1  Topic Subscribe
WATCH
 1 page 490 views POST REPLY
Scorpion Power Scorpion Power
HelicopterRadio - Servo - Gyro - Gov - Batt › xtrmeme power system on 9Z WC2
09-13-2007 01:51 PM  10 years agoPost 1
Bobglennspy4u

rrApprentice

Port Orange FL.

My Posts: All  Forum  Topic

has anyone used the xtreme power system on there 9Z..if so how has it been working

PM  EMAIL  GALLERY  Attn:RR
09-13-2007 02:06 PM  10 years agoPost 2
Foxden

rrElite Veteran

Port Charlotte, FL. USA

My Posts: All  Forum  Topic

I've had one in mine for about a month with no problems, antenna is still in the radio, I just leave it collapsed as instructed by Jim Drew, I'm going to convert my entire fleet over to XPS receivers.

Clyde Fox
Port Charlotte FL
Team Outrage

PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR
09-13-2007 03:22 PM  10 years agoPost 3
Bobglennspy4u

rrApprentice

Port Orange FL.

My Posts: All  Forum  Topic

Thanks

cool thanks for the info...

PM  EMAIL  GALLERY  Attn:RR
09-13-2007 07:10 PM  10 years agoPost 4
fritzthecat

rrKey Veteran

Virginia Beach, VA

My Posts: All  Forum  Topic

XPS is a great system but be aware of the 9Z XPS servo pulsing bug that can happen.
http://www.rcgroups.com/forums/showthread.php?t=722695

Fritz


'Send Money, Women and Guns!'

PM  EMAIL  GALLERY  Attn:RR
09-14-2007 02:01 AM  10 years agoPost 5
helo_chris

rrVeteran

goodlettsville, tn

My Posts: All  Forum  Topic

Have it in mine and works great. I have seen the servo pulsing mentioned a few times, mainly when I am at the field and it is hot. I cant get it to do it at home. And I know for a fact mine needs new pots, have needed it since before I got XPS.

"There is a fine line between cutting edge and bleeding edge.."

PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR
09-14-2007 02:28 AM  10 years agoPost 6
Nasscar][

rrVeteran

Delaware

My Posts: All  Forum  Topic

Guys, note: this isn't an XPS BUG . . .

Back when the orginal WC2 was released this bug was around.
(Around 2001)
If you used your tx on your simulator or stressed your pots then this issue would develop.

It took Sodel services several attempts to fix my radio back then when this problem orginally surfaced.

The XPS system is an awsome product and it's not professional to bash a product because of an assumption.

Get your facts together . . .

Nas,

PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR
09-14-2007 05:16 AM  10 years agoPost 7
fritzthecat

rrKey Veteran

Virginia Beach, VA

My Posts: All  Forum  Topic

I have my facts. I also like the XPS system.

I used the 9Z with the G3.5 sim. There was no pulsing.
I had a 72Mhz synth module in my 9Z. There was no servo pulsing.
I had a Spektrum module in my 9Z. There was no servo pulsing.
I had a XPS module in my 9Z. The servos pulsed.
Draw your own conclusion. I did. My FASST module is on order. I don't expect to see servo pulses with it.

Fritz - who likes XPS but hasn't partaken of the cool-aid.


'Send Money, Women and Guns!'

PM  EMAIL  GALLERY  Attn:RR
WATCH
 1 page 490 views POST REPLY
Scorpion Power Scorpion Power
HelicopterRadio - Servo - Gyro - Gov - Batt › xtrmeme power system on 9Z WC2
 Print TOPIC  Make Suggestion 

 1  Topic Subscribe

Thursday, September 21 - 2:30 am - Copyright © 2000-2017 RunRyder   EMAILEnable Cookies

Login Here
 New Subscriptions 
 Buddies Online