RunRyder RC
 1  Topic Subscribe
WATCH
 1 page 456 views POST REPLY
Scorpion Power Scorpion Power
HelicopterBeginners Corner › Need Help with Lama V4
09-12-2007 04:00 PM  10 years agoPost 1
boosted05

rrNovice

NY/NJ

My Posts: All  Forum  Topic

I recently purchased a Lama V4. Im new to the hobby and after several crashes i broke the swash plate. I installed a new one i guess wrong because it does not level out after testing with covers off left to right it moves but stays there in down unlevel position.Should it return to level position on its own when not using right hand stick. Also i messed with the forward and rev servo setting on the lower right hand side of controller now it does not fly at all. How do i get the stock settings back since i was paying no attention to there original position.The instruction manual does not contain much info. Thanks in advance for any help.

PM  EMAIL  GALLERY  Attn:RR
09-12-2007 04:44 PM  10 years agoPost 2
Pistol Pete

rrProfessor

Seffner, FL

My Posts: All  Forum  Topic

perhaps some photos will help us visualize to assist you.

~~Enjoying the hobby one flight at a time~~

PM  EMAIL  HOMEPAGE  GALLERY  BLOGAttn:RR
09-12-2007 05:23 PM  10 years agoPost 3
Lowezz

rrApprentice

Canada

My Posts: All  Forum  Topic

I have the Lama V4 also and here is how the radio should be setup.

AIL=Rev
ELE=Rev
THR=Nor
RUD=Nor

Put these settings back and work from there as they are the proper factory settings!

PM  EMAIL  GALLERY  Attn:RR
09-13-2007 01:26 AM  10 years agoPost 4
boosted05

rrNovice

NY/NJ

My Posts: All  Forum  Topic

Thanks guys i will take a pic of the swashplate.

PM  EMAIL  GALLERY  Attn:RR
09-13-2007 09:02 AM  10 years agoPost 5
Eartaker

rrApprentice

Tacoma, WA

My Posts: All  Forum  Topic

The four little screws that hold the swash into position.... loosen them and slide the swash upward on the main shaft until the swash plate is level and then tighten the four little screws then you think it is level. when you do this, unplug the motors and have the heli on so that the servos do not move. also have the trims set to the middle

PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR
WATCH
 1 page 456 views POST REPLY
Scorpion Power Scorpion Power
HelicopterBeginners Corner › Need Help with Lama V4
 Print TOPIC  Make Suggestion 

 1  Topic Subscribe

Wednesday, September 20 - 6:26 am - Copyright © 2000-2017 RunRyder   EMAILEnable Cookies

Login Here
 New Subscriptions 
 Buddies Online