RunRyder RC
 2  Topic Subscribe
WATCH
 1 page 1107 views
Scorpion Power Scorpion Power
Helicopter
e-
Blade
Blade CP Pro › throttle mid point problem.
09-10-2007 03:18 PM  10 years agoPost 1
bekylane

rrNovice

FL, USA

My Posts: All  Forum  Topic

Hi!

I am new to the forum, but not new to helicopters. I have a BCX2 and a Blade CP Pro. Recently I noticed an issue on the CP Pro when I started doing 3D.

When I set the mid point to 50% and the helicopter is in iddle up:

The motor is getting to the mid point at 70% left stick instead of center. If I set the throttle trim to the middle then it reaches the mid point at center stick. The manual says that the trim should be down all the time.

Is this the normal behavior or is there something wrong with my helicopter?

Bellow are charts of the throttle pitch curves I am getting depending on the throttle trim: (note the pitch is moving the same as the stick, what is changing with the trim is the midpoint)

PM  EMAIL  Attn:RR  Quote
09-10-2007 04:35 PM  10 years agoPost 2
futuramille

rrVeteran

SC USA

My Posts: All  Forum  Topic

Though you have to have the trim all down for initialization, I raise it until the tail motor kicks in (about middle). That way, when flying, the throttle/pitch trim is at half or hovering at 65% throttle stick. I set 0 pitch with the trim at half as well. Doing this should give you uniform curves your looking for.



------------------------------
.....I need more batteries!!!

PM  EMAIL  GALLERY  Attn:RR  Quote
09-10-2007 04:39 PM  10 years agoPost 3
bekylane

rrNovice

FL, USA

My Posts: All  Forum  Topic

Thnks.

The thing is that the manual says the throttle curve should be straight like in my first graph with the trim down but it is not, as if something was wrong with the helicopter.

PM  EMAIL  Attn:RR  Quote
09-10-2007 05:35 PM  10 years agoPost 4
futuramille

rrVeteran

SC USA

My Posts: All  Forum  Topic

I've got 4 bcp's and three use the stock electronics. In my experience, they all behave uniformly in the throttle only with the trim set to half. eg. in idle up, the 4 in 1 shows red (full throttle) at 85% and -85%. With the trim all down, red shows at 90% and -75%

I don't know if the CP pro instructions differ from the BCP but my instructions say nothing about trim in the curves detail page (19).



------------------------------
.....I need more batteries!!!

PM  EMAIL  GALLERY  Attn:RR  Quote
09-10-2007 05:53 PM  10 years agoPost 5
tutelar-rc

rrKey Veteran

Nobleton, Ontario -​Canada

My Posts: All  Forum  Topic

I always flew my stock transmitter with the throttle trim all the way up... I liked where the "hover point" was with the trim all the way up.

I think what you are seeing is normal.

PM  EMAIL  GALLERY  Attn:RR  Quote
09-11-2007 04:40 AM  10 years agoPost 6
bekylane

rrNovice

FL, USA

My Posts: All  Forum  Topic

The manual for the CP Pro is practically the same, it does not says anything about the trim in relation to the curves.

PM  EMAIL  Attn:RR  Quote
09-13-2007 05:09 AM  10 years agoPost 7
Micro-Maniac

rrElite Veteran

Pasco,Washington​Formerly: Captain​Chaos

My Posts: All  Forum  Topic

Just turn the throttle curve knob all the way up to 100% for a flat throttle curve in idle-up and fly happy - A V-curve just messes with the torque etc anyways

PM  EMAIL  GALLERY  Attn:RR  Quote
09-13-2007 08:19 PM  10 years agoPost 8
bekylane

rrNovice

FL, USA

My Posts: All  Forum  Topic

Thanks!

PM  EMAIL  Attn:RR  Quote
WATCH
 1 page 1107 views
Scorpion Power Scorpion Power
Helicopter
e-
Blade
Blade CP Pro › throttle mid point problem.
 Print TOPIC  Make Suggestion 

 2  Topic Subscribe

Saturday, November 18 - 4:41 am - Copyright © 2000-2017 RunRyder   EMAILEnable Cookies

Login Here
 New Subscriptions 
 Buddies Online