RunRyder RC
 2  Topic Subscribe
WATCH
 1 page 430 views POST REPLY
HelicopterRadio - Servo - Gyro - Gov - Batt › Ok here's one for all you experts on electrical troubleshooting!
08-12-2007 03:05 PM  10 years agoPost 1
draven

rrNovice

las vegas nv usa

My Posts: All  Forum  Topic

In my raptor 30 I have Futaba 9252 seros throughout,gy 401.
I just installed a hitec HS-635HB for my throttle.It only glitches when i plug in the hitec. Is this servo just simply not compatable with the other four servos.
Oh i'm also running a ppm reciever with my JR9303.
Anyone experience anything like this let me know!

PM  EMAIL  Attn:RR  Quote
08-12-2007 03:21 PM  10 years agoPost 2
z11355

rrMaster

New England

My Posts: All  Forum  Topic

does it glitch if you put a different servo in that location and
run the wires the same way?

it may be that the Hitec is 'noisy' and it is feeding back that
noise into the JR receiver.

I have a similar setup on more than one machine although w/ a Futaba
149DP rx and there are no problems.

PM  EMAIL  GALLERY  Attn:RR  Quote
08-12-2007 04:11 PM  10 years agoPost 3
Bad Karma

rrVeteran

UK

My Posts: All  Forum  Topic

I had a similar issue when running a 6965 on the collective, I already had one on the tail, but when both where on, the pitch one would glitch, but with a futaba servo it was fine.

PM  EMAIL  Attn:RR  Quote
WATCH
 1 page 430 views POST REPLY
HelicopterRadio - Servo - Gyro - Gov - Batt › Ok here's one for all you experts on electrical troubleshooting!
 Print TOPIC  Make Suggestion 

 2  Topic Subscribe

Monday, April 23 - 10:30 pm - Copyright © 2000-2018 RunRyder   EMAILEnable Cookies

Login Here
 New Subscriptions 
 Buddies Online