RunRyder RC
 2  Topic Subscribe
WATCH
 1 page 346 views
Scorpion Power Scorpion Power
HelicopterThunder TigerRAPTOR 50 › R50 Titan with GY401 and 6EXH problem with​rotating around
08-12-2007 03:46 AM  10 years agoPost 1
Sarosh

rrNovice

Brainerd, MN USA

My Posts: All  Forum  Topic

Well heres short story about history of the R50 Titan.

well, a couple weeks ago, i burned the clutch, clutch bell, because when iwas installing the new liner on, i put the throttle linkage on the wrong side, so when i started it, it was actually at full throttle instead of idle as supposed to be at. so that destroyed the clutch.

So i get new clutch, bell, bearings, installed it, fired it up, as i put it in idle up, the rpm was sooo high that when i moved the lever up a bit it just shot up like a slingshot, and came back down so fast when i moved the lever down a little bit, hit the ground and tilted to the side and chewed up the wood blades to half.

put new blades on, looked at the idle up settings, it was too high since i was using a old worn clutch with that setup.

changed it down, worked a lot better, next day which is tonight, took it out to the field, hovering was very stable like usual, but the tail will not turn around fast, more like 360 degree a mintue.. yes i mean mintue. so i put it down, tried to figure things out, everything looked fine and was in place like its supposed to be. Gyro sensitivity on the tx is at 88percent like it has been from first flight a few months ago. Gyro is GY401 and supplied Futaba digital servo (forgot the number) and with Futaba 6EXH tx.

So after the last adjustment to see how it is, still the same, so i brought it back down and it was far away, so i tilted it back to bring it closer to me, as i tilted it was fine and started to come to me, and all of suddenly it goes full back elevator, nose was straight up, tail striked the road, tilted the heli to its left into the tall grass field, did 3 360 degree somersault until it rested on the ground. just damaged the blades in the insde of the blade where it hit the mast, and a nice nick on the boom, broke one landing gear. thats all.

SO why is it not rotating around fast like it usually does. i tried variety of different rotor speeds. still the same, checked the belt tension, its tight like its supposed to be. no slippage found. even tried to hold the tail blade with my finger and move the stick left and right, and it still turns with me holding it. so i know the servo is strong. RX battery is reading 5.0 volts, TX is reading 10.5 volts.

Was the crash caused by interference? there was no body else around, just me.

PM  EMAIL  Attn:RR  Quote
08-12-2007 06:59 AM  10 years agoPost 2
airthumper

rrApprentice

Sacramento, CA

My Posts: All  Forum  Topic

I think you should first try to find someone to help you with your setup mechanically and on your radio this is sounded too expensive already. Try increasing the ATV/EPA on your radio to a much higher percentage and check that the limits set on your gyro allow your tail slider to move fully to the left and right on the shaft.

I Fly So Good: BECAUSE I'M SPONSORED! ...what's this bill here?

PM  EMAIL  GALLERY  Attn:RR  Quote
08-12-2007 09:11 AM  10 years agoPost 3
Sarosh

rrNovice

Brainerd, MN USA

My Posts: All  Forum  Topic

um, its gone through 6+ gallons of fuel without any problems, flies amazing beautifully, i never touched anything else until i decided to replace the clutch liner since i burned it a few times with the first gallon when i made some throttle mistakes at the start up, ie like too much trim, or idle up was switched on etc. then after that it was all fine for 5 gallons until the clutch replacement, all problems started coming up. My local heli friends thinks the GY401 is shot or something. its all set up perfectly, no binds, all links move freely after reaming it. blade on tail moves full directions ever since.

how do i find out if the gyro is still good or not? i mean it turns completely full left and right on the ground (the tail blades) but up in air, its just not rotating the heli as its supposed to do it like, seems like the tail blades rpm is low like not giving enough push, but it cant be because the belt is on good, and head speeds r around 1700-1730rpm. so its got to be servo/gyro related, but what is it.. thats my question and puzzle.

PM  EMAIL  Attn:RR  Quote
WATCH
 1 page 346 views
Scorpion Power Scorpion Power
HelicopterThunder TigerRAPTOR 50 › R50 Titan with GY401 and 6EXH problem with​rotating around
 Print TOPIC  Make Suggestion 

 2  Topic Subscribe

Wednesday, November 22 - 7:14 am - Copyright © 2000-2017 RunRyder   EMAILEnable Cookies

Login Here
 New Subscriptions 
 Buddies Online