RunRyder RC
 2  Topic Subscribe
WATCH
 1 page 446 views
Scorpion Power Scorpion Power
HelicopterAlignOther › elevator servo jumps up when switched into idle.
08-11-2007 04:32 PM  10 years agoPost 1
npsk8ter

rrApprentice

Joliet, Illinois USA

My Posts: All  Forum  Topic

I run the new jr8717 servos and a jr 8103 radio. When programmed i had to put -60 in the swash mix for the pitch since it was backwards and for some reason when i switch from normal to idle or to t-hold the elevator jumps up a tiny bit and now the swash isnt level! Ive never seen this before and it doesnt do this on my raptor 30 or my 600E. I went threw the whole radio for the cause and now mixes are active and im stumped! I know it cant fly right! Someone had this happen yet?

PM  EMAIL  GALLERY  Attn:RR  Quote
08-11-2007 04:37 PM  10 years agoPost 2
Nightstalker

rrElite Veteran

UK (BEDFORDSHIRE)

My Posts: All  Forum  Topic

Most radios require you to trim the heli out in each mode, so if you have her trimmed out perfect in normal mode then go into idle up and shes no longer in trim, then you will need to keep her in idle up and trim her in that mode or copy the settings into each mode (not all radios can do this) as the only difference is the throttle curve

PM  EMAIL  Attn:RR  Quote
08-11-2007 05:10 PM  10 years agoPost 3
npsk8ter

rrApprentice

Joliet, Illinois USA

My Posts: All  Forum  Topic

thanks a bunch and i guess we learn something new every day! Ive had this radio over 2 years and never knew the trim was seperate between all flight modes. I notice that was the problem watching my main screen when i changed between the 2! I never use trims and thats how i noticed! Thanks again tho!

PM  EMAIL  GALLERY  Attn:RR  Quote
WATCH
 1 page 446 views
Scorpion Power Scorpion Power
HelicopterAlignOther › elevator servo jumps up when switched into idle.
 Print TOPIC  Make Suggestion 

 2  Topic Subscribe

Monday, November 20 - 3:30 pm - Copyright © 2000-2017 RunRyder   EMAILEnable Cookies

Login Here
 New Subscriptions 
 Buddies Online