RunRyder RC
 2  Topic Subscribe
WATCH
 1 page 491 views
Scorpion Power Scorpion Power
HelicopterThunder TigerRAPTOR 50 › Clutch shim broke!
08-07-2007 04:09 AM  10 years agoPost 1
jschenck

rrProfessor

La Vista, NE.

My Posts: All  Forum  Topic

A few months ago the clutch on my Titan started dragging. My cheap fix (cuz I'm cheap) was to gently push the clutch shoes back in. Well that lasted about 2 gallons. The last few tanks it started dragging again until I could not start it. So this time I replaced the clutch. Here's where it get a bit weird - the clutch shim is broken. I think the clutch shoe was grabbing and hanging on the cracked shim! When I first dropped the engine the clutch was dragging in a spare bell I have just like in the heli. After I was done swapping everything out I noticed that the clutch fits properly in the bell now!?

Anyone have this happen before? I think this may have been caused by me installing the shim upside down. thoughts? I really appreciate having the clutch shoe clearance machined into the fan, wish tt did this instead.

PM  EMAIL  GALLERY  Attn:RR  Quote
08-07-2007 11:03 AM  10 years agoPost 2
Peefor

rrVeteran

Norfolk UK

My Posts: All  Forum  Topic

If you look at the holes in the shim, they are offset. With regard to the way the shim has worn would suggest the shim was indeed upside down.

Pete

PM  EMAIL  GALLERY  Attn:RR  Quote
WATCH
 1 page 491 views
Scorpion Power Scorpion Power
HelicopterThunder TigerRAPTOR 50 › Clutch shim broke!
 Print TOPIC  Make Suggestion 

 2  Topic Subscribe

Friday, November 24 - 2:56 pm - Copyright © 2000-2017 RunRyder   EMAILEnable Cookies

Login Here
 New Subscriptions 
 Buddies Online